/usr/lib32/libGL.so.1 prevents Doom 3 from starting

Bug #851947 reported by Dmitry Pankratov
76
This bug affects 37 people
Affects Status Importance Assigned to Milestone
ia32-libs (Ubuntu)
Fix Released
High
Scott Ritchie
Oneiric
Fix Released
High
Scott Ritchie
nvidia-graphics-drivers (Ubuntu)
Invalid
Undecided
Unassigned
Oneiric
Invalid
Undecided
Unassigned

Bug Description

Ubuntu 11.10 AMD64.

After updating to the latest ia32-libs (version 20090808ubuntu22) doom3 executable does not start properly.
Error message is: Couldn't get a visual.

I have tracked it down to /usr/lib32/libGL.so.1 library which causes this issue. In the previous version if the package this library is absent.

After deleting it and running ldconfig the game runs normally.

Related branches

description: updated
Steve Langasek (vorlon)
Changed in ia32-libs (Ubuntu):
assignee: nobody → Scott Ritchie (scottritchie)
Revision history for this message
Adam Conrad (adconrad) wrote :

Is one of the binary drivers being used here? They used to divert /usr/lib32/libGL.so.1 out of the way to avoid these sorts of issues, but perhaps something regressed along the way.

Revision history for this message
Dmitry Pankratov (dremon) wrote :

Nvidia proprietary driver is actually installed, version 280.13-0ubuntu3.

Revision history for this message
Scott Ritchie (scottritchie) wrote :

Yeah it doesn't look like nvidia does this diversion anymore, perhaps it should.

Revision history for this message
Steve Langasek (vorlon) wrote :

It absolutely should not. The *native* nvidia and mesa drivers cooperate correctly - the newly introduced /usr/lib32/libGL.so.1 does *not* follow the same (carefully designed and tested) method of selecting the GL driver via update-alternatives.

I think you should revert your recent changes to mesa handling in ia32-libs. We are not ever going to have fully working 32-bit support for mesa + nvidia GL via ia32-libs, so we might as well stick with the previous known set of bugs - which also resulted in smaller ia32-libs package anyway.

Changed in nvidia-graphics-drivers (Ubuntu):
status: New → Invalid
Revision history for this message
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in ia32-libs (Ubuntu):
status: New → Confirmed
Revision history for this message
Scott Ritchie (scottritchie) wrote :

Do you think the existing libgl.so symlink that was there should be removed as well?

Revision history for this message
Steve Langasek (vorlon) wrote : Re: [Bug 851947] Re: /usr/lib32/libGL.so.1 prevents Doom 3 from starting

On Fri, Sep 16, 2011 at 10:30:55PM -0000, Scott Ritchie wrote:
> Do you think the existing libgl.so symlink that was there should be
> removed as well?

I think restoring the previous behavior is the best option at this point.

--
Steve Langasek Give me a lever long enough and a Free OS
Debian Developer to set it on, and I can move the world.
Ubuntu Developer http://www.debian.org/
<email address hidden> <email address hidden>

Steve Langasek (vorlon)
Changed in ia32-libs (Ubuntu):
importance: Undecided → High
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ia32-libs - 20090808ubuntu24

---------------
ia32-libs (20090808ubuntu24) oneiric; urgency=low

  * Remove libllvm2.9 and DRI driver manual symlinks (LP: #851947)
  * Freshen packages
 -- Scott Ritchie <email address hidden> Wed, 28 Sep 2011 17:37:52 -0700

Changed in ia32-libs (Ubuntu Oneiric):
status: Confirmed → Fix Released
Revision history for this message
Robert Hooker (sarvatt) wrote :

Now we have no 32 bit accelerated GL for anyone except the ones using proprietary drivers. Is there no chance we could add multiarch libpciaccess so libgl1-mesa-dri:i386 is installable?

Revision history for this message
Steve Langasek (vorlon) wrote :

On Fri, Sep 30, 2011 at 02:38:04AM -0000, Robert Hooker wrote:
> Now we have no 32 bit accelerated GL for anyone except the ones using
> proprietary drivers.

LD_LIBRARY_PATH=/usr/lib32/mesa ?

> Is there no chance we could add multiarch libpciaccess so
> libgl1-mesa-dri:i386 is installable?

I don't think that can be justified as a freeze exception - given that this
is a problem that's been around for more than a full release cycle already.

--
Steve Langasek Give me a lever long enough and a Free OS
Debian Developer to set it on, and I can move the world.
Ubuntu Developer http://www.debian.org/
<email address hidden> <email address hidden>

Revision history for this message
Pastor (sinel1980) wrote :

The Bug#852873 (https://bugs.launchpad.net/ubuntu/+source/ia32-libs/+bug/852873) is set to be duplicate of this bug. But the solution written here to delete /usr/lib32/libGL.so.1 results on my Kubuntu x64 with error saying there's not this file when i try to run wine 3d games.
The working solution is from 852873 bug to set LD_LIBRARY_PATH (in my case it is for example command in shell: LD_LIBRARY_PATH=/usr/lib32/nvidia-current wine wow.exe)

Revision history for this message
Dmitry Pankratov (dremon) wrote :

Have you performed "sudo ldconfig" after file deletion?

Revision history for this message
Albert Pool (albertpool) wrote :

I have this issue after uninstalling proprietary drivers. When running with nvidia 280 it's fine.

Revision history for this message
Albert Pool (albertpool) wrote :

Uninstalling nvidia-current breaks this. So I guess the uninstall script of nvidia-current is to blame as well.

To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Duplicates of this bug

Other bug subscribers