Ubuntu

ia32-libs does not install /usr/lib32/libGL.so.1

Reported by Michal Suchanek on 2011-08-04
130
This bug affects 28 people
Affects Status Importance Assigned to Milestone
Wine
Invalid
Undecided
Unassigned
ia32-libs (Ubuntu)
High
Scott Ritchie
Natty
Undecided
Unassigned

Bug Description

Can't run Wine D3D against ia32-libs because the library /usr/lib32/libGL.so.1 is missing.

ia32-libs: /usr/lib32/libGL.so
ia32-libs: /usr/lib32/mesa/libGL.so.1.2
ia32-libs: /usr/lib32/mesa/libGL.so.1

ProblemType: Bug
DistroRelease: Ubuntu 11.10
Package: ia32-libs 20090808ubuntu13
ProcVersionSignature: Ubuntu 3.0.0-5.6-generic 3.0.0-rc7
Uname: Linux 3.0.0-5-generic x86_64
Architecture: amd64
Date: Thu Aug 4 21:36:47 2011
ProcEnviron:
 PATH=(custom, user)
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SourcePackage: ia32-libs
UpgradeStatus: No upgrade log present (probably fresh install)

Related branches

Michal Suchanek (hramrach) wrote :
Changed in ia32-libs (Ubuntu):
status: New → Confirmed

Also,
manually creating the /usr/lib32/libGL.so.1 symlink is not enough here
as several libraries are either missing or not found by ldd, preventing my dri drivers from being loaded:

$ ldd /usr/lib32/dri/r600_dri.so
 ...
 libdricore.so => not found
 libglsl.so => not found
        ...
 libgallium.so => not found
 libLLVM-2.9.so.1 => not found
 ...

libdricore.so, libglsl.so and libgallium.so are installed under /usr/lib32/dri/ but not found
libLLVM-2.9.so.1 is missing

stpg (alexander-fedora) wrote :

Workaround:

$ LD_LIBRARY_PATH=/usr/lib32/dri/ LD_PRELOAD=/usr/lib32/mesa/libGL.so.1 wine thething.exe

Jason Wood (sandain) wrote :

I too am affected by this bug. The workaround suggested by stpg works to an extent, however the software render is used instead of the appropriate hardware driver.

err:winediag:X11DRV_WineGL_InitOpenglInfo The Mesa OpenGL driver is using software rendering, most likely your OpenGL drivers haven't been installed correctly

direct rendering: Yes

OpenGL vendor string: X.Org
OpenGL renderer string: Gallium 0.4 on AMD SUMO
OpenGL version string: 2.1 Mesa 7.11
OpenGL shading language version string: 1.20

falkTX (falk-t-j) wrote :

I'm also affected by this bug.

any 32bit application on my system (which is 64bit) cannot use OpenGL stuff.
This means both Wine, and any other game out there in a 32bit binary

We're getting very close to final oneiric,
please make this medium or urgent

Jason Wood (sandain) wrote :

This is bug has to do with the move to multiarch/eventual removal of this package. The Mesa related libraries in this package should be removed, deferring to multiarch instead. The wine package also needs to update its dependencies to deal with this change.

I am still getting crashes, but I am able to get around this particular problem via:
sudo apt-get install libgl1-mesa-glx:i386 libc6:i386

On Tue, Sep 13, 2011 at 11:23:36PM -0000, Jason Wood wrote:
> This is bug has to do with the move to multiarch/eventual removal of
> this package.

No, it doesn't. This is a longstanding bug in ia32-libs' incorporation of
the mesa libraries that has nothing to do with multiarch.

> The Mesa related libraries in this package should be removed, deferring to
> multiarch instead. The wine package also needs to update its dependencies
> to deal with this change.

This can't happen until all libraries shipped in ia32-libs are converted to
multiarch (which means not until this cycle).

> I am still getting crashes, but I am able to get around this particular
> problem via: sudo apt-get install libgl1-mesa-glx:i386 libc6:i386

Yes, the genuine mesa i386 packages are not affected by this bug.

--
Steve Langasek Give me a lever long enough and a Free OS
Debian Developer to set it on, and I can move the world.
Ubuntu Developer http://www.debian.org/
<email address hidden> <email address hidden>

Jason Wood (sandain) wrote :

Steve Langasek wrote:

>> The Mesa related libraries in this package should be removed, deferring to
>> multiarch instead. The wine package also needs to update its dependencies
>> to deal with this change.
>
>This can't happen until all libraries shipped in ia32-libs are converted to
>multiarch (which means not until this cycle).

I probably don't fully understand the problem here..

Why not just have this package depend on the genuine mesa i386 packages? If having the libraries in /usr/lib32 is important for some reason, why not just have this package install a few symlinks as well?

Steve Langasek (vorlon) wrote :

On Tue, Sep 13, 2011 at 11:52:40PM -0000, Jason Wood wrote:
> Why not just have this package depend on the genuine mesa i386 packages?

Because cross-architecture dependencies on libraries are not supported.

> If having the libraries in /usr/lib32 is important for some reason, why
> not just have this package install a few symlinks as well?

It should do something like this. It doesn't today because no developer has
committed to making the effort to implementing it.

Personally, I'm not going to spend any energy on it; there's enough work to
do just getting rid of ia32-libs.

--
Steve Langasek Give me a lever long enough and a Free OS
Debian Developer to set it on, and I can move the world.
Ubuntu Developer http://www.debian.org/
<email address hidden> <email address hidden>

Scott Ritchie (scottritchie) wrote :

Well I can create the symlinks in ia32-libs, but I'm not 100% sure that's gonna be enough here.

Changed in ia32-libs (Ubuntu):
assignee: nobody → Scott Ritchie (scottritchie)
importance: Undecided → High
Scott Ritchie (scottritchie) wrote :

Adding symlinks seems to have fixed most of them, however r300, r600, and nouveau-dri will require adding libllvm2.9 to ia32-libs.

Changed in ia32-libs (Ubuntu):
status: Confirmed → In Progress
Changed in wine:
status: New → Invalid
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ia32-libs - 20090808ubuntu22

---------------
ia32-libs (20090808ubuntu22) oneiric; urgency=low

  * Create some manual symlinks for DRI drivers (LP: #821100)
    - Also add libllvm2.9
 -- Scott Ritchie <email address hidden> Thu, 15 Sep 2011 16:52:17 -0700

Changed in ia32-libs (Ubuntu):
status: In Progress → Fix Released
Maciek G (maciek-gaszynski) wrote :

Can someone add fix also for Natty?

Alexander Alasjö (alasjo) wrote :

+1 for a Natty fix, or please a hint on which symlinks to create?

Cheers

mokabar (tim-klingt) wrote :

i experience a similar issue with 20090808ubuntu23. maybe there are some libs, which are still missing? installing natty's ia32-libs works fine

Scott Ritchie (scottritchie) wrote :

I reverted the change in Oneiric, but am working on a different solution.

Changed in ia32-libs (Ubuntu):
status: Fix Released → In Progress
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ia32-libs - 20090808ubuntu25

---------------
ia32-libs (20090808ubuntu25) oneiric; urgency=low

  * Create an ia32-libs-multiarch package to depend on i386 versions of
    libraries that were dropped over the last cycle
    - Should ease transitional issues
    - Recommended (but not depended by) ia32-libs
    - Makes it less likely to have no handler for 32 bit (LP: #852101)
  * Libraries for ia32-libs-multiarch are:
    - qt4-x11: libqtcore4, libqtgui4, libqt4-dbus, libqt4-network,
      libqt4-opengl, libqt4-qt3support, libqt4-script, libqt4-scripttools,
      libqt4-sql, libqt4-svg, libqt4-test, libqt4-xml, libqt4-xmlpatterns
    - acl: libacl1
    - attr: libattr1
    - libcupsimage2: libcups2, libcupsimage2
    - curl: libcurl3
    - gdbm: libgdbm3
    - nss: libnss3
    - nspr: libnspr4
    - openssl: libssl1.0.0
    - libxss: libxss1
  * ia32-libs-multiarch also recommends libgl1-mesa-glx (LP: #821100)
  * debian/rules: create special dh_gencontrol for i386 to avoid build failure
  * Readd libqtwebkit4 to ia32-libs
    - while qtwebkit-source was Multi-Arched, it still depends on libgstreamer
      which has not yet been multiarched and resides in ia32-libs
 -- Scott Ritchie <email address hidden> Wed, 28 Sep 2011 23:47:04 -0700

Changed in ia32-libs (Ubuntu):
status: In Progress → Fix Released

Actually I get this bug also on an updated Oneiric. Using the #3 workaround, I get the "software render issue"

Jelle Smedts (smedtsjelle) wrote :

I got it working by running both:

sudo apt-get install --reinstall libc6-i386 (not sure if this one fixed anything)
sudo apt-get install ia32-libs*

now I can run
wine tft.exe -opengl

Chris Halse Rogers (raof) wrote :

Seems like this is also broken in Natty, and would be SRUable.

G4JC (gaming4jc2) wrote :

Another +1 for natty. :)

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in ia32-libs (Ubuntu Natty):
status: New → Confirmed
dino99 (9d9) wrote :
Changed in ia32-libs (Ubuntu Natty):
status: Confirmed → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers