Ubuntu

libSDL_image.1.2.so.0 and libpython2.5.so.1.0 are missing in ia32-libs

Reported by meuns on 2008-10-03
16
This bug affects 2 people
Affects Status Importance Assigned to Milestone
ia32-libs (Ubuntu)
Wishlist
Unassigned

Bug Description

Binary package hint: ia32-libs

Hello,

I would use glGo 1.4.1 on my Hardy (64bit), but this application is compiled for 32bit systems and ia32-libs doesn't provide libSDL_image.1.2.so.0 and libpython2.5.so.1.0.

If I launch the application :
glGo: error while loading shared libraries: libSDL_image-1.2.so.0: cannot open shared object file: No such file or directory

If I list the linked libraries :
linux-gate.so.1 => (0xffffe000)
libsgfparser.so => /usr/lib/games/glGo/libsgfparser.so (0xf7f40000)
libSDL-1.2.so.0 => /usr/lib32/libSDL-1.2.so.0 (0xf7e99000)
libSDL_image-1.2.so.0 => not found
libSDL_ttf-2.0.so.0 => /usr/lib32/libSDL_ttf-2.0.so.0 (0xf7e93000)
libpython2.5.so.1.0 => not found
libGL.so.1 => /usr/lib32/libGL.so.1 (0xf7def000)
libGLU.so.1 => /usr/lib32/libGLU.so.1 (0xf7d6c000)
libgtk-x11-2.0.so.0 => /usr/lib32/libgtk-x11-2.0.so.0 (0xf79f4000)
libgdk-x11-2.0.so.0 => /usr/lib32/libgdk-x11-2.0.so.0 (0xf7970000)
libatk-1.0.so.0 => /usr/lib32/libatk-1.0.so.0 (0xf7956000)
libgdk_pixbuf-2.0.so.0 => /usr/lib32/libgdk_pixbuf-2.0.so.0 (0xf793e000)
libpango-1.0.so.0 => /usr/lib32/libpango-1.0.so.0 (0xf7901000)
libgobject-2.0.so.0 => /usr/lib32/libgobject-2.0.so.0 (0xf78c4000)
libgmodule-2.0.so.0 => /usr/lib32/libgmodule-2.0.so.0 (0xf78c0000)
libgthread-2.0.so.0 => /usr/lib32/libgthread-2.0.so.0 (0xf78bb000)
librt.so.1 => /lib32/librt.so.1 (0xf78b2000)
libglib-2.0.so.0 => /usr/lib32/libglib-2.0.so.0 (0xf7801000)
libXinerama.so.1 => /usr/lib32/libXinerama.so.1 (0xf77fe000)
libSM.so.6 => /usr/lib32/libSM.so.6 (0xf77f5000)
libpng12.so.0 => /usr/lib32/libpng12.so.0 (0xf77d2000)
libjpeg.so.62 => /usr/lib32/libjpeg.so.62 (0xf77b2000)
libtiff.so.4 => /usr/lib32/libtiff.so.4 (0xf775f000)
libexpat.so.1 => /usr/lib32/libexpat.so.1 (0xf773e000)
libz.so.1 => /usr/lib32/libz.so.1 (0xf7729000)
libdl.so.2 => /lib32/libdl.so.2 (0xf7725000)
libstdc++.so.6 => /usr/lib32/libstdc++.so.6 (0xf7631000)
libm.so.6 => /lib32/libm.so.6 (0xf760c000)
libgcc_s.so.1 => /usr/lib32/libgcc_s.so.1 (0xf7601000)
libpthread.so.0 => /lib32/libpthread.so.0 (0xf75e9000)
libc.so.6 => /lib32/libc.so.6 (0xf749a000)
libX11.so.6 => /usr/lib32/libX11.so.6 (0xf73b3000)
libasound.so.2 => /usr/lib32/libasound.so.2 (0xf72ef000)
libdirectfb-1.0.so.0 => /usr/lib32/libdirectfb-1.0.so.0 (0xf728c000)
libfusion-1.0.so.0 => /usr/lib32/libfusion-1.0.so.0 (0xf7284000)
libdirect-1.0.so.0 => /usr/lib32/libdirect-1.0.so.0 (0xf7271000)
libfreetype.so.6 => /usr/lib32/libfreetype.so.6 (0xf7201000)
libGLcore.so.1 => /usr/lib32/libGLcore.so.1 (0xf66eb000)
libnvidia-tls.so.1 => /usr/lib32/tls/libnvidia-tls.so.1 (0xf66e9000)
libXext.so.6 => /usr/lib32/libXext.so.6 (0xf66db000)
libpangocairo-1.0.so.0 => /usr/lib32/libpangocairo-1.0.so.0 (0xf66d2000)
libXcomposite.so.1 => /usr/lib32/libXcomposite.so.1 (0xf66cf000)
libXdamage.so.1 => /usr/lib32/libXdamage.so.1 (0xf66cb000)
libXfixes.so.3 => /usr/lib32/libXfixes.so.3 (0xf66c6000)
libcairo.so.2 => /usr/lib32/libcairo.so.2 (0xf6664000)
libfontconfig.so.1 => /usr/lib32/libfontconfig.so.1 (0xf663a000)
libXrender.so.1 => /usr/lib32/libXrender.so.1 (0xf6632000)
libXi.so.6 => /usr/lib32/libXi.so.6 (0xf6629000)
libXrandr.so.2 => /usr/lib32/libXrandr.so.2 (0xf6623000)
libXcursor.so.1 => /usr/lib32/libXcursor.so.1 (0xf661a000)
libselinux.so.1 => /lib32/libselinux.so.1 (0xf6601000)
/lib/ld-linux.so.2 (0xf7f92000)
libpcre.so.3 => /usr/lib32/libpcre.so.3 (0xf65da000)
libICE.so.6 => /usr/lib32/libICE.so.6 (0xf65c1000)
libxcb-xlib.so.0 => /usr/lib32/libxcb-xlib.so.0 (0xf65bf000)
libxcb.so.1 => /usr/lib32/libxcb.so.1 (0xf65a7000)
libXau.so.6 => /usr/lib32/libXau.so.6 (0xf65a4000)
libpangoft2-1.0.so.0 => /usr/lib32/libpangoft2-1.0.so.0 (0xf657d000)
libpixman-1.so.0 => /usr/lib32/libpixman-1.so.0 (0xf6553000)
libXdmcp.so.6 => /usr/lib32/libXdmcp.so.6 (0xf654e000)

Best regards

Related branches

Daniel T Chen (crimsun) on 2008-11-11
Changed in ia32-libs:
importance: Undecided → Wishlist
meuns (sylvainmeunier26) on 2008-11-11
description: updated

I'm marking this as a dupe of bug #298611.
if this is not correct, please remove the dupe.
Thank

Anders Kaseorg (anders-kaseorg) wrote :

No, libSDL_image and libpython2.5 are different libraries; bug #298611 is about libuuid. These problems will have to be dealt with separately.

C. Cooke (ccooke) wrote :

Confirmed here - just tried to run Dwarf Fortress on a new 64-bit Jaunty Alpha-4.

C. Cooke (ccooke) wrote :

It's an expected lib for most 32-bit games you're likely to run on a 64-bit install - and since many of them are going to be 32-bit for the foreseeable future...

Changed in ia32-libs:
status: New → Confirmed
C. Cooke (ccooke) wrote :

WORKAROUND:

You can work around this by copying a correct 32-bit libSDL_image-1.2.so into /usr/lib32. I've attached the one from current 32-bit Intrepid (I know it works and I don't have spare systems to try with 32-bit Jaunty).

To install this, you need to:

1) Download the attached file to your desktop.
2) sudo cp ~/libSDL_image-1.2.so.0.1.5 /usr/lib32
3) sudo ldconfig

That should fix it for now.

C. Cooke (ccooke) wrote :

Oops. That's what happens when you get distracted by a phone call half-way through a comment.

Let's try this again:

WORKAROUND (that WORKS)

You can work around this by copying the correct 32-bit libs to your /usr/lib32. I've attached the python and libSDL_image libs from 32-bit Intrepid and verified they work with glGo (and a couple of other 32-bit games).

To install, you need to:

1) Download the targalled libs to your Desktop.
2) Open a terminal.
2) cd ~/Desktop
3) sudo tar -C /usr/lib32 -xvjf ia32-missing-libs.tar.bz2
4) sudo ldconfig

That should have it working for you.

meuns (sylvainmeunier26) wrote :

It works ! I will play on IGS with my Ubuntu now.

Thanks

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ia32-libs - 2.7ubuntu4

---------------
ia32-libs (2.7ubuntu4) jaunty; urgency=low

  * fetch-and-build:
    - add libsqlite3-0, needed as a dependency of libnss3-1d (LP: #326311).
    - add libmikmod2 and libsmpeg0 needed as dependencies of libsdl-mixer1.2
      (LP: #154883).
    - add libcanberra-gtk-module and its dependencies (libcanberra-gtk0,
      libcanberra0 and libtdb1)
    - add libsdl-image1.2 and python2.5 (LP: #277454)
    - add missing dependencies:
      - libcelt0 for libjack0
      - libsmbios2 for libhal1
      - libspeexdsp1 and liboil0.3 for libpulsecore9
      - libavahi-common3 and libavahi-client3 for libpulse-browse0
      - libgail18 for libgnomecanvas2-0
    - drop libartsc0, which is now obsolete.
  * debian/rules:
    - automatically create all missing .so symlinks in /lib32 and /usr/lib32 as
      the manual list of links was always out of sync and incomplete
      (LP: #277772, #309841).
  * Freshen packages (as of Jaunty beta1) (LP: #338145, #325098, #337210)

 -- Fabien Tassin <email address hidden> Fri, 20 Mar 2009 23:48:50 +0100

Changed in ia32-libs:
status: Confirmed → Fix Released
Sergik (refill2002) on 2011-12-29
Changed in ia32-libs (Ubuntu):
assignee: nobody → Sergik (refill2002)
Steve Langasek (vorlon) on 2011-12-29
Changed in ia32-libs (Ubuntu):
assignee: Sergik (refill2002) → nobody
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers