Skype doesn't work with Bluetooth headsets on AMD64

Bug #240666 reported by Maik Zumstrull on 2008-06-17
8
Affects Status Importance Assigned to Milestone
Medibuntu
Invalid
Undecided
Unassigned
ia32-libs (Ubuntu)
Wishlist
Scott Ritchie

Bug Description

Skype doesn't work with my Bluetooth headset on AMD64 Hardy. The headset does work in general on that system (tested with other software).

I think the issue is probably that the current bluez-audio stack requires a library (/usr/lib/alsa-lib/libasound_module_pcm_bluetooth.so) to be linked at runtime into any program that uses it, which has no equivalent in /usr/lib32/alsa-lib.

Related branches

Maik Zumstrull (maik-zumstrull) wrote :

I can now confirm that this missing 32-bit library is in fact the problem.

I downloaded bluez-audio_3.26-0ubuntu6_i386.deb and manually extracted the files libasound_module_ctl_bluetooth.so and libasound_module_pcm_bluetooth.so into /usr/lib32/alsa-lib. It works.

Lionel Le Folgoc (mrpouit) wrote :

I don't know if this should be in lib32asound2 or ia32-libs.

Changed in medibuntu:
status: New → Invalid
Daniel T Chen (crimsun) wrote :

There is nothing relevant to lib32asound2 here; ia32-libs needs bluez-alsa added.

Changed in ia32-libs:
importance: Undecided → Wishlist
status: New → Triaged
ozonehole (taibei) wrote :

When I attempt to call a phone with Skype, I get an error message:

"Problem with Audio Playback"

and this on the command line:

ALSA lib pcm_bluetooth.c:1619:(bluetooth_init) BT_GETCAPABILITIES failed : Input/output error(5)

If this is a problem specifically with Skype, they may have fixed it at their end...

This post details some updates for the current dev. version:

"We've completely rewritten the audio library, and have spent considerable effort transforming the existing audio code into a form more suitable for Skype. We've also fixed some compatibility issues with Bluetooth headsets."

http://share.skype.com/sites/linux/2009/01/skype_for_linux_updates.html

David McClosky (dmcc) wrote :

I made a horrible hacky solution since there doesn't seem to be much activity on what seems like a trivial bug:

   http://snappletronics.blogspot.com/2009/05/technical-getting-skype-working-with.html

My hackish package is attached. I'd be happy to contribute to the official ia32-libs package, but couldn't figure out how to get involved. Any tips on that would be appreciated.

Changed in ia32-libs (Ubuntu):
assignee: nobody → Scott Ritchie (scottritchie)
status: Triaged → In Progress
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ia32-libs - 2.7ubuntu11

---------------
ia32-libs (2.7ubuntu11) karmic; urgency=low

  * Add bluez-alsa (LP: #240666)

 -- Scott Ritchie <email address hidden> Tue, 11 Aug 2009 22:34:08 -0700

Changed in ia32-libs (Ubuntu):
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers