missing ia32-libs package on Saucy (13.10)

Bug #1241327 reported by Watcharapol Tadtiang on 2013-10-18
56
This bug affects 13 people
Affects Status Importance Assigned to Milestone
ia32-libs (Ubuntu)
Undecided
Unassigned

Bug Description

missing ia32-libs package on Saucy (13.10)

$ uname -svmrpio
Linux 3.11.0-12-generic #19-Ubuntu SMP Wed Oct 9 16:20:46 UTC 2013 x86_64 x86_64 x86_64 GNU/Linux

$ cat /etc/lsb-release
DISTRIB_ID=Ubuntu
DISTRIB_RELEASE=13.10
DISTRIB_CODENAME=saucy
DISTRIB_DESCRIPTION="Ubuntu 13.10"

$ echo $DESKTOP_SESSION
Lubuntu

$ apt-cache policy ia32-libs
ia32-libs:
  Installed: (none)
  Candidate: (none)
  Version table:

thank you.

tags: added: saucy
Steve Langasek (vorlon) wrote :

No bug here. This package has been removed as obsolete, superseded by multiarch support. You don't need ia32-libs, you just need to install the i386 version of the package you want and it will pull in the correct libraries.

Changed in ia32-libs (Ubuntu):
status: New → Invalid

Thank You, Steve Langasek

Tommy_CZ (t-kijas) wrote :

Ok, you removed it. Then tell me howto install AfterShotPro that demands ia32-libs? Or all of us photographers, that have hard times in Linux are just screwed out because you did not want to have ia32 in repositories? Shall we use Windows or OSX now? And is this what do you want?

Changed in ia32-libs (Ubuntu):
status: Invalid → Confirmed
Steve Langasek (vorlon) wrote :

By installing an i386 package of AfterShotPro instead of an ia32-libs-using monstrosity. Like I already said.

Changed in ia32-libs (Ubuntu):
status: Confirmed → Invalid
Changed in ia32-libs (Ubuntu):
status: Invalid → New
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in ia32-libs (Ubuntu):
status: New → Confirmed
Ma Hsiao-chun (mahsiaochun) wrote :

Second Life Viewer also depends on ia32-libs:
http://community.secondlife.com/t5/Second-Life-Viewer/Ubuntu-13-10-and-the-death-of-ia32-libs/m-p/2269003

And Google Earth:
https://bugs.launchpad.net/ubuntu/+source/googleearth-package/+bug/1220086

The real problem is that some software out there does depend on ia32-libs and may not be updated any time soon (probably never). I believe that at least a dummy package should be there.

Ingram (ingram87) wrote :

This also affects most of the games on playdeb.net for 13.10

Christoph Korn (c-korn) wrote :

@Ingram: Make sure you have the 13.10 repository of playdeb installed.

There is not package which depends on ia32-libs any longer.
They use multiarch now.

Kryztoval (criesca) wrote :

This is a bug,

I just installed Ubuntu-gnome 13.10 and out of the box tried to install vlc, skype and steam from the standard ubuntu repository (saucy one, with no changes) and all complain that there are dependencies that are not installable.

So maybe it is actually not required (ia32-libs) but it surely is still broken.

Yuv (yuv) wrote :

This is another one of these cases where developers do not think of the consequences of their actions on the common user downstream. Sure, Mr. Langasek, ia32-libs is a "monstrosity", but users prefer a monstrosity that works for them to the technically elegant solution that you imposed on them and that only cause them pains.

Software behaviours like this one are difficult for the general public to understand. if it ain't broken, don't fix it. Or for this case: leave these ugly transitional packages in place until the last of the users no longer needs it, even if it means keeping them around for eternity. Better an eternity with ugly transitional packages, than users migrating back to Windows in frustration to software purism.

Specifically in my case, this change motivated my father-in-law to go back to Windows. An upgrade to Saucy and his Canon printer stopped working. Who is at fault for this?

Of course you will point your finger at Canon. My in-law does not care. He needs a working printer and so this Christmas I found that my work weaning him off Windows has been thwarted by this change. Worse: when I tried to get things working again (and I am tenacious and have a little bit of Linux experience under my belt), I wasted four hours, managed to make it work on my laptop, but not on his desktop. Probably because on my laptop there were some i386 libraries installed previously. Go figure which ones.

By leaving us users out in the cold like this, you lose us!

Buck Evan (bukzor) wrote :

@vorlon: The above complaints are all related to painful transition.
This was a transitional package.
Doesn't that indicate that this transitional package was deleted prematurely?

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers