Please patch i810switch to work with i945

Bug #92528 reported by chastell on 2007-03-15
22
Affects Status Importance Assigned to Milestone
i810switch (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: i810switch

Please patch i810switch with the attached patch so it works with the i945 chip found in ThinkPad X60, as the Fn+F7 combination for switching the display doesn’t work in Feisty. The patch was written by Dieter Jurzitza.

chastell (chastell) wrote :

Gaah, sorry, only the i810switch.c part is relevant for Ubuntu. Attaching a trimmed patch.

chastell (chastell) wrote :

I meant i945, sorry.

description: updated
Master Ar2ro (ar2ro) wrote :

Even with this patch the program fails with Segmentation Fault, when I try to run it on my Feisty amd64 machine. I've got an Aristo Slim 430 laptop with i945 chip.

(gdb) bt
#0 0x00002b172fae1483 in ?? () from /lib/libc.so.6
#1 0x00002b172fae526c in free () from /lib/libc.so.6
#2 0x00002b172fad1164 in fclose () from /lib/libc.so.6
#3 0x0000000000401376 in main ()

Blaise Alleyne (balleyne) wrote :

I can confirm that this patch worked on my Thinkpad X60 running Feisty - thanks!

Chris Wagner (chris-wagner) wrote :

@Master Ar2ro - Is it i810switch that is failing (with the seg-fault)? Does it fail even when the patch is *not* applied?

lezem (jhcepas) wrote :

I have the same seg-fault after applying this patch (not before).
I'm using a macbook core2duo.

Chris Wagner (chris-wagner) wrote :

Is anyone else having problems with the patch? It seems to work okay for me. (Well, I have had some problems, but I don't believe they're due to the i810switch.)

@lezem - Which patch are you using? The more recently posted, shorter one? Could you get a detailed backtrace (see https://wiki.ubuntu.com/Backtrace). Thanks.

lezem (jhcepas) wrote :

I'm using the last patch ( the short one ). And I attach the backtrace.

Luca Falavigna (dktrkranz) wrote :

You should inform upstream developers of your efforts, they can help you and eventually include your patch in the next release.

Sam Peterson (peabodyenator) wrote :

Patch worked for me, I'm running a Compaq Presario C571NR. Thanks very much.

unggnu (unggnu) wrote :

I am closing this bug because i810switch has become obsolete with the new Intel driver which is enabled by default since Gutsy. With this driver and xrandr it should be easily possible to change monitor configuration. If it still doesn't work for you please open a new bug against package xserver-xorg-video-intel.

Changed in i810switch:
status: New → Invalid
chastell (chastell) wrote :

There are lots of problems with the Intel driver (which I’ll report as bugs against xserver-xorg-video-intel at my earliest free time, of course; unfortunately it’s really time-consuming) – like unusably slow Compiz performance and really low signal strength which makes the screen ‘shiver’ – which make me revert to the i810 driver every time I try to ‘upgrade’.

I won’t reopen this bug as I understand your decision, although I find it trivial to apply this four-line patch to the i810switch sources (and it’d be nice if it was applied ‘upstream’, instead of having to rebuild the package myself).

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers