Sync i2p 0.9.35-1 (universe) from Debian unstable (main)

Bug #1785125 reported by Masayuki Hatta
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
i2p (Ubuntu)
Undecided
Unassigned

Bug Description

Please sync i2p 0.9.35-1 (universe) from Debian unstable (main)

Explanation of the Ubuntu delta and why it can be dropped:
  * Revert the last change.
  * Build using the default-jdk package (currently OpenJDK 10), dropping references
    to the OpenJDK 9 packages.
  * Revert the last change.
  * Build using the default-jdk package (currently OpenJDK 10), dropping references
    to the OpenJDK 9 packages.
  * Fix build by enforcing JAVA_HOME to java9 location

  Those Ubuntu changes have been incorporated into 0.9.35-1.

Changelog entries since current cosmic version 0.9.34-1ubuntu3:

i2p (0.9.35-1) unstable; urgency=medium

  * New upstream release.
  * i2p should depend on apparmor - closes: #902426

 -- Masayuki Hatta <email address hidden> Wed, 25 Jul 2018 14:54:05 +0900

i2p (0.9.34-2) unstable; urgency=medium

  * Bumped Standards-Version to 4.1.4.
  * Built with OpenJDK 10, default-jdk for the current
    Debian sid - closes: #897322

 -- Masayuki Hatta <email address hidden> Fri, 22 Jun 2018 16:49:49 +0900

tags: added: upgrade-software-version
Revision history for this message
Jeremy Bicha (jbicha) wrote :

This bug was fixed in the package i2p - 0.9.35-2
Sponsored for Hans Joachim Desserud (hjd)

---------------
i2p (0.9.35-2) unstable; urgency=medium

  * d/control: Bumped Standards-Version to 4.1.5.
  * d/control: Now Build-Depends on default-jdk.
  * d/control: i2p-router now depends on sensible-utils.
  * d/control: i2p-router now depends on openjdk 8, 10(default for sid) & 11.

 -- Masayuki Hatta <email address hidden> Fri, 03 Aug 2018 09:21:32 -0700

i2p (0.9.35-1) unstable; urgency=medium

  * New upstream release.
  * i2p should depend on apparmor - closes: #902426

 -- Masayuki Hatta <email address hidden> Wed, 25 Jul 2018 14:54:05 +0900

i2p (0.9.34-2) unstable; urgency=medium

  * Bumped Standards-Version to 4.1.4.
  * Built with OpenJDK 10, default-jdk for the current
    Debian sid - closes: #897322

 -- Masayuki Hatta <email address hidden> Fri, 22 Jun 2018 16:49:49 +0900

Changed in i2p (Ubuntu):
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers