Ubuntu

Sync hylafax 2:6.0.4-10 (universe) from Debian unstable (main)

Reported by tildar on 2010-05-14
56
This bug affects 10 people
Affects Status Importance Assigned to Milestone
Gentoo Linux
Won't Fix
Medium
hylafax (Ubuntu)
Low
Unassigned
Declined for Lucid by Sebastien Bacher
Declined for Maverick by Sebastien Bacher

Bug Description

I believe this might be due to recent ghostscript update.

ii hylafax-client 2:6.0.3-5.1ubuntu1 Flexible client/server fax software - client
ii hylafax-server 2:6.0.3-5.1ubuntu1 Flexible client/server fax software - server
ii ghostscript 8.71.dfsg.1-0ubuntu5.1 The GPL Ghostscript PostScript/PDF interpret
ii ghostscript-cups 8.71.dfsg.1-0ubuntu5.1 The GPL Ghostscript PostScript/PDF interpret
ii ghostscript-x 8.71.dfsg.1-0ubuntu5.1 The GPL Ghostscript PostScript/PDF interpret

same or simular problem reported here: https://bugzilla.redhat.com/show_bug.cgi?id=569957

Please advise on any additional debugging that I can provide.

Related branches

tildar (tildar) wrote :

ok, this is due to a change in ghostscript.

The default MaxStripSize had changed from 0 in ghostscirpt-8.70 to 8192 in ghostscript-8.71

I'm testing to see if adding -dMaxStripSize=0 to bin/ps2fax.gs and bin/pdf2fax.gs changes anything for me.

tildar (tildar) wrote :

Adding adding -dMaxStripSize=0 to bin/ps2fax.gs and bin/pdf2fax.gs seems to have corrected this issue for me.

Indeed, this does fix the problem of Ubuntu 10.04 LTS hylafax sending blank pages for me.

I modified bin/pdf2fax.gs as described by adding the -dMaxStripSize=0 onto the GS command at the end of the file and that fixed the problem.

As this fix has been around for around a month and seems to be correct it would be great to see it added to the online updates - it does not seem to have much likelihood of breaking anything else so looks like a nice clean fix to roll out.

Patch file is trivial and attached.

Bodo Meissner (bodo-bodo-m) wrote :

A similar fix must be added to pdf2fax.

Giuseppe Sacco (eppesuig) wrote :

From what I understand from https://bugzilla.redhat.com/show_bug.cgi?id=571520 it seems the problem is in ghostscript and has been fixed upstream.
I would suggest uploading a new ghostscript package instead of a new hylafax package.

Bodo Meissner (bodo-bodo-m) wrote :

Giuseppe Sacco wrote:
> it seems the problem is in ghostscript and has been fixed upstream.

That's a matter of opinion.

HylaFAX relies on Ghostscript having a default MaxStripSize that is large enough. The default that used to be 0 (unlimited) was changed to a small value that broke HylaFAX. In a recent version the default has been changed again to a value that seems to be big enough. Who knows what might get changed in future versions of Ghostscript.

I think it's a good idea to make HylaFAX more robust by explicitly specifying parameters for Ghostscript and maybe checking the resulting TIFF file.

In the HylaFAX mailing list a message was posted with a link to a version that checks the TIFF file created by Ghostscript and modifies it if necessary. IIRC this patch is included in HylaFAX+. The scripts in HylaFAX+ may be different from HylaFAX, but it should be possible to copy the mechanism to appropriate places in HylaFAX.

Bodo

tags: added: patch

Solved the problem for me, thanks.

tildar (tildar) wrote :

I would have to agree with Bodo Meissner's point about explicitly specifying parameters, especially if default setting keep changing around thus breaking things, then fixing, then braking.....

I would even go so far as to ask why we do not have HylaFAX+ packaged as an optional replacement? or even just drop the org version and go to hylafax+ instead!

It seems that every time I have a problem with hylafax, it has already been fixed in hylafax+., or was never a problem to begin with.

Changed in hylafax (Ubuntu):
status: New → Confirmed
assignee: nobody → Giuseppe Sacco (giuseppe-eppesuigoccas)
Giuseppe Sacco (eppesuig) wrote :

I am uploading hylafax 6.0.4-10 to Debian. This package include the supplied patch and should hopefully fix the problem. Please let me know if anything is still broken.

Bye,
Giuseppe

Changed in hylafax (Ubuntu):
status: Confirmed → Fix Committed
Sebastien Bacher (seb128) wrote :

subscribing sponsors to review the sync request

Changed in hylafax (Ubuntu):
importance: Undecided → Low
status: Fix Committed → Triaged

This is a bug already discovered in Ubuntu (see URL). Ghostscript changed processing defaults so ps2fax and pdf2fax (etc) cannot generate a valid TIFF. The result is that the fax recipient only gets an empty page. The fix described there (MaxStripSize=0) resolves the issue.

Involved versions:
net-misc/hylafax-6.0.3
app-text/ghostscript-gpl-8.71-r1

I propose to use the MaxStripSize=0 approach in HylaFax to make it more robust to ghostscript upstream changes.

Reproducible: Always

Changed in gentoo:
status: Unknown → Confirmed

You may get Debian patches from http://patch-tracker.debian.org/package/hylafax/2:6.0.4-10 . It is the one called 808_ghostscript_args.patch and keep two corrections: the one you already proposed in this report, and adding '-P' that seems to be required with '-dSAFER=true'

summary: - Hylafax is sending blank pages.
+ Sync hylafax 2:6.0.4-10 (universe) from Debian unstable (main)
Changed in hylafax (Ubuntu):
assignee: Giuseppe Sacco (giuseppe-eppesuigoccas) → nobody
assignee: nobody → Stefano Rivera (stefanor)
status: Triaged → In Progress
Stefano Rivera (stefanor) wrote :

Guiseppe: hylafax currently ftbfs http://udd.debian.org/cgi-bin/ubuntu_ftbfs.cgi

I had to modify the configure script to add __THROW.

Changed in hylafax (Ubuntu):
assignee: Stefano Rivera (stefanor) → nobody
status: In Progress → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package hylafax - 2:6.0.4-10ubuntu1

---------------
hylafax (2:6.0.4-10ubuntu1) maverick; urgency=low

  * Sync from Debian unstable (LP: #580568)
  * Add 901_fchmod-prototype.patch: glibc now includes an fchmod prototype
    which doesn't match hylafax's.

hylafax (2:6.0.4-10) unstable; urgency=low

  * Check for upstart scripts in /etc/init instead of /etc/event.d.
  * Added -dMaxStripSize=0 to all ghostscript invokation. (See
    https://bugzilla.redhat.com/show_bug.cgi?id=569957)

hylafax (2:6.0.4-9) unstable; urgency=low

  * Fixed a problem with faxadduser/faxdeluser overwriting hosts.hfaxd file.
  * Updated to Debian Policy 3.9.1 (no changes required).
  * Added a NEWS about faxmail behaviour changed since hylafax 4.
  * Added an example on how to make exim4 deliver email to faxmail.
 -- Stefano Rivera <email address hidden> Sun, 05 Sep 2010 23:23:42 +0200

Changed in hylafax (Ubuntu):
status: Fix Committed → Fix Released
Giuseppe Sacco (eppesuig) wrote :

Thanks,
I am going to report this upstream.

Giuseppe Sacco (eppesuig) wrote :

Hi, before reporting it, I better checked all bug reports. This problem has already been reported both against Debian package and against Hylafax upstream developers. The latest statement from upstream is that it is probably a bug in latest gcc. Are you telling me that Ubuntu gcc-4.4_4.4.4-13ubuntu2 include patches from gcc 4.5?

More info:
http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=565001
http://bugs.hylafax.org/show_bug.cgi?id=924

Stefano Rivera (stefanor) wrote :

> I better checked all bug reports.

Thanks, I didn't see that one when I skimmed the reports in Debian, and I didn't look ino what was causing configure to misdetect this prototype.

> Are you telling me that Ubuntu gcc-4.4_4.4.4-13ubuntu2 include patches from gcc 4.5?

Yes, according to the changelog it's "built from VCS".

Looks like this is our culprit: http://gcc.gnu.org/bugzilla/show_bug.cgi?id=15638

Changed in gentoo:
importance: Unknown → Medium

Closing as WONTFIX because hylafax was removed from Portage. But adding 361187 to Blocks: -line since this bug should get fixed if introduced back to Portage.

Changed in gentoo:
status: Confirmed → Won't Fix
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.