Ubuntu

Translation template unavailable, even though hwtest is in main

Reported by Tomasz Dominikowski on 2008-03-15
4
Affects Status Importance Assigned to Milestone
Checkbox (Legacy)
Undecided
Unassigned
Launchpad itself
Undecided
Unassigned
hwtest (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: hwtest

https://translations.launchpad.net/ubuntu/hardy/+source/hwtest

A translation template should be available for this application.

Timo Jyrinki (timo-jyrinki) wrote :

Confirming. This should be fixed very, very quickly in order to have the application translated to Ubuntu 8.04. Additionally, the .desktop entry lacks the Ubuntu-specific tag to allow it translated, it should be fixed too.

Changed in hwtest:
status: New → Confirmed

It will have to be rebuilt for Launchpad to get translatable templates.

Timo Jyrinki (timo-jyrinki) wrote :

By the way, there is existing (old) translation template hwdb-client with probably most of the strings translated:
https://translations.launchpad.net/ubuntu/hardy/+source/hwdb-client/+pots/hwdb-client

Timo Jyrinki (timo-jyrinki) wrote :

Adding also the main hwtest project. It looks like dholbach would have added the i18n support in January in his branch, but it was probably never merged? https://code.launchpad.net/~dholbach/hwtest/packaging-fixes

Changed in hwtest:
status: New → Confirmed
Timo Jyrinki (timo-jyrinki) wrote :

Looks like the branch was merged, but the hwtest is not translatable in Rosetta nevertheless. So, as Danilo says, at least a rebuild is needed.

Timo Jyrinki (timo-jyrinki) wrote :

Ok, Martin Pitt uploaded a no-change upload of the 0.1ubuntu6 (now 0.1ubuntu7) to get the translation template imported into Rosetta. So far at least the template is empty, even though it is there. And even if it wasn't empty it would lack the .desktop translation possibility we just added to the hwtest trunk.

Could a new release from the trunk be made soonish? With the fixes it has, it would hopefully solve this bug finally properly. Before doing that, however, bug 202235 should probably be fixed about the relocation of Hardware Testing from Applications -> System Tools to most probably System -> Administration (unless something else has been discussed).

David Murphy (schwuk) wrote :

I got Martin to re-upload the template so we could proceed with the rest of the fixes and push for a new release, then a call for translators. I aim to address several bugs including 202235 before that release though.

Marc Tardif (cr3) wrote :

I have extended the i18n support in hwtest to include the suites files, those which contain test descriptions. Before, translations were maintained rfc822deb old-style where each translation resided in the file itself. Now, the descriptions of the tests are identified with underscores in the suites files so that intltool-merge can generate the corresponding pot file.

So, now that translations for the tests are maintained centrally in the pot file, I have taken this opportunity to refresh the import of translations:

  https://translations.edge.launchpad.net/hwtest/trunk/+imports

Not sure how we can help here. If a template needs to be uploaded, feel free to do it. For Ubuntu packages and their automatic template uploads, a package needs to be rebuilt. If approval is needed, point Arne at it for speedier results. For upstream products, just upload a template and ask us to approve it (again, for faster response: it will be handled in a week or so anyway).

Changed in rosetta:
status: New → Invalid
Timo Jyrinki (timo-jyrinki) wrote :

This was fixed meanwhile regarding hwtest.

Changed in checkbox:
status: Confirmed → Fix Released
Changed in hwtest:
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers