driver-inject-disk: in target debs are installed before kernel has been

Bug #1216043 reported by Dimitri John Ledkov on 2013-08-23
12
This bug affects 2 people
Affects Status Importance Assigned to Milestone
hw-detect (Ubuntu)
High
Dimitri John Ledkov
Precise
Undecided
Unassigned
Saucy
High
Dimitri John Ledkov

Bug Description

Driver-inject-disk copies the debs in a well known location, and later installs them in-target.

At the moment this is done during post-base-installer.d/* time, which is just before the kernel is installed in-target.

Thus if a deb has dependencies on the correct linux-image-3.x.y-WW-generic, it will fail to install & configure at that time.

A better time to install driver-injection-disk debs would be at pre-pkgse.d/* time, since that is after the kernel has been installed but before initramfs has been updated in-target.

I'll propose such a change, but it is probably worth testing with pre-existing driver-injection-disks.

Related branches

Changed in hw-detect (Ubuntu):
status: New → Confirmed
importance: Undecided → High
assignee: nobody → Dmitrijs Ledkovs (xnox)
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in hw-detect (Ubuntu Precise):
status: New → Confirmed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package hw-detect - 1.95ubuntu1

---------------
hw-detect (1.95ubuntu1) saucy; urgency=low

  [ Colin Watson ]
  * Resynchronise with Debian. Remaining changes:
    - Remove FireWire Ethernet support.
    - Register lp module on i386 and amd64.
    - Exit zero if you continue all the way through ethdetect's errors about
      having no network interfaces.
    - Register rtc module on amd64.
    - Drop priorities of a couple of ethdetect questions to medium.
    - disk-detect.sh: Do not check the kernel command line for any option
      to enable dmraid support. If functional dmraid arrays are found, the
      user will be asked if they wish to activate them.
    - Make dmraid logging a bit neater.
    - 'dmraid -c -s' changed its output format; cope with both old and new.
    - Remove dm-emc from the multipath modules, since it's gone since
      2.6.27.
    - Improve checks for dm-* drivers being present to avoid relying on them
      being built as modules.
    - Offer iSCSI targets for preseeding if partman-iscsi is available and
      no disk devices are found.
    - Stop installing acpi, acpid, and acpi-support-base if acpi is
      available.
    - Add an 'archdetect-deb' package, containing /usr/bin/archdetect. Add
      an archdetect(1) manual page.
    - Refer to /usr/share/common-licenses/GPL-2 in debian/copyright.
    - Load xenbus_probe_frontend if we're running under the Xen hypervisor.
    - Redirect update-dev output to /dev/null, as it is in principle
      possible for it to write to stdout and that would interfere with
      debconf.
  * Drop changes for PS3 and Cell, since we haven't been able to support
    these platforms for some time.

  [ Dmitrijs Ledkovs ]
  * Move firmware/injected drivers' .deb packages installation from
    post-base-installer.d stage to pre-pkgsel.d stage. (LP: #1209287, LP:
    #1216043)
  * Bump question to load driver injection disk from medium to high, and
    raise driver-injection-disk package priority to standard. Thus the
    udeb will be loaded by default, but before installing any debs from
    the OEMDRV a confirmation question will be asked (default true, can be
    pre-seeded)

hw-detect (1.95) unstable; urgency=low

  [ Updated translations ]
  * Tajik (tg.po) by Victor Ibragimov

hw-detect (1.94) unstable; urgency=low

  [ Dmitrijs Ledkovs ]
  * Set debian source format to '3.0 (native)'.
  * Bump debhelper compat level to 9.
  * Set Vcs-* to canonical format.

hw-detect (1.93) unstable; urgency=low

  [ Updated translations ]
  * Croatian (hr.po) by Tomislav Krznar
 -- Dmitrijs Ledkovs <email address hidden> Fri, 04 Oct 2013 10:40:26 +0100

Changed in hw-detect (Ubuntu Saucy):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers