New Libre office icons are used in the launcher but not in Nautilus / Dash search results

Bug #753584 reported by Chris Kenyon on 2011-04-07
26
This bug affects 4 people
Affects Status Importance Assigned to Milestone
Ayatana Design
High
Paul Sladen
Humanity
Wishlist
Vish
One Hundred Papercuts
Wishlist
Vish
humanity-icon-theme (Ubuntu)
Low
Unassigned
oxygen-icons (Ubuntu)
Undecided
Unassigned

Bug Description

Suspect that this is a bug with the Ambiance theme.

The new Libre Office icons are great - Blue for docs, Green for spread sheets and Red for presentations. These icons are clean and reflect the document type colour coding standards that users expect (Google and MSFT both do the same here.)

When you see files in Nautilus OR the dash, the icons used to represent files pick up the old, frankly unattractive and unclear icons from open office.

Getting the Libre Off icons to be used by Nautilus is a quick but very large usability and aesthetic win.

ProblemType: Bug
DistroRelease: Ubuntu 11.04
Package: libreoffice-core 1:3.3.2-1ubuntu2
ProcVersionSignature: Ubuntu 2.6.38-8.41-generic 2.6.38.2
Uname: Linux 2.6.38-8-generic i686
Architecture: i386
Date: Thu Apr 7 14:47:01 2011
InstallationMedia: Ubuntu 10.04 LTS "Lucid Lynx" - Release i386 (20100429)
ProcEnviron:
 LANGUAGE=en_GB:en
 LANG=en_GB.UTF-8
 SHELL=/bin/bash
SourcePackage: libreoffice
UpgradeStatus: Upgraded to natty on 2011-04-01 (6 days ago)

Chris Kenyon (chriskenyon) wrote :
description: updated

Ubuntu uses Humanity icons since Karmic

affects: human-icon-theme → humanity
affects: ubuntu → humanity-icon-theme (Ubuntu)

Proposed for hundrepapercuts because it's an easy-to-fix usability issue

Actually, the icons used in Dash and Nautilus shouldn't be not from OpenOffice.org, they're from Humanity set. Could you please provide a screenshot of the issue?

Adding oxygen-icons for Kubuntu.

The icons used for file types outside LibreOffice are not bound to its branding because OpenDocument is not related to LibreOffice, it's a completely independent standard. So we can't change them to LibreOffice ones, but we still can do two things to make the experience more consistent:
A) Add data-type-based color distinction to Humanity icons
B) Make LibreOffice use Humanity icons
Please provide a screenshot so we can have a deeper understanding of the issue.

Currently there's no presentation icon in Humanity (except PowePoint), so I'm working on one.

Vish (vish) wrote :

Waiting for screenshots to know exactly what this bug is about.

Changed in humanity-icon-theme (Ubuntu):
status: New → Incomplete
Changed in hundredpapercuts:
status: New → Incomplete
Changed in humanity-icon-theme (Ubuntu):
importance: Undecided → Wishlist
Changed in hundredpapercuts:
importance: Undecided → Wishlist
Changed in humanity:
importance: Undecided → Wishlist
status: New → Incomplete

subscribing Christoph Noack of LibreOffice UX fame.
@Christoph Noack: Please clarify if you would oppose usage of the LO icons for ODF in general.

Also note that the humanity theme used in LO uses the excellent LO icons, so for consistency alone it would make a lot of sense to use them on the desktop too.

Vish (vish) wrote :

The problem here is that these icon names are generic icon names:
../application-vnd.oasis.opendocument.database.png
../application-vnd.oasis.opendocument.drawing.png
../application-vnd.oasis.opendocument.drawing-template.png
../application-vnd.oasis.opendocument.formula.png
../application-vnd.oasis.opendocument.master-document.png
../application-vnd.oasis.opendocument.presentation.png
../application-vnd.oasis.opendocument.presentation-template.png
../application-vnd.oasis.opendocument.spreadsheet.png
../application-vnd.oasis.opendocument.spreadsheet-template.png
../application-vnd.oasis.opendocument.text.png
../application-vnd.oasis.opendocument.text-template.png
../application-vnd.oasis.opendocument.web-template.png

And even if we remove these icons in Humanity, gnome-icon-theme (the first fallback icon theme, hicolor icons are second fallback) icons will be used.

So, the only way to "fix" this issue is, we have to copy LibO hicolor icons into Humanity.

Now we have a few concerns,
1: The default LibO mime icons are a completely different color palate from Humanity. Is the Canonical Design team OK with this? (We need an ACK from them as well.)
2: If they are OK, then we need permission from LibO icon authors to be able to copy them into Humanity.
3: If 1 and 2 is done, and if we want to get this into Ubuntu 11.04, we need to get a UIFe (https://wiki.ubuntu.com/FreezeExceptionProcess#UserInterfaceFreeze%20Exceptions). We are way past UIF for Natty.

Vish (vish) wrote :

(2) is not necessarily contacting authors, we need to check the Copyright license the LibO icons are published, and if we are allowed to copy them to other icon themes.

Jonathan Thomas (echidnaman) wrote :

Oxygen's icons integrate well with KDE, and this is not going to change.

Changed in oxygen-icons (Ubuntu):
status: New → Invalid

Björn Michaelsen, could you provide a screenshot of humanity icons used in LibO?

The humanity theme in LibreOffice had to replace the document icons in them because they contained OpenOffice.org branding, which is clearly unwanted.

I attached a screenshot of the startcenter of LibreOffice-3.3.2-1ubuntu2 with the Humanity theme.

Vish (vish) wrote :

@Chris Kenyon : Still waiting for your screenshot of the problem.
If this aint the bug we think it is, we could move this discussion to a different bug.

I wonder if it's the Humanity theme I'm thinking of... the "open" icon is clearly not from the one based on Elementary.

It is. LibreOffice has updated a lot of artwork themselves, thus the theme would need an update to fix in again. Feel free to contribute.
Note also that this is not an easy task as LibreOffice branding is cold White-Green with high contrast, while Humanity is warm colors with low contrast.

A second attachment showing writer and a the basic editor with the same theme. Clearly Humanity themed.

Vish (vish) wrote :

Shnatsel, thats from Galaxy. Björn's screenshot is about icons *in* the LibO package, that icon package has however been wrongly named Human, instead of Humanity.

Which is why this bug got confusing about what it really is about, while the original bug report says "icons from open office." o.0

OK. As far as I can see we have branding vs humanity conflict here. Open/Libre Office always was poorly integrated...
Vish, I'll have a look at the theme, maybe I'll fix some minor but annoying stuff.

Hey, I was wrong and the original reporter was right. Check out all those ooo-* icons in Humanity.

Larry Tate (cathect) wrote :

I'm having this problem. No matter what "theme" I use, I can't get the Libreoffice icons to represent my documents. The new icons ARE functional in the application menu, however.

I'm attaching a screenshot of how my icons look.

Chris Kenyon (chriskenyon) wrote :

Screenshot attached.

Chris Kenyon (chriskenyon) wrote :

@Sergey & @ Vish - Apologies for radio silence screengrab uploaded. Let me know if you have any further questions.

Hi all, sorry for the late reply - had a few days vacation.

A short disclaimer before I reply to individual comments: At the moment, there is no official ODF icon set being shared by multiple applications / desktops. So we've created icons that contain vendor neutral application symbolism (like text lines, spreadsheet grid, ... within the document icon). In special cases (e.g. Tango icons in the UI) we've adapted the colors / shadings slightly according the target color palette.

@ Björn (comment #12):
> Christoph Noack: Please clarify if you would oppose usage of the LO icons for ODF in general.
From my POV, they can be used to represent these document types (and personally, I would be more than happy). So if LibreOffice is the preferred application to handle ODF within Ubuntu, this surely would be helpful for users.

@ Vish (comment #14):
> (2) is not necessarily contacting authors, we need to check the Copyright license the LibO icons are published, and if we are allowed to copy them to other icon themes.
Same license as the source code; the original icons (see comment #18 for link) should be licensed as "CC-by-SA, LGPL 3+, MPL 1.1)". If there are any questions, I can help to clarify that - of course.

@ Sergey (comment #20):
> I wonder if it's the Humanity theme I'm thinking of... the "open" icon is clearly not from the one based on Elementary.
This icon is still based on the previous work by Sun/Oracle (colored version: Galaxy by Sun, derived version: StartCenter specific to match Oracle branding). We didn't update it yet ... sorry :-\

Please tell me if you need further information / support ... Christoph

Chris Kenyon (chriskenyon) wrote :

The design team are a strong +1 on using the more upto date icons rather than the old OO ones.

I spoke with Jason Warner on the desktop team and I believe we will get a UI freeze exception for this.

Let me know what I can do to help here.

Ivanka Majic (ivanka) on 2011-04-12
Changed in ayatana-design:
status: New → Confirmed
importance: Undecided → High
assignee: nobody → Paul Sladen (sladen)
Ivanka Majic (ivanka) on 2011-04-12
tags: added: fitandfinish

All icons outside LibreOffice except presentation and formula are handled by Humanity theme. This icon is shown because it's a fallback icon from Gnome theme or something like that. I'm working on a presentation icon for Humanity at the moment. I made some sketches and presented them to DanRabbit, he picked the best layout and gave me further directions; I expect one or two more such iterations to happen. You can check out my current drafts at http://dl.dropbox.com/u/5279564/presentation-icon.tar.gz

By the way, most icons inside LibO still use the obsolete Human icon theme, so even LibO itself is not consistent (and some of them are simply horrible, just look at the "new document" icon). I've updated/fixed 156 icons and proposed them for inclusion as bug #756895, they're uploaded to the upstream git and will land in Oneiric for sure. I'd be very happy to see them included in Natty, it would be awesome if the design team gets a UI freeze exception for this.

I've filed a separate bug #758854 about LibO mime type colors not being used in the rest of the system.

Vish (vish) wrote :

Christoph Noack, thanks for clearing that up about licenses.

Paul, As I'v mentioned in comment#13, I'll be copying over icons from LibO. I'm recoloring their MIME cons ito fit the Humanity theme. It is not too much of a deviation from the default LibO icons.
I'm just making final checks if they need some extra symlinks and stuff. Will be pushing a fix for this by today

Chris Kenyon, Could you take care of the getting UIFe for this?

Changed in hundredpapercuts:
assignee: nobody → Vish (vish)
status: Incomplete → Triaged
importance: Wishlist → Low
Changed in humanity-icon-theme (Ubuntu):
assignee: nobody → Vish (vish)
importance: Wishlist → Low
status: Incomplete → Triaged
Changed in humanity:
assignee: nobody → Vish (vish)
importance: Wishlist → Low
status: Incomplete → Triaged

OMG. Vish, are you sure you want to pull then in Humanity? It seems to me that it's going to break icon consistency completely. Something like the attached sample icons would work better IMHO.

Vish (vish) wrote :

Shnatsel, are you sure you read this bug report? ;-)
That's what folks want here, I've tried to not break the consistency with a few minor tweaks to make them fit in.
However, dont worry about the generic icons you did for the LibO package, we can leave them as generic, since LibO can do both open document and MS documents using either is not good there.

Vish (vish) wrote :

Hmm, I'v just been told that there are only 24hrs more left to get this bug fixed for Natty...
I've pushed the icons and what i think is fine for mentioning LibO icons copyright (pretty sure someone who is more pedantic than me needs to look at getting this right, I'd rather not spend that 24hrs making people wait on me to get it right. ;-) )
I'm not sure if we have the UIFe for this bug already or not.

In short, Icons are ready, anyone interested in getting this into Natty needs to get it there, (nothing is blocking on me).. ;p

FFe rationale: Needed for consistency on desktop. No code changes.

summary: - New Libre office icons are used in the launcher but not in Nautilus /
- Dash search results
+ [FFe] New Libre office icons are used in the launcher but not in
+ Nautilus / Dash search results

@Vish: I think the copyright note is fine as is. As there was no version control when the icons were created, one cant get more specific than "LibreOffice Design Team" or "LibreOffice Contributors".

Scott Kitterman (kitterman) wrote :

What matters for this purpose is the license, not who has the copyright.

@Scott: Well the license is clear -- Christoph Noack has named it and it representing the original authors.

Vish (vish) wrote :

Björn Michaelsen, OK, Cool! Then, it just needs to be released...

(just a reminder for all, the reason we _have_ to copy these icons into Humanity is as I've mentioned in comment#13. And an example is, Chris Kenyon's screenshot, the icon is from first fallback,gnome-icon-theme, since Humanity does not have a presentation icon)

Changed in humanity:
status: Triaged → Fix Committed
Changed in hundredpapercuts:
status: Triaged → Fix Committed
Changed in humanity-icon-theme (Ubuntu):
assignee: Vish (vish) → nobody
Martin Pitt (pitti) wrote :

This is a bug fix, no need for FFE.

summary: - [FFe] New Libre office icons are used in the launcher but not in
- Nautilus / Dash search results
+ New Libre office icons are used in the launcher but not in Nautilus /
+ Dash search results
Chris Kenyon (chriskenyon) wrote :

Am using Beta 2 and the bug is still present.

Vish (vish) wrote :

Chris Kenyon, Launchpad still says bug is triaged.. atleast for me here it is not showing as fix released.. ;-)
You could speed up the process by finding a sponsor who will upload the package for Ubuntu. :-)

Changed in humanity:
importance: Low → Wishlist
Changed in hundredpapercuts:
importance: Low → Wishlist
milestone: none → nt7-potpourri
Paul Sladen (sladen) on 2011-04-15
Changed in humanity-icon-theme (Ubuntu):
milestone: none → ubuntu-11.10
milestone: ubuntu-11.10 → ubuntu-11.04
Changed in ayatana-design:
status: Confirmed → Fix Released
Changed in humanity-icon-theme (Ubuntu):
status: Triaged → Fix Committed
Changed in humanity:
status: Fix Committed → Fix Released

@Chris, Vish: Its uploaded and waiting for approval.

Vish (vish) wrote :

Yup, it's uploaded now , since Paul got annoyed by people asking 'are we there yet' ;)

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package humanity-icon-theme - 0.5.3.10

---------------
humanity-icon-theme (0.5.3.10) natty; urgency=low

  * LibreOffice mime icons; (LP: #753584)
  * debian/copyright: Add LibreOffice to list.
 -- K Vishnoo Charan Reddy <email address hidden> Wed, 13 Apr 2011 01:00:08 +0530

Changed in humanity-icon-theme (Ubuntu):
status: Fix Committed → Fix Released
Martin Pitt (pitti) on 2011-04-18
Changed in hundredpapercuts:
status: Fix Committed → Fix Released
Chris Kenyon (chriskenyon) wrote :

Great work - looks much much better

Sergios (linuxmangr) wrote :

I confirm the bug just for 10.04 not for the 11.04 .
For the Lucid Lynx 10.04 I found the easy way to add all new icons LibreOffice to all files .odt , .ods , .odp and more .
I just download the humanity-icon-theme_0.5.3.10_all.deb for Natty and install it , now not need to remove any files and replaced with new , Icons is just beautiful , nice work !!!

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers