Gnome Bluetooth needs to use different icons for notification area and system menu

Bug #437162 reported by Peng Deng on 2009-09-26
40
This bug affects 7 people
Affects Status Importance Assigned to Milestone
GNOME Bluetooth
Fix Released
Wishlist
gnome-bluetooth (Ubuntu)
Undecided
Unassigned
Nominated for Karmic by Ian Hutchinson
humanity-icon-theme (Ubuntu)
Undecided
Loïc Minier
Nominated for Karmic by Ian Hutchinson

Bug Description

Binary package hint: humanity-icon-theme

The bluetooth applet is a common item appearing in the system tray, so for completeness the icon theme should include a monochrome style icon for it.

ProblemType: Bug
Architecture: i386
Date: Sat Sep 26 14:17:32 2009
DistroRelease: Ubuntu 9.10
Package: humanity-icon-theme 0.3.1-0ubuntu3
PackageArchitecture: all
ProcEnviron:
 LANG=en_US.UTF-8
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 2.6.31-10.35-generic
SourcePackage: humanity-icon-theme
Uname: Linux 2.6.31-10-generic i686

Peng Deng (d6g) wrote :
Vish (vish) on 2009-09-26
Changed in humanity-icon-theme (Ubuntu):
assignee: nobody → mac_v (drkvi-a)
status: New → In Progress
Vish (vish) wrote :

Peng , could you test it with the latest rev if the bluetooth icon works

Changed in humanity-icon-theme (Ubuntu):
status: In Progress → Fix Committed
Peng Deng (d6g) wrote :

I'm at r338, and it seems hasn't fixed the problem, see the screenshot

Peng Deng (d6g) wrote :

Add gnome-bluetooth as affected because it should not use the same icon for representing both the application and the status

Vish (vish) wrote :

I'v for now added a black version on the bluetooth icon ,and this is the best that cna be done for now... because the notification area , wrongly uses the app icon!

This is not an ideal way , as the notification area is a status indicator and the notification area should use an icon from the status folder... a new icon should be defined in the status folder preferably "bluetooth-active" or something likewise.

Changed in humanity-icon-theme (Ubuntu):
status: Fix Committed → Confirmed
Dylan McCall (dylanmccall) wrote :

Bug reported and patch (maybe) submitted upstream. I haven't given it much love, though, so they may hate it :P

https://bugzilla.gnome.org/show_bug.cgi?id=596564

Mat Tomaszewski (mat.t.) wrote :

I suggest using a monochrome "B" symbol without the lozenge, to keep the styling in tune with other indicators.

Peng Deng (d6g) wrote :

when upstream is fixed, i would imagine something like this: (see screenshot)

Mat Tomaszewski (mat.t.) wrote :

@ Peng Deng, I think you got it *almost* pixel perfect :)

Vish (vish) wrote :

Fixed in rev 350, As UX believes that the panel is more visible than the menu.
But ideally we would want to to have color icons in the menu and greyscale icon only in the panel.

So it is better that gnome-bluetooth is patched..

Changed in humanity-icon-theme (Ubuntu):
assignee: mac_v (drkvi-a) → nobody
status: Confirmed → Fix Committed
Vish (vish) wrote :

Upstream might not have the motivation to fix this immediately.
But , If the patch is applied in the ubuntu version , this would be ideal. [since the greyscale icons are used in Ubuntu by default]

When fixed , kindly mention the new labels , so that the icons can be assigned accordingly

Changed in gnome-bluetooth (Ubuntu):
status: New → Confirmed
Loïc Minier (lool) wrote :

Can you provide the bluetooth icons as a patch/pointer to fixed files when ready?

Loïc Minier (lool) wrote :

Sorry, these are already in 0.4.1.

Changed in humanity-icon-theme (Ubuntu):
assignee: nobody → Loïc Minier (lool)
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package humanity-icon-theme - 0.4.1-0ubuntu1

---------------
humanity-icon-theme (0.4.1-0ubuntu1) karmic; urgency=low

  * New upstream release
    - Adds a Humanity-Dark theme and uses darker grey levels for Humanity;
      LP: #436485.
    - Use greyscale icons for everything system related; LP: #430277.
    - Update watch file to use "Humanity" instead of "humanity".
    - Update description to mention Humanity-Dark.
    - Update install file to install Humanity-Dark.
    - Update icon-naming-utils calls to cover both themes.
    - Adds monochrome icon for bluetooth; LP: #437162.
  * Cherry pick fixes from lp:humanity/Humanity{,-Dark}/index.theme@r393,
    fixing various typos spotted during review with a script to generate the
    index instead of updating it manually.
  * Cherry pick new greyscales icons for disabled bluetooth from
    lp:Humanity{,-Dark}/status/24/bluetooth-disabled.svg@r394; LP: #442867.
  * Cherry pick updates to zoom icons, copied from
    lp:humanity/Humanity/actions/*/zoom-*.svg@r395.

 -- Loic Minier <email address hidden> Fri, 02 Oct 2009 23:28:22 +0200

Changed in humanity-icon-theme (Ubuntu):
status: Fix Committed → Fix Released
Vish (vish) on 2009-10-06
Changed in gnome-bluetooth:
importance: Undecided → Unknown
status: New → Unknown
Vish (vish) on 2009-10-06
summary: - Missing monochrome icon for bluetooth applet
+ Gnome Bluetooth needs to use different icons for notification area and
+ system menu
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gnome-bluetooth - 2.28.1-0ubuntu2

---------------
gnome-bluetooth (2.28.1-0ubuntu2) karmic; urgency=low

  * fix LP: #437162 - Gnome Bluetooth needs to use different icons for
    notification area and system menu; take notify.c part of bgo:596564
    patch to support special icons for tray; also install all bluetooth.png
    as bluetooth-active.png in binary-post-install/gnome-bluetooth::
    - debian/patches/01-status-icon.patch
  * fix LP: #445422 - topcrash bluetooth-applet crashed with SIGSEGV in
    g_type_instance_get_private(); add improved patch from bgo:598181
    att:145298
    - debian/patches/02-lazy-killswitch-crashes.patch
  * fix memleak surrouding killswitch removal
    - debian/patches/03-fix-killswitch-memleak.patch
  * fix handling of killswitch removal
    - debian/patches/04-fix-yes-no-killswitch-handling.patch
  * fix icon not properly removed from panel after bt device/killswitch
    gets removed
    - debian/patches/05-fix-icon-visibility-for-no-killswitch.patch

 -- Alexander Sack <email address hidden> Wed, 14 Oct 2009 17:00:55 +0200

Changed in gnome-bluetooth (Ubuntu):
status: Confirmed → Fix Released
Changed in gnome-bluetooth:
importance: Unknown → Wishlist
status: Unknown → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.