Wrong size of folder-drag-accept/gnome-fs-directory-accept icon at zoom levels bigger than 100% in Nautilus

Bug #1462346 reported by Jan Rathmann on 2015-06-05
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
humanity-icon-theme (Ubuntu)
Undecided
Lars Karlitski

Bug Description

Hello,

the icon size of the folder-drag-accept/gnome-fs-directory-accept icon in Nautilus is too small when a zoom level bigger than 100% in the icon view is used. This can be reproduced the following way:

- Start Nautilus (or Nemo)
- Open a directory that contains at least one subdirectory plus at least one file (or a second subdirectory)
- Switch to icon view, set a zoom level bigger than 100%
- Try to move a file/directory into another directory
- When the mouse moves over the target directory, it's icon will switch to the folder-drag-accept/gnome-fs-directory-accept icon, but in a version that is no larger than 48x48, even if the zoom level (and thus the icon size) is set greater. I have attached a screenshot that illustrates the problem.

With the Adwaita icon theme the problem does not happen, the icon seems to get the correct size at all zoom levels.

Currently the Humanity icon theme contains (as symlink) a svg file of the responsible folder-drag-accept/gnome-fs-directory-accept icon in the directories Humanity/status/24 and Humanity/48. The dirs for bigger icons (e.g. 128) do not contain that icons, so I assumed it may be a quick fix to symlink them to also to those dirs. But that caused just other problems - now the icons had always the 128x128 size regardless of zoom level and was often too big instead of too small!

A way to fix this seems to be to place png files of the icons in all of the Humanity/status/[icon size]-directories, each png scaled to the appropriate size. That is a bit more hassle but seems to work for the Adwaita theme.

Kind regards,
Jan

ProblemType: Bug
DistroRelease: Ubuntu 15.04
Package: humanity-icon-theme 0.6.8
ProcVersionSignature: Ubuntu 3.19.0-20.20-generic 3.19.8
Uname: Linux 3.19.0-20-generic x86_64
NonfreeKernelModules: nvidia
ApportVersion: 2.17.2-0ubuntu1.1
Architecture: amd64
CurrentDesktop: Unity
Date: Fri Jun 5 10:53:39 2015
InstallationDate: Installed on 2015-04-16 (49 days ago)
InstallationMedia: Ubuntu 15.04 "Vivid Vervet" - Beta amd64 (20150415)
PackageArchitecture: all
SourcePackage: humanity-icon-theme
UpgradeStatus: No upgrade log present (probably fresh install)

Related branches

Jan Rathmann (kaiserclaudius) wrote :
Lars Karlitski (larsu) on 2015-06-29
Changed in humanity-icon-theme (Ubuntu):
assignee: nobody → Lars Uebernickel (larsu)
Lars Karlitski (larsu) on 2015-07-06
Changed in humanity-icon-theme (Ubuntu):
status: New → In Progress
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package humanity-icon-theme - 0.6.9

---------------
humanity-icon-theme (0.6.9) wily; urgency=medium

  * Provide folder-drag-accept in all sizes (lp: #1462346)

 -- Lars Uebernickel <email address hidden> Mon, 06 Jul 2015 17:26:00 +0200

Changed in humanity-icon-theme (Ubuntu):
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers