Restore triangle disclosure widget

Bug #527789 reported by Luca Ferretti on 2010-02-25
38
This bug affects 8 people
Affects Status Importance Assigned to Milestone
Murrine GTK Engine
Fix Released
Medium
human-theme
Undecided
Unassigned
gtk2-engines-murrine (Ubuntu)
Low
Unassigned
human-theme (Ubuntu)
Wishlist
Unassigned
light-themes (Ubuntu)
Wishlist
Unassigned

Bug Description

Binary package hint: human-theme

Disclaimer: I wasn't able to found any commit on human-theme module referring to this.

In Lucid the disclosure widget changed from triangle to button with + o -, depending on current status.

I remember a long discussion in GTK+/GNOME regarding this, and the triangles was chosen due to their ability to suggest the users how they are used and to represent the current state. At the contrary, the + & - could carry the ideas of "add" and "remove", leading to misbehaving.

Then, could we please restore triangles?

ProblemType: Bug
Architecture: i386
Date: Thu Feb 25 14:35:36 2010
DistroRelease: Ubuntu 10.04
InstallationMedia: Ubuntu 10.04 "Lucid Lynx" - Alpha i386 (20100113)
Package: human-theme 0.38
PackageArchitecture: all
ProcEnviron:
 LANGUAGE=en_US.utf8
 LANG=en_US.utf8
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 2.6.32-14.20-generic
SourcePackage: human-theme
Uname: Linux 2.6.32-14-generic i686

Luca Ferretti (elle.uca) wrote :
Vish (vish) wrote :

I agree , that this is misleading. Unfortunately, murrine does not have an option to change the +/- .

For the expander , we have to use the clearlooks engine or get a good image and use pixmap

Changed in human-theme (Ubuntu):
importance: Undecided → Low
status: New → Triaged
Luca Ferretti (elle.uca) wrote :

Filed upstream against murrine asking to restore triangle or add option.
https://bugzilla.gnome.org/show_bug.cgi?id=611159

(Was "Also affects project" link the one to add a link to upstream, wasn't it? It seems I can only link stuff on launchpad)

PS Vish, honestly I dislike the idea to use 2 engines for one theme.

Vish (vish) wrote :

@Luca Ferretti : Well, i dont think using two engines is better. But I had this same itch and that was the response Cimi gave me ;)

Vish (vish) wrote :

Ha , just noticed Cimi's comment upstrem ;-)

Luca Ferretti (elle.uca) wrote :

  ## Use triagle style expander instead misleading +/- from latest murrine
  style "expander-fix" = "default"
  {
   engine "clearlooks" {
  }
  }
  class "GtkExpander" style "expander-fix"
  class "GtkTreeView" style "expander-fix"
  class "GtkCTree" style "expander-fix"

This seems to work, while I've tested in Radiance/Ambiance. :)

PS how can you use GTK+ default theme??? maybe `engine "reileight"`??

Vish (vish) on 2010-03-15
Changed in light-themes (Ubuntu):
importance: Undecided → Low
status: New → Triaged
Vish (vish) wrote :

Wishlist , since the current appearance is how the the theme is designed.

Changed in light-themes (Ubuntu):
importance: Low → Wishlist
Changed in human-theme (Ubuntu):
importance: Low → Wishlist

2010/3/15 Vish <email address hidden>:
> Wishlist , since the current appearance is how the the theme is
> designed.

This is how the theme is designed in/for Ubuntu or how the theme is
designed upstream?

Luca Ferretti (elle.uca) wrote :

It seems that the following works too, using default gtk+ theme instead clearlooks

style "expander-fix" = "default" {
   engine "" {}
}

Vish (vish) wrote :

@Milo Casagrande, This is how the light theme is design for Ubuntu.

Changed in gtk2-engines-murrine:
status: Unknown → Confirmed
Changed in gtk2-engines-murrine:
status: Confirmed → Fix Released
Vish (vish) wrote :

This has now been fixed upstream.
Opening Ubuntu task to track the update, once the upstream change lands , the themes can use the new option :
expanderstyle = 0

Changed in gtk2-engines-murrine (Ubuntu):
importance: Undecided → Low
status: New → Fix Committed
Matthew Paul Thomas (mpt) wrote :

Fixed in light-themes 0.1.6.8, Ubuntu Maverick.

Changed in light-themes (Ubuntu):
status: Triaged → Fix Released
Vish (vish) wrote :

This is fixed in murrine with the release of murrine 0.90.3+git20100810-0ubuntu1 in maverick

Changed in gtk2-engines-murrine (Ubuntu):
status: Fix Committed → Fix Released
Vish (vish) wrote :

This was fixed in murrine , no change is needed in human theme for this.

Changed in human-theme (Ubuntu):
status: Triaged → Invalid
Changed in human-theme:
status: New → Invalid
Changed in gtk2-engines-murrine:
importance: Unknown → Medium
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.