Firefox GTKEntry Bug in Human Theme

Bug #452664 reported by James Schriver on 2009-10-16
48
This bug affects 6 people
Affects Status Importance Assigned to Milestone
human-theme
Medium
James Schriver
ubuntustudio-look
Fix Released
Undecided
Conn O Griofa
human-theme (Ubuntu)
Low
James Schriver

Bug Description

Entry border around Firefox can be be fixed with branch.

James Schriver (dashua) wrote :
Changed in human-theme:
assignee: nobody → dashua (dashua)
James Schriver (dashua) wrote :

Fix GtkEntry border w/Gecko

Changed in human-theme:
status: New → Fix Committed
importance: Undecided → Medium
James Schriver (dashua) on 2009-10-20
Changed in human-theme (Ubuntu):
status: New → Confirmed
assignee: nobody → dashua (dashua)
GianZap (gianzap) wrote :

Hi Dashua, I just tried Lucid daily and this bug still affects Human, Human-Clearlooks and Darkroom. They all miss "GtkEntry::honors-transparent-bg-hint = 1". I commented just to say that all three themes are affected. Nice to see this will be fixed! :)

Vish (vish) wrote :

Dashua , could you send the bzr merge request for this ?

Changed in human-theme (Ubuntu):
importance: Undecided → Low
status: Confirmed → In Progress
Conn O Griofa (psyke83) wrote :

Dashua and Vish,

I added Dashua's fix to my branch at: https://code.launchpad.net/~psyke83/human-theme/human-theme
The merge request is at: https://code.launchpad.net/~psyke83/human-theme/human-theme/+merge/18747

I already put in a merge request for my branch, as it contains updates that were supposed to be included in Karmic (from Humanity GTK 1.2), and adds support/documentation of the new Murrine GIT engine options. I've already notified Ken about this, and he's going to take a look and make sure that it's safe to merge, I think.

(Slightly OT: Dashua, when I look at the diff for your merge, it seems that it considers the entire gtkrc file as completely new. Surely that can't be right? Or is that because you didn't create a copy of the original branch first?)

Conn O Griofa (psyke83) wrote :

This also affects the UbuntuStudio theme (in the ubuntustudio-look branch).

I put in a merge request for UbuntuStudio which fixes the problem here: https://code.launchpad.net/~psyke83/ubuntustudio-look/UbuntuStudio/+merge/18821

*However*, this branch also contains visual updates for the UbuntuStudio theme which have not yet been approved. I sent an e-mail to Cory Kontros (I'm not sure if anybody else has taken over responsibility for theming UbuntuStudio in Lucid).

James Schriver (dashua) wrote :

@Conn

I'm sure he will not mind. I was to take the artwork lead for Studio but got tied up with some real like event. I can help prepare murrine updates on all of the Human themes, Dust, etc. Cory is on hiatus but I believe he still reads the mailing list.

Conn O Griofa (psyke83) wrote :

@dashua,

Feel free to prepare the updates on the other Murrine-based themes, but you can skip Human itself and DarkRoom (concerning the latter, I'm also working on a visual update, and I'll be sure to include your GTKEntry fix).

I heard back from Cory - it seems he'll be merging the Studio theme update which includes your fix.

Conn O Griofa (psyke83) on 2010-02-18
Changed in ubuntustudio-look:
status: New → Fix Released
assignee: nobody → Conn O Griofa (psyke83)
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers