iPod icon on Human theme not correct

Bug #43073 reported by Adolfo González Blázquez
14
Affects Status Importance Assigned to Milestone
human-icon-theme (Ubuntu)
Low
Kenneth Wimer

Bug Description

I have an iPod Color 30GB, and the icon displayed on desktop using the Human theme is the default removable media player icon, not the iPod icon.

Using the GNOME icon theme, the iPod icon is ok.

Revision history for this message
Adolfo González Blázquez (infinito) wrote : iPod icons on different themes

This is the iPod icon on different themes

Revision history for this message
Eduardo Silva (jobezone) wrote :
Revision history for this message
Daniel Holbach (dholbach) wrote :

Thanks for your bug report. Human in your icon theme shows an ipod (whatever model it is). What do you suggest? Shipping all kinds of different ipod icons?

Changed in ubuntu-artwork:
assignee: nobody → dholbach
status: Unconfirmed → Needs Info
Revision history for this message
Adriaan Peeters (apeeters) wrote :

It would be nice if the icon reflects the type of iPod that is connected. So an iPod Color has a colored screen icon, the older monochrome have a corresponding screen and the Mini has something like the current iPod icon in the Human theme.

This might be helpful for those happy few with multiple iPods :)

Revision history for this message
Daniel Holbach (dholbach) wrote :

Not sure we get that information from hal at all.

Revision history for this message
Adriaan Peeters (apeeters) wrote :

Apparently not, wishlist bug reported: #47265.

Revision history for this message
André Rüdiger (andreruediger-deactivatedaccount) wrote :

IMO the default should be a generic player like in tango/tangerine. I think that's better than showing an IPod when it's an other device.

Further we could add the functionality of displaying the correct icon for known devices which can be found here: http://webcvs.freedesktop.org/tango/tango-icon-theme-extras/scalable/devices/

libipoddevice (http://cvs.gnome.org/viewcvs/libipoddevice/) should provide the needed functionality to find out, wich model is connected. IIRC banshee is already using it.

Revision history for this message
Daniel Holbach (dholbach) wrote :

Ok, I'm going to reject this bug for now. As long as apps don't make use of that functionality, it's not a icon theme bug.

Changed in ubuntu-artwork:
status: Needs Info → Rejected
Revision history for this message
Adriaan Peeters (apeeters) wrote :

Acoording to bug #47265, the iPod model is now reported by hal.

Changed in ubuntu-artwork:
status: Invalid → New
Changed in ubuntu-artwork:
assignee: dholbach → nobody
Kenneth Wimer (kwwii)
Changed in human-icon-theme (Ubuntu):
assignee: nobody → Kenneth Wimer (kwwii)
Revision history for this message
rusivi2 (rusivi2-deactivatedaccount) wrote :

Thank you for posting this bug.

Does this issue occur in Lucid?

Changed in human-icon-theme (Ubuntu):
status: New → Incomplete
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers