Ubuntu

emblems are too small

Reported by Nicolò Chieffo on 2007-07-15
70
Affects Status Importance Assigned to Milestone
gnome-icon-theme (Ubuntu)
Undecided
Unassigned
human-icon-theme (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: human-icon-theme

human-icon-theme 0.18-1ubuntu1

The file emblems are really too small. I can't even see the difference between "documents" "multimedia" "audio" ecc...
The emblems from other themes (such as tangerine) are bigger. Please change them to be the same size as other themes

Miguel Martinez (el-quark) wrote :

I subscibe the original poster's opinion. Small undistinguishable emblems defeat their point, quickly finding a certain file or folder.

Miguel Martinez (el-quark) wrote :

OK, latest nautilus update in gutsy (1:2.19.91-0ubuntu1) noted in its changelog that emblem size should be correct now. Well, it isn't (at least for the human theme). Before this update, icon themes falling back on the default gnome emblems used to have huge emblems (sized as normal icons), and human emblems were small. Now that gnome emblems are a tad to small (although distinguishable for me), human emblems are so tiny it's a joke. I've attached a screenshot and changed the status to confirmed.

As a side note, using only one base colour for emblems that are also small doesn't help much unless you use emblems only as a generic highlight.

Changed in human-icon-theme:
status: New → Confirmed
Sitsofe Wheeler (sitsofe) wrote :

I've just run into this too (updated Gutsy). An easy way to see the super tiny emblems is to do
mkdir ~/Desktop/tinylock
chmod 444 ~/Desktop/tinylock
and see if you can see the emblem.

a way to fix the tiny emblems is to edit /usr/share/icons/Human/index.theme
and find

[scalable/emblems]
Size=128
Context=Emblems
Type=Scalable
MinSize=32
MaxSize=256

then change Size=128 to Size=24

Dylan McCall (dylanmccall) wrote :

Subscribing to this bug. I'll see if I can submit a patch for Nicolò's change.

This is in need of a fix prior to Gutsy's release. The choice of using all orange for the emblems was risky, but they are still coherent (and quite attractive) when sized reasonably. However, with their current size, they are impossible to tell apart due to all being orange.

Perhaps it is worth noting that some emblems which are not user defined - such as the FTP, Home and USB ones - are sized much more generously, and thus are quite coherent.

the fix suggested by Nicolò Chieffo only works for me if the default size is set to 100%, having it set to 50%, the emblem is still completely unvisible, in feisty it wasn't.

This bug appears with every theme, not just human, so maybe it's related to nautilus...

Simon Booth (sgb-ubuntu) wrote :

Seen here with Gutsy beta, nautilus v. 1:2.20.0-0ubuntu7. Nicolò's workaround works too.

SilverLoz (launchpad-loznet) wrote :

Also in Gutsy RC with all updates (as of today) - Nicolò's workaround still works here.

pt123 (pt123) wrote :

They are in the final Gutsy, and in all themes. Once again what is the point of small emblems.

Is anyone here that is pro small emblems?

If not why isn't it going to be fixed.

Alexander Jones (alex-weej) wrote :

People are more bothered about spinning cubes.

I'd say the real reason it isn't fixed is because Nautilus code is scary.

srynznfyra (srynznfyra) wrote :

Thanks Nicolo, now i have emblems that I can see.

Victor Osadci (victor-os) wrote :

Works for me in Hardy.

Nicolò Chieffo (yelo3) wrote :

this works for me too.

Changed in human-icon-theme:
status: Confirmed → Fix Released
Nicolò Chieffo (yelo3) wrote :

even fixed in the gnome-icon-theme

Changed in gnome-icon-theme:
status: New → Fix Released
chreko (chreko) wrote :

Does not work for me, because I am using Tango, which uses some of the 48x48 emblems from the gnome-icon-theme. Changing the following part of /usr/share/icons/gnome/index.theme will only makes some emblems appears bigger. So should be an other solution!

[48x48/emblems]
#Size = 48
Size=32
Context=Emblems
Type=Fixed

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers