hugin exits when changing photos

Bug #223239 reported by Denis_AeC on 2008-04-27
10
Affects Status Importance Assigned to Milestone
Hugin
Unknown
Unknown
hugin (Ubuntu)
Medium
Unassigned

Bug Description

Hardy RC + updates,

Hugin correctly assembles 2 photos or more. Then I want to assemble other photos in Images tab. I delete previous images, then in this tab (or in Assistant : same behaviour), I click on Add image. I can select images in popup. When I click OK, Hugin window closes.

I can start again Hugin, select the same "new" photos and assemble them. When I want to change to other photos : hugin exits "as usual".

This can be repeated, it's a systematic exit !

Maybe related to this bug or not : sometimes, Hugin exits when starting the assembly, just after having clicked on button.

As an addon to the first post, Hugin accepts to remove a photo and add a new one if no connection point has previously been defined. It seems to exit only if you remove a photo (or more) that has connections to other(s) and when you want to add a new one.

Thanks for the bug report and helping to make Ubuntu better.

When hugin exits (from either scenario) could you look to see if there is a .crash file in the directory /var/crash ? if there is, please double click on it and it will report the crash to launchpad automatically (and come back here and set this bug's status to "invalid" as it is then redundant).

If there is not a .crash file, start hugin from the command line and copy any output to a text file and attach that here.

Also, are you running an up-to-date Hardy (just running a "sudo apt-get dist-upgrade" will bring you to the latest version of Hardy)

Thanks!

Changed in hugin:
status: New → Incomplete

1°) Hardy is uptodate (RC + all updates up to 2 hours ago: but nothing since some days)
2°) Nothing in /var/crash
3°) From Terminal :
denis@pom:~$ hugin
Panorama obj created
Could not load pano13Optimizing Variables
Strategy 1
Average (rms) distance between Controlpoints
after 0 iteration(s): 81.8462717679426 units
...
Optimizing Variables
Strategy 2
Average (rms) distance between Controlpoints
after 0 iteration(s): 5.32771651594207 units
... ...
Strategy 2
Average (rms) distance between Controlpoints
after 3 iteration(s): 5.32181043980409 units

terminate called after throwing an instance of 'std::logic_error'
  what(): basic_string::_S_construct NULL not valid
Abandon

Hope this help !

Thanks for the information. Sent upstream, you can follow the progress and add comments here: http://sourceforge.net/tracker/index.php?func=detail&aid=1954543&group_id=77506&atid=550441

Changed in hugin:
importance: Undecided → Medium
status: Incomplete → Triaged
Motin (motin) wrote :

I can confirm this behavior. It happens anytime that I attempt Save after I have aligned my images!

The terminal output is the same on exit:
terminate called after throwing an instance of 'std::logic_error'
  what(): basic_string::_S_construct NULL not valid

And no crash files are left in /var/crash

I have uploaded my set of pictures together with the .pto-file if anyone wants to confirm this behavior. Steps to reproduce:
1. Open Tokyo Moritower.pto in Hugin
2. Choose Align in the Assistant tab
3. Click "Save" in the toolbar

I had added a lot more keypoints and lines but of course they were lost due to this...
In practice, this bug renders hugin 0.7 beta 4 useless in Hardy...

PS My pictures of Tokyo Moritower Night View are of course uploaded according to a CC Share-alike license type...

Motin (motin) wrote :

I started out from scratch and this time I never ran into this bug. The only difference was that the images were named 1.jpg, 2.jpg before but are now named a.jpg, b.jpg etc.

Not much of a clear advice, but if you are experiencing this problem, try starting out anew I guess...

Jojo (kuzniarpawel) wrote :

Confirmed
I receive this bug always when want to save pto file.

hugin 0.7 beta 4
Linux jojo-desktop 2.6.24-19-server #1 SMP Wed Jun 18 15:18:00 UTC 2008 i686 GNU/Linux

Fabrice Coutadeur (fabricesp) wrote :

Hi,

Can you test with the version in my ppa (http://ppa.launchpad.net/fabricesp/ubuntu) to see if this fixes the issue?

thanks,
Fabrice

Changed in hugin:
status: Triaged → Incomplete

Hello,

I don't know how to proceed ...

If I go to your repository and try to install hugin => error,
hugin-tools needed
when installing hugin-tools => error, hugin-data needed
and no hugin-data in your repository.

Hugin is currently installed as 0.7 beta 4 on Hardy.

Must I proceed through Synaptic and add your repository + update package
list ?

Regards,

Denis

fabrice_sp a écrit :
> Hi,
>
> Can you test with the version in my ppa
> (http://ppa.launchpad.net/fabricesp/ubuntu) to see if this fixes the
> issue?
>
> thanks,
> Fabrice
>
> ** Changed in: hugin (Ubuntu)
> Status: Triaged => Incomplete
>
>

Fabrice Coutadeur (fabricesp) wrote :

Please install it adding my ppa to your sources.list, through Synaptic.
Thanks.

Fabrice

It doesn't work as I am under Hardy :
if I put Hardy for the source list, Hugin is not marked as updatable
if I put Intrepid, Hugin can be updated but it can not be done as errors for dependancies occur.

Fabrice Coutadeur (fabricesp) wrote :

Hi,

You're right: I forgot to upload a hardy version in my ppa.
Fixed now.

Can you test again, with hardy in the source list?

Thanks,
Fabrice

Hello Fabrice,

For what concerns this bug, it seems corrected ;-))

-add 2 images + assembly : OK
-delete images, add others + assembly : OK
-same thing + save .pto : OK
-delete images, add others + assembly : OK
-open saved .pto + assembly : OK

no more crash !

For what concerns Hugin by itself, please find attached some notes.

Thank you for your job for this bug, and many thanks to the Hugin team for this great tool !

Denis

Fabrice Coutadeur (fabricesp) wrote :

Thanks for your comments.

About the error you're having when assembling, it's because you have a & in your path, and the shell is interpreting it as a &. If you change the directory name, it should work.

Thanks,
Fabrice

Changed in hugin:
status: Incomplete → Fix Released

Oups, I didn't take care of this "&" when I looked at the error ... I
should have seen it. It's not a character that I often use in path and I
don't remeber of such an error in previous Hugin version (but we did not
have so much information). Anyway, Hugin works correctly and I will
change my path ;-)

Thank you for your help

Regards,
Denis

fabrice_sp a écrit :
> Thanks for your comments.
>
> About the error you're having when assembling, it's because you have a &
> in your path, and the shell is interpreting it as a &. If you change the
> directory name, it should work.
>
> Thanks,
> Fabrice
>
> ** Changed in: hugin (Ubuntu)
> Status: Incomplete => Fix Released
>
>

Arnaud LE CAM (arnaudlecam) wrote :

Hello,

I had the same bug using Hugin 0.7~beta4.0ubuntu4 (hardy) under ubuntu : there wasn't any bug until trying to save a project after optimization.
Adding Fabrice's path to my /etc/apt/sources.list ("deb http://ppa.launchpad.net/fabricesp/ubuntu/ hardy main"), then reloading my repository and switching to the Fabrice's version in Synaptic worked fine.
No problems now, pano are superbs !

Thank you for your work.

Arnaud

alexG (j-alex-gracio) wrote :

Hello

I have the same bug (also with Hugin 0.7-beta40ubuntu4 on Hardy).
I've tried to add Fabrice's repository I get the error in Synaptic:

"W: GPG error: http://ppa.launchpad.net hardy Release: The following signatures couldn't be verified because the public key is not available: NO_PUBKEY 370CF012F65DB995"

Am I doing something wrong? (I'm new with Ubuntu and Synaptic, so maybe this one of those newbie questions...).

I would also would like to know how I switch in Synaptic to Fabric'es version of the repository.

Thanks Alex

Fabrice Coutadeur (fabricesp) wrote :

Hi alexG,

First of all: this is only a warning, so you can 'ignore' it. If you want to get rid of this warning, you just have to follow the instructions at https://launchpad.net/+help/soyuz/ppa-sources-list.html

thanks,
Fabrice

alexG (j-alex-gracio) wrote :

Hi Fabrice

Thanks for your e-mail. Indeed, I first though that Synaptic did dot
accepted your repository, but after posting my message I did see that it
added your repository correctly. Then I asked to reinstall Hugin and it
found and installed your version all right. After a very quick test I
hugin doesn't crashes - many thanks!

Cheers Alex

On Sun, 2009-07-26 at 17:47 +0000, fabrice_sp wrote:
> Hi alexG,
>
> First of all: this is only a warning, so you can 'ignore' it. If you
> want to get rid of this warning, you just have to follow the
> instructions at https://launchpad.net/+help/soyuz/ppa-sources-list.html
>
> thanks,
> Fabrice
>

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.