When using a hidpi screen the GL preview only uses a quarter of the screen

Bug #1852505 reported by Jose Gómez on 2019-11-13
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
hugin (Ubuntu)
Undecided
Unassigned

Bug Description

Using a hi-dpi screen. The GL preview screen must be taking screen size divided by 2 somehow. See attached screenshot.

ProblemType: Bug
DistroRelease: Ubuntu 19.10
Package: hugin 2019.0.0+dfsg-2
ProcVersionSignature: Ubuntu 5.3.0-21.22-generic 5.3.7
Uname: Linux 5.3.0-21-generic x86_64
ApportVersion: 2.20.11-0ubuntu8.1
Architecture: amd64
CurrentDesktop: ubuntu:GNOME
Date: Wed Nov 13 23:10:27 2019
InstallationDate: Installed on 2016-07-21 (1210 days ago)
InstallationMedia: Ubuntu-GNOME 16.10 "Yakkety Yak" - Alpha amd64 (20160718)
SourcePackage: hugin
UpgradeStatus: Upgraded to eoan on 2019-09-28 (46 days ago)

Jose Gómez (adler-dreamcoder) wrote :
tmodes (tmodes) wrote :

Trying to fix in changeset 940fc9d31c27.
But I have no access to a hidpi display with Ubuntu. So I can't test the patch for myself.
Feedback would be appreciated.

Changed in hugin (Ubuntu):
status: New → Fix Committed
Jose Gómez (adler-dreamcoder) wrote :

Thanks! I can test it once I'm back I can try to figure out how to build the application.

Jose Gómez (adler-dreamcoder) wrote :

Hi, I am back now. How can I test this? Are there instructions or a PPA that I can use?

tmodes (tmodes) wrote :

Sorry for the late reply.

We released 2019.2 RC1 with this patch last weekend. I was hoping it find its ways into the repository.
The maintainer of our own ppa disappear recently and nobody else volunteered to maintain it now. So I can't give you a link to a ppa.

The building instructions can be found at https://wiki.panotools.org/Hugin_Compiling_Ubuntu
(The list of the dependencies is a little bit out of date. For some libraries newer versions are needed. Otherwise it should be the same.)

Jose Gómez (adler-dreamcoder) wrote :

I have finally found a place where to download an updated version of Hugin (2019.2.0.6c8394bb3ce7). The preview windows are now correctly _displayed_, but the drag functionality is not working fine.

Dragging on the right side of the image moves the image as if the mouse were in the middle. Therefore it is not possible to drag the image on its right side.

Jose Gómez (adler-dreamcoder) wrote :

The same issue with the dragging also happens when trying to crop an image. Basically, the detection of the position of the mouse pointer within the image is incorrect in this version.

tmodes (tmodes) wrote :

It seems there are different ways to handle HiDPI screens on Linux.
Some ways work fine, other exhibit the described behavior. I needed some time to found the corresponding setting.
Now I could test it for myself and fix it. It should now work fine with Hugin from default branch.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers