Hugin freezes after alignment

Bug #1815996 reported by Scott Cowles Jacobs on 2019-02-15
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
hugin (Ubuntu)
Undecided
Unassigned

Bug Description

I just tried to do another long (14 picture) panorama (also with a tripod).

This one had a wide brightness range, which was eventually going to cause a problem, but I told it to go ahead and align it anyway.
In two different runs-through, I got two slightly different results:
1: Alignment finished, but I could see a problem between what appeared to be photos 8 and 9.
I tried to call up the window where I could manually enter control points.
Window comes up - blank. Nothing more. Had to kill the process.
2: The second time around, I noticed that it could find no control points between Photo 8 and 9.
Not surprising, but when it finished, it put up a window, and then an error box but both were blank, and nothing further was possible, except killing the process.

A third time, I started Hugin from the terminal.
some gtk-critical warnings and some info came up immediately, but until I reached the blank-window=and-error-box stage, nothing more.
Then, I got:
"(hugin:4321): Gtk-WARNING **: gtk_widget_size_allocate(): attempt to allocate widget with width 0 and height -27

(hugin:4321): Gtk-WARNING **: gtk_widget_size_allocate(): attempt to allocate widget with width -5 and height 17

"
The gtk critical warnings i then noted were also widget-based, so I will mention that there were 12 identical lines:
"(hugin:4321): Gtk-CRITICAL **: IA__gtk_widget_set_size_request: assertion 'height >= -1' failed
"
I will attach a text file with the complete terminal output.

This appears to be a freeze/endless loop, as when I brought up HTOP, one or other of my CPU cores was (almost) always at a full 100%

---------------------------------------------------
scott@scott-Asus-M2N68-AM-PLUS:~$ uname -a
Linux scott-Asus-M2N68-AM-PLUS 4.13.0-46-generic #51-Ubuntu SMP Tue Jun 12 12:36:29 UTC 2018 x86_64 x86_64 x86_64 GNU/Linux
scott@scott-Asus-M2N68-AM-PLUS:~$ lsb_release -dsc
Ubuntu 17.10
artful
scott@scott-Asus-M2N68-AM-PLUS:~$ echo $DESKTOP_SESSION
QLubuntu

scott@scott-Asus-M2N68-AM-PLUS:~$ apt-cache policy hugin*
hugin:
  Installed: 2018.1.0+hg7969+dfsg-0ubuntu1~artful
  Candidate: 2018.1.0+hg7969+dfsg-0ubuntu1~artful
  Version table:
 *** 2018.1.0+hg7969+dfsg-0ubuntu1~artful 500
        500 http://ppa.launchpad.net/hugin/nightly/ubuntu artful/main amd64 Packages
        100 /var/lib/dpkg/status
     2017.0.0~rc2+dfsg-2 500
        500 http://us.archive.ubuntu.com/ubuntu artful/universe amd64 Packages

(I was using 2017.0.0~rc2+dfsg-2 (Standard for [L]ubuntu 17.10) originally, but noted that
elsewhere, a more recent version was available, and thought that perhaps the "bug" (?) had been fixed there. Alas, no...
Hugin itself prints "2018.1.0.aac6fbdf0772" for my current version, from the "Help" menu.)

(I don't print the pkgs for enblend/enfuse here, as it never gets that far...)

------------------------------------------------------------------

The attached screenshot shows what the desktop with the empty window and empty Error box looks like, after going away to a different desktop (to file this bug) and then returning to it.
Part of the window gets erased, but not redrawn with anything, and hence remains blank, and the rest doesn't even get redrawn.
The error box gets erased and redrawn blank.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers