Hugin always report 'assert !fn.IsDir()" failed when generating panoramic photo

Bug #1743064 reported by Leo on 2018-01-13
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
hugin (Ubuntu)
Undecided
Unassigned

Bug Description

1. It used to work and I used it few days ago. After some update today, it stopped working.
It is always reproducible for all stitching jobs. So it should be easy to fix. I attached a screen shot of the error message.
Thanks.

ProblemType: Bug
DistroRelease: Ubuntu 16.04
Package: hugin 2015.0.0+dfsg-1
ProcVersionSignature: Ubuntu 4.4.0-103.126-generic 4.4.98
Uname: Linux 4.4.0-103-generic x86_64
NonfreeKernelModules: nvidia_uvm nvidia_drm nvidia_modeset nvidia
ApportVersion: 2.20.1-0ubuntu2.15
Architecture: amd64
CurrentDesktop: X-Cinnamon
Date: Fri Jan 12 17:42:38 2018
ExecutablePath: /usr/bin/hugin
InstallationDate: Installed on 2016-06-08 (583 days ago)
InstallationMedia: Ubuntu 16.04 LTS "Xenial Xerus" - Release amd64 (20160420.1)
SourcePackage: hugin
UpgradeStatus: No upgrade log present (probably fresh install)

Leo (lionghostshop) wrote :
tmodes (tmodes) wrote :

Can you provide the backtrace from the assert dialog?
Also check the preferences, tab filename: what is set for the "Default project filename:" and "Default output prefix:"

Changed in hugin (Ubuntu):
status: New → Incomplete
tmodes (tmodes) wrote :

Could you also attach your preferences file (it should be ~/.hugin)? So I can check some more settings by myself.
(But the backtrace is still needed.)

Leo (lionghostshop) wrote :

ASSERT INFO:
../src/common/filefn.cpp(251): assert "!fn.IsDir()" failed in FindValidPath(): Cannot search for directories; only for files

BACKTRACE:
[1] wxPathList::FindValidPath(wxString const&) const
[2] wxPathList::FindAbsoluteValidPath(wxString const&) const
[3] HuginQueue::GetExternalProgram(wxConfigBase*, wxString const&, wxString const&)
[4] HuginQueue::detail::PrintDetailInfo(HuginBase::Panorama const&, HuginBase::PanoramaOptions const&, std::set<unsigned int, std::less<unsigned int>, std::allocator<unsigned int> > const&, wxString const&, wxString const&, wxConfigBase*, double&)
[5] HuginQueue::GetStitchingCommandQueue(HuginBase::Panorama const&, wxString const&, wxString const&, wxString const&, wxString&, wxArrayString&, wxArrayString&)
[6] RunStitchPanel::StitchProject(wxString, wxString)
[7] RunStitchFrame::StitchProject(wxString, wxString)
[8] Batch::OnStitch(wxString, wxString, int)
[9] Batch::RunNextInBatch()
[10] Batch::RunBatch()
[11] BatchFrame::RunBatch()
[12] PTBatcherGUI::OnInit()
[13] wxEntry(int&, wchar_t**)
[14] main
[15] __libc_start_main
[16] _start

Leo (lionghostshop) wrote :
Leo (lionghostshop) wrote :

Hopefully, it helps.

tmodes (tmodes) wrote :

The cause is probably that then blender program is not correctly specified in the preferences. (But I can't reproduce it.) To fix this go to Files>Preferences, on tab Programs select "Reset to default" and close dialog with "Ok". Now it should work again. (I will add an additional check for this case.)

(If you still get the error, check that you can run exiftool from a terminal.)

Leo (lionghostshop) wrote :

I reset does not work. I just remove .hugin directly. Now it works. Thanks a lot.

Launchpad Janitor (janitor) wrote :

[Expired for hugin (Ubuntu) because there has been no activity for 60 days.]

Changed in hugin (Ubuntu):
status: Incomplete → Expired
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers