window-stack-bridge crashed with SIGSEGV in BamfWindow::windowId()

Bug #1243654 reported by Otus on 2013-10-23
44
This bug affects 6 people
Affects Status Importance Assigned to Milestone
hud (Ubuntu)
High
Charles Kerr
Nominated for Saucy by Timo Jyrinki
Saucy
Undecided
Unassigned

Bug Description

SRU for saucy.

[Impact]

A crash in certain situations.

[Test Case]

A crasher, no clear test case. Ensure errors.ubuntu.com stops reporting this. The bucket is at:

https://errors.ubuntu.com/bucket/?id=/usr/lib/x86_64-linux-gnu/hud/window-stack-bridge:11:BamfWindow::windowId:BamfWindowStack::ActiveWindowChanged:BamfWindowStack::qt_static_metacall:QMetaObject::activate:OrgAyatanaBamfMatcherInterface::ActiveWindowChanged

[Regression Potential]

Low, a null safe guard added in three places.

ProblemType: CrashDistroRelease: Ubuntu 13.10
Package: hud 13.10.1+13.10.20131014-0ubuntu1
ProcVersionSignature: Ubuntu 3.11.0-12.19-generic 3.11.3
Uname: Linux 3.11.0-12-generic x86_64
ApportVersion: 2.12.5-0ubuntu2
Architecture: amd64
CrashCounter: 1
Date: Wed Oct 23 13:44:21 2013
ExecutablePath: /usr/lib/x86_64-linux-gnu/hud/window-stack-bridge
InstallationDate: Installed on 2012-11-10 (346 days ago)
InstallationMedia: Ubuntu 12.10 "Quantal Quetzal" - Release amd64 (20121017.5)
MarkForUpload: True
ProcCmdline: /usr/lib/x86_64-linux-gnu/hud/window-stack-bridge
SegvAnalysis:
 Segfault happened at: 0x409b70 <_ZN10BamfWindow8windowIdEv>: mov 0x24(%rdi),%eax
 PC (0x00409b70) ok
 source "0x24(%rdi)" (0x00000024) not located in a known VMA region (needed readable region)!
 destination "%eax" ok
SegvReason: reading NULL VMA
Signal: 11SourcePackage: hud
StacktraceTop:
 BamfWindow::windowId() ()
 BamfWindowStack::ActiveWindowChanged(QString const&, QString const&) ()
 ?? ()
 QMetaObject::activate(QObject*, int, int, void**) () from /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
 OrgAyatanaBamfMatcherInterface::ActiveWindowChanged(QString const&, QString const&) ()
Title: window-stack-bridge crashed with SIGSEGV in BamfWindow::windowId()
UpgradeStatus: Upgraded to saucy on 2013-10-18 (4 days ago)
UserGroups: adm cdrom dip libvirtd lpadmin plugdev sambashare sudo
upstart.hud.log: (process:1812): hudapplicationsource-WARNING **: Unable to export application 'python2' skeleton on path '/com/canonical/hud/applications/python2': An object is already exported for the interface com.canonical.hud.Application at /com/canonical/hud/applications/python2
upstart.window-stack-bridge.log: Could not get desktop file for "/org/ayatana/bamf/window/75497480"

Related branches

Otus (jan-varho) wrote :
Otus (jan-varho) on 2013-10-23
description: updated

StacktraceTop:
 BamfWindow::windowId (this=this@entry=0x0) at /build/buildd/hud-13.10.1+13.10.20131014/window-stack-bridge/BamfWindowStack.cpp:80
 BamfWindowStack::ActiveWindowChanged (this=0x7fff2b8d4190, oldWindowPath=..., newWindowPath=...) at /build/buildd/hud-13.10.1+13.10.20131014/window-stack-bridge/BamfWindowStack.cpp:208
 BamfWindowStack::qt_static_metacall (_o=0x0, _c=38120416, _id=38114112, _a=0x7fff2b8d39d0) at /build/buildd/hud-13.10.1+13.10.20131014/obj-x86_64-linux-gnu/window-stack-bridge/moc_BamfWindowStack.cpp:110
 QMetaObject::activate (sender=0x7fff2b8d41b8, signalOffset=<optimized out>, local_signal_index=<optimized out>, argv=0x7fff2b8d39d0) at kernel/qobject.cpp:3445
 OrgAyatanaBamfMatcherInterface::ActiveWindowChanged (this=<optimized out>, _t1=..., _t2=...) at /build/buildd/hud-13.10.1+13.10.20131014/obj-x86_64-linux-gnu/window-stack-bridge/BamfInterface.moc:392

Changed in hud (Ubuntu):
importance: Undecided → Medium
tags: removed: need-amd64-retrace
Charles Kerr (charlesk) on 2013-10-28
Changed in hud (Ubuntu):
assignee: nobody → Charles Kerr (charlesk)
status: New → In Progress
importance: Medium → High
information type: Private → Public
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package hud - 13.10.1+14.04.20131029.1-0ubuntu1

---------------
hud (13.10.1+14.04.20131029.1-0ubuntu1) trusty; urgency=low

  [ Pete Woods ]
  * Fix the ref counting of application sources The application sources
    are now entirely owned by the application-list's hash table.

  [ Ted Gould ]
  * Add apport dependencies to the package hook. (LP: #1233994)
  * Don't show disabled items in search results. (LP: #1192646)

  [ Charles Kerr ]
  * Add a nullptr safeguard to prevent a crash-on-null-ptr-reference.
    Also, move a QMap lookup outside of a for loop. Yay! . (LP:
    #1242032)
  * if we can't get the busname, log a g_critical and then exit
    gracefully instead of abort()ing in g_error. (LP: #1244688)
  * Add a null safeguard when accessing window SharedPtrs held in the
    m_windows QMap . (LP: #1243654)

  [ Ubuntu daily release ]
  * Automatic snapshot from revision 343
 -- Ubuntu daily release <email address hidden> Tue, 29 Oct 2013 11:17:56 +0000

Changed in hud (Ubuntu):
status: In Progress → Fix Released
description: updated
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in hud (Ubuntu Saucy):
status: New → Confirmed

Hello Otus, or anyone else affected,

Accepted hud into saucy-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/hud/13.10.1+13.10.20131031-0ubuntu1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

description: updated
Changed in hud (Ubuntu Saucy):
status: Confirmed → Fix Committed
tags: added: verification-needed
Sebastien Bacher (seb128) wrote :

looking to errors report it seems the fix is working, setting as verification-done

tags: added: verification-done
removed: verification-needed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package hud - 13.10.1+13.10.20131031-0ubuntu1

---------------
hud (13.10.1+13.10.20131031-0ubuntu1) saucy; urgency=low

  [ Charles Kerr ]
  * If we can't get the busname, log a g_critical and then exit
    gracefully instead of abort()ing in g_error. (LP: #1244688)
  * Add a null safeguard when accessing window SharedPtrs held in the
    m_windows QMap. (LP: #1243654)

  [ Ubuntu daily release ]
  * Automatic snapshot from revision 344
 -- Ubuntu daily release <email address hidden> Thu, 31 Oct 2013 23:12:19 +0000

Changed in hud (Ubuntu Saucy):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers