window-stack-bridge crashed with SIGSEGV in data()

Bug #1242339 reported by Кудрин Сергей on 2013-10-20
66
This bug affects 12 people
Affects Status Importance Assigned to Milestone
Unity HUD
Fix Released
High
Ted Gould
hud (Ubuntu)
High
Unassigned
Saucy
Undecided
Unassigned

Bug Description

[Impact]
High impoact on our users, this is one of the highest reported issues on errors.ubuntu.com: https://errors.ubuntu.com/problem/80ec348bd203ad9f5b91a956c463234dce72d2e7

[Test case]
Use Unity, switch between applications and try to access menus via the HUD.

[Rgression potential]
This changes behavior in the window properties retrieval. Regression potential is low since this would simply return an empty set (rather than crashing) should the window not be identifyable.

---

Just working in eclipse

ProblemType: Crash
DistroRelease: Ubuntu 13.10
Package: hud 13.10.1+13.10.20131014-0ubuntu1
ProcVersionSignature: Ubuntu 3.11.0-12.19-generic 3.11.3
Uname: Linux 3.11.0-12-generic i686
NonfreeKernelModules: nvidia
ApportVersion: 2.12.5-0ubuntu2
Architecture: i386
Date: Sun Oct 20 20:11:13 2013
ExecutablePath: /usr/lib/i386-linux-gnu/hud/window-stack-bridge
InstallationDate: Installed on 2012-05-14 (523 days ago)
InstallationMedia: Ubuntu 11.10 "Oneiric Ocelot" - Release i386 (20111012)
MarkForUpload: True
ProcCmdline: /usr/lib/i386-linux-gnu/hud/window-stack-bridge
ProcEnviron:
 PATH=(custom, no user)
 LANGUAGE=ru
 XDG_RUNTIME_DIR=<set>
 LANG=ru_RU.UTF-8
 SHELL=/bin/bash
SegvAnalysis:
 Segfault happened at: 0xb73110d7 <_ZN22QDBusAbstractInterface25asyncCallWithArgumentListERK7QStringRK5QListI8QVariantE+23>: mov 0x4(%edi),%esi
 PC (0xb73110d7) ok
 source "0x4(%edi)" (0x00000004) not located in a known VMA region (needed readable region)!
 destination "%esi" ok
SegvReason: reading NULL VMA
Signal: 11
SourcePackage: hud
StacktraceTop:
 QDBusAbstractInterface::asyncCallWithArgumentList(QString const&, QList<QVariant> const&) () from /usr/lib/i386-linux-gnu/libQt5DBus.so.5
 BamfWindow::xProp(QString const&) ()
 BamfWindowStack::GetWindowProperties(unsigned int, QString const&, QStringList const&) ()
 WindowStackAdaptor::GetWindowProperties(unsigned int, QString const&, QStringList const&) ()
 ?? ()
Title: window-stack-bridge crashed with SIGSEGV in QDBusAbstractInterface::asyncCallWithArgumentList()
UpgradeStatus: Upgraded to saucy on 2013-10-19 (1 days ago)
UserGroups: adm lpadmin nopasswdlogin sambashare sudo
upstart.window-stack-bridge.log:
 QDBusConnection: name 'org.ayatana.bamf' had owner '' but we thought it was ':1.14'
 Error getting parents for "/org/ayatana/bamf/window/75613984" QDBusError("org.freedesktop.DBus.Error.UnknownMethod", "Интерфейс «org.ayatana.bamf.view» для пути /org/ayatana/bamf/window/75613984 объекта не найден")
 Error getting parents for "/org/ayatana/bamf/window/75614083" QDBusError("org.freedesktop.DBus.Error.UnknownMethod", "Интерфейс «org.ayatana.bamf.view» для пути /org/ayatana/bamf/window/75614083 объекта не найден")

Related branches

StacktraceTop:
 data (this=0x4) at ../../include/QtCore/../../src/corelib/tools/qscopedpointer.h:134
 qGetPtrHelper<QScopedPointer<QObjectData> > (p=...) at ../../include/QtCore/../../src/corelib/global/qglobal.h:991
 d_func (this=0x0) at qdbusabstractinterface.h:158
 QDBusAbstractInterface::asyncCallWithArgumentList (this=0x0, method=..., args=...) at qdbusabstractinterface.cpp:493
 Xprop (xprop=..., this=0x0) at /build/buildd/hud-13.10.1+13.10.20131014/obj-i686-linux-gnu/window-stack-bridge/BamfViewInterface.h:247

Changed in hud (Ubuntu):
importance: Undecided → Medium
summary: - window-stack-bridge crashed with SIGSEGV in
- QDBusAbstractInterface::asyncCallWithArgumentList()
+ window-stack-bridge crashed with SIGSEGV in data()
tags: removed: need-i386-retrace
Sebastien Bacher (seb128) wrote :

The issue is one of the most reported one on saucy: https://errors.ubuntu.com/problem/80ec348bd203ad9f5b91a956c463234dce72d2e7

information type: Private → Public
Changed in hud:
importance: Undecided → High
Changed in hud (Ubuntu):
importance: Medium → High
Ted Gould (ted) on 2013-10-22
Changed in hud:
assignee: nobody → Ted Gould (ted)
status: New → In Progress
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in hud (Ubuntu):
status: New → Confirmed
PS Jenkins bot (ps-jenkins) wrote :

Fix committed into lp:hud/13.10 at revision 341, scheduled for release in hud, milestone Unknown

Changed in hud:
status: In Progress → Fix Committed
description: updated
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in hud (Ubuntu Saucy):
status: New → Confirmed

Hello Кудрин, or anyone else affected,

Accepted hud into saucy-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/hud/13.10.1+13.10.20131024-0ubuntu1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in hud (Ubuntu Saucy):
status: Confirmed → Fix Committed
tags: added: verification-needed
Miklos Juhasz (mjuhasz) wrote :

I don't experience this crash with the proposed package anymore.
HUD does crash though but that's LP bug #1239360 : hud-service crashed with signal 5 in _start()
I am marking this bug is verification done since I think this one is fixed (but there is another one causing hud crash after login).

tags: added: verification-done
removed: verification-needed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package hud - 13.10.1+13.10.20131024-0ubuntu1

---------------
hud (13.10.1+13.10.20131024-0ubuntu1) saucy; urgency=low

  [ Pete Woods ]
  * Fix the ref counting of application sources The application sources
    are now entirely owned by the application-list's hash table.

  [ Ted Gould ]
  * Add apport dependencies to the package hook. (LP: #1233994)
  * Don't show disabled items in search results. (LP: #1192646)
  * Don't crash if we get asked about a window we don't know about,
    return a null list. (LP: #1242339)

  [ Ubuntu daily release ]
  * Automatic snapshot from revision 341
 -- Ubuntu daily release <email address hidden> Thu, 24 Oct 2013 16:12:43 +0000

Changed in hud (Ubuntu Saucy):
status: Fix Committed → Fix Released
zasran (erik-zasran) wrote :

doesn't seem like the fix helped, I have hud (13.10.1+13.10.20131014-0ubuntu1) installed but I just saw the crash (segfault).

erik@jojda:~$ COLUMNS=250 dpkg -l hud
Desired=Unknown/Install/Remove/Purge/Hold
| Status=Not/Inst/Conf-files/Unpacked/halF-conf/Half-inst/trig-aWait/Trig-pend
|/ Err?=(none)/Reinst-required (Status,Err: uppercase=bad)
||/ Name Version Architecture Description
+++-========================================================-=================================-=================================-======================================================================================================================
ii hud 13.10.1+13.10.20131014-0ubuntu1 amd64 Backend for the Unity HUD

Charles Kerr (charlesk) wrote :

Zasran, Thank you for taking the time to report this bug and helping to make Ubuntu better. If HUD is still crashing for you, it would be useful to have that crash information so that we can confirm whether or not it's the same crash; and if not, to handle it separately in its own ticket.

Please follow these instructions to have apport report a new bug about your crash that can be dealt with by the automatic retracer.

If you are running the Ubuntu Stable Release you might need to enable apport in /etc/default/apport and restart.

Now open your file manager, navigate to your /var/crash directory and open the crash report you wish to submit.
If this fails you will have to open a terminal and file your report with 'ubuntu-bug /var/crash/_my_crash_report.crash' where _my_crash_report.crash is the crash you would like to report. If you get an error that you aren't allowed to access this report you will have to file it with 'sudo ubuntu-bug /var/crash/_my_crash_report.crash'.

The process outlined above will automatically open a new bug report which can then dealt with more efficiently. Thanks in advance for your cooperation and understanding.

Charles Kerr (charlesk) on 2013-11-03
Changed in hud:
status: Fix Committed → Fix Released
Pete Woods (pete-woods) on 2013-12-05
Changed in hud (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers