window-stack-bridge crashed with SIGSEGV in BamfWindow::windowId()

Bug #1238338 reported by Karma Dorje on 2013-10-11
304
This bug affects 71 people
Affects Status Importance Assigned to Milestone
hud (Ubuntu)
Undecided
Unassigned

Bug Description

apt-cache policy hud
hud:
  Installed: 13.10.1+13.10.20131010.1-0ubuntu1
  Candidate: 13.10.1+13.10.20131010.1-0ubuntu1
  Version table:
 *** 13.10.1+13.10.20131010.1-0ubuntu1 0
        500 http://archive.ubuntu.com/ubuntu/ saucy/main amd64 Packages
        100 /var/lib/dpkg/status

ProblemType: Crash
DistroRelease: Ubuntu 13.10
Package: hud 13.10.1+13.10.20131010.1-0ubuntu1
ProcVersionSignature: Ubuntu 3.11.0-12.19-generic 3.11.3
Uname: Linux 3.11.0-12-generic x86_64
ApportVersion: 2.12.5-0ubuntu1
Architecture: amd64
CrashCounter: 1
Date: Fri Oct 11 08:29:01 2013
ExecutablePath: /usr/lib/x86_64-linux-gnu/hud/window-stack-bridge
InstallationDate: Installed on 2012-09-30 (375 days ago)
InstallationMedia: Ubuntu 12.04.1 LTS "Precise Pangolin" - Release amd64 (20120817.1)
MarkForUpload: True
ProcCmdline: /usr/lib/x86_64-linux-gnu/hud/window-stack-bridge
SegvAnalysis:
 Segfault happened at: 0x409b70 <_ZN10BamfWindow8windowIdEv>: mov 0x24(%rdi),%eax
 PC (0x00409b70) ok
 source "0x24(%rdi)" (0x00000024) not located in a known VMA region (needed readable region)!
 destination "%eax" ok
SegvReason: reading NULL VMA
Signal: 11
SourcePackage: hud
StacktraceTop:
 BamfWindow::windowId() ()
 BamfWindowStack::removeWindow(QString const&) ()
 BamfWindowStack::ViewClosed(QString const&, QString const&) ()
 ?? ()
 QMetaObject::activate(QObject*, int, int, void**) () from /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
Title: window-stack-bridge crashed with SIGSEGV in BamfWindow::windowId()
UpgradeStatus: Upgraded to saucy on 2013-05-06 (157 days ago)
UserGroups: adm cdrom dip lpadmin plugdev sambashare sudo
upstart.window-stack-bridge.log: Error getting parents for "/org/ayatana/bamf/window/65011880" QDBusError("org.freedesktop.DBus.Error.UnknownMethod", "Интерфейс «org.ayatana.bamf.view» для пути /org/ayatana/bamf/window/65011880 объекта не найден")

Related branches

Karma Dorje (taaroa) wrote :
tags: removed: need-amd64-retrace
Karma Dorje (taaroa) on 2013-10-11
information type: Private → Public
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in hud (Ubuntu):
status: New → Confirmed
lokz (lokz) wrote :

Coogle Chromium crashed, also Google Chrome crashed.

lokz (lokz) wrote :

Few minutes ago I installed latest updates and restarted (approx 07:50 CET - 11.10.2013.)

Thomas Strehl (strehl-t) on 2013-10-11
Changed in hud (Ubuntu):
assignee: nobody → Pete Woods (pete-woods)
vito7988 (vito7988) on 2013-10-13
Changed in hud (Ubuntu):
assignee: Pete Woods (pete-woods) → vito7988 (vito7988)
assignee: vito7988 (vito7988) → nobody
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package hud - 13.10.1+13.10.20131014-0ubuntu1

---------------
hud (13.10.1+13.10.20131014-0ubuntu1) saucy; urgency=low

  [ Pete Woods ]
  * Fix crash on window removal. (LP: #1238338)
  * Fix application disposal, so HUD doesn't crash for apps with no
    actions.

  [ Ubuntu daily release ]
  * Automatic snapshot from revision 336
 -- Ubuntu daily release <email address hidden> Mon, 14 Oct 2013 08:53:02 +0000

Changed in hud (Ubuntu):
status: Confirmed → Fix Released
zasran (erik-zasran) wrote :

doesn't seem like the fix helped, I have hud (13.10.1+13.10.20131014-0ubuntu1) installed but I just saw the crash (segfault).

erik@jojda:~$ COLUMNS=250 dpkg -l hud
Desired=Unknown/Install/Remove/Purge/Hold
| Status=Not/Inst/Conf-files/Unpacked/halF-conf/Half-inst/trig-aWait/Trig-pend
|/ Err?=(none)/Reinst-required (Status,Err: uppercase=bad)
||/ Name Version Architecture Description
+++-========================================================-=================================-=================================-======================================================================================================================
ii hud 13.10.1+13.10.20131014-0ubuntu1 amd64 Backend for the Unity HUD

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers