HUD does not support unity8's window stack API

Bug #1233992 reported by Jean-Baptiste Lallement on 2013-10-02
34
This bug affects 6 people
Affects Status Importance Assigned to Milestone
Unity HUD
Fix Released
Undecided
Pete Woods
unity-mir
Undecided
Pete Woods
hud (Ubuntu)
High
Pete Woods
unity-mir (Ubuntu)
Undecided
Unassigned

Bug Description

The crux of the problem here is that HUD was talking to the SurfaceFlinger based Unity Platform API.

We HUD to talk to unity8's new window stack API. On the desktop we will construct a bridge daemon that adapts from the BAMF API to the unity8 API.

-------

I got this crash right after booting the device with mir enabled.

ProblemType: Crash
DistroRelease: Ubuntu 13.10
Package: hud 13.10.1+13.10.20130918-0ubuntu1
Uname: Linux 3.4.0-3-mako armv7l
ApportVersion: 2.12.5-0ubuntu1
Architecture: armhf
Date: Wed Oct 2 05:57:57 2013
Disassembly: => 0x4007b494: Cannot access memory at address 0x4007b494
ExecutablePath: /usr/lib/arm-linux-gnueabihf/hud/hud-service
InstallationDate: Installed on 2013-10-01 (0 days ago)
InstallationMedia: Ubuntu Saucy Salamander (development branch) - armhf (20131001.3)
LocalLibraries: /android/system/lib/libGLESv2.so /android/system/lib/libnetutils.so /android/system/lib/libsync.so /android/system/lib/libskia.so /android/system/lib/libstlport.so /android/system/lib/libstdc++.so /android/system/lib/libdsyscalls.so /android/system/lib/libm.so /android/system/lib/libc.so /android/system/lib/libGLES_trace.so /android/system/lib/libexpat.so /android/system/lib/liblog.so /android/system/lib/libcorkscrew.so /android/system/lib/libubuntu_application_api.so /android/system/lib/libgccdemangle.so /android/system/lib/libutils.so /android/system/lib/libjpeg.so /android/system/lib/libemoji.so /android/system/lib/libhardware_legacy.so /android/system/lib/libandroidfw.so /android/system/lib/libbinder.so /android/system/lib/libhardware.so /android/system/lib/libz.so /android/system/lib/libgui.so /android/system/lib/libcutils.so /android/system/lib/libEGL.so /android/system/lib/libwpa_client.so /android/system/lib/libui.so
MarkForUpload: True
ProcCmdline: /usr/lib/arm-linux-gnueabihf/hud/hud-service
Signal: 11
SourcePackage: hud
StacktraceTop:
 ?? ()
 ?? ()
 ?? ()
Title: hud-service crashed with SIGSEGV
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups: adm autopilot cdrom dialout dip nopasswdlogin plugdev sudo tty video

Related branches

Jean-Baptiste Lallement (jibel) wrote :
information type: Private → Public

StacktraceSource:
 #0 0x4007b494 in ?? ()
 #1 0x403fa328 in ?? ()
 #2 0x403fa328 in ?? ()
StacktraceTop:
 ?? ()
 ?? ()
 ?? ()

tags: added: apport-failed-retrace
tags: removed: need-armhf-retrace

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in hud (Ubuntu):
status: New → Confirmed
Thomas Strehl (strehl-t) on 2013-10-02
Changed in hud (Ubuntu):
assignee: nobody → Pete Woods (pete-woods)
Changed in hud (Ubuntu):
importance: Undecided → High
tags: added: rls-s-incoming
Pete Woods (pete-woods) on 2013-10-02
summary: - hud-service crashed with SIGSEGV
+ HUD does not support unity8's ApplicationManger
Changed in hud (Ubuntu):
status: Confirmed → In Progress
Pete Woods (pete-woods) on 2013-10-09
Changed in unity-mir:
assignee: nobody → Pete Woods (pete-woods)
Changed in hud:
assignee: nobody → Pete Woods (pete-woods)
Changed in unity-mir:
status: New → In Progress

Fix committed into lp:unity-mir at revision 110, scheduled for release in unity-mir, milestone phone-v1-freeze

Changed in unity-mir:
status: In Progress → Fix Committed
Pete Woods (pete-woods) on 2013-10-09
summary: - HUD does not support unity8's ApplicationManger
+ HUD does not support unity8's window stack API
description: updated
PS Jenkins bot (ps-jenkins) wrote :

Fix committed into lp:hud at revision 329, scheduled for release in hud, milestone Unknown

Changed in hud:
status: New → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package unity-mir - 0.1+13.10.20131009.3-0ubuntu2

---------------
unity-mir (0.1+13.10.20131009.3-0ubuntu2) saucy; urgency=low

  * No change rebuild to drop upstart-app-launch dep; sigh.
 -- Loic Minier <email address hidden> Thu, 10 Oct 2013 04:12:30 +0200

Changed in unity-mir (Ubuntu):
status: New → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package hud - 13.10.1+13.10.20131010-0ubuntu1

---------------
hud (13.10.1+13.10.20131010-0ubuntu1) saucy; urgency=low

  [ Loïc Minier ]
  * Fix build-deps for desktop build.

  [ Ubuntu daily release ]
  * Automatic snapshot from revision 331

hud (13.10.1+13.10.20131009.1-0ubuntu1) saucy; urgency=low

  [ Pete Woods ]
  * Support unity8's window stack API. (LP: #1233992)

  [ Ubuntu daily release ]
  * Automatic snapshot from revision 329
 -- Ubuntu daily release <email address hidden> Thu, 10 Oct 2013 02:23:33 +0000

Changed in hud (Ubuntu):
status: In Progress → Fix Released
Michał Sawicz (saviq) on 2013-10-11
Changed in unity-mir:
status: Fix Committed → Fix Released
Charles Kerr (charlesk) on 2013-10-15
Changed in hud:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers