package libhttpcore-java 4.4.9-1 failed to install/upgrade: package is in a very bad inconsistent state; you should reinstall it before attempting configuration

Bug #1797709 reported by Sathya Nallasamy on 2018-10-13
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
httpcomponents-core (Ubuntu)
Undecided
Unassigned

Bug Description

Initially unable to use the eclipse IDE immediately after installing. So I did "sudo dpkg configure -a" and then i opened the eclipse, it crashed.

ProblemType: Package
DistroRelease: Ubuntu 18.04
Package: libhttpcore-java 4.4.9-1
ProcVersionSignature: Ubuntu 4.15.0-37.40-generic 4.15.18
Uname: Linux 4.15.0-37-generic x86_64
ApportVersion: 2.20.9-0ubuntu7.4
AptOrdering: NULL: ConfigurePending
Architecture: amd64
Date: Sat Oct 13 22:48:32 2018
Dependencies:

DpkgTerminalLog:
 dpkg: error processing package libhttpcore-java (--configure):
  package is in a very bad inconsistent state; you should
  reinstall it before attempting configuration
ErrorMessage: package is in a very bad inconsistent state; you should reinstall it before attempting configuration
InstallationDate: Installed on 2018-09-15 (28 days ago)
InstallationMedia:

PackageArchitecture: all
Python3Details: /usr/bin/python3.6, Python 3.6.6, python3-minimal, 3.6.5-3ubuntu1
PythonDetails: /usr/bin/python2.7, Python 2.7.15rc1, python-minimal, 2.7.15~rc1-1
RelatedPackageVersions:
 dpkg 1.19.0.5ubuntu2
 apt 1.6.5
SourcePackage: httpcomponents-core
Title: package libhttpcore-java 4.4.9-1 failed to install/upgrade: package is in a very bad inconsistent state; you should reinstall it before attempting configuration
UpgradeStatus: No upgrade log present (probably fresh install)

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers