Comment 15 for bug 1735160

Andrea Azzarone (azzar1) wrote :

Oh I removed the python3 patch from the series but the not actual file.

Regarding 17.10 sil2100 confirmed me that this is required. But at least it's going to be easier considering that:

- python3-httmock is already in artful (1.2.6-1 universe)
- python3-protobuf is already in artful (3.0.0-9ubuntu5 universe) (so no need to apply the nacl patch in py-macaroon-bakery)
- python3-nacl's version of artful is 1.1.1-1build2 (so no need to apply the nacl patch in py-macaroon-bakery)

The only things to be done are:
- target https://bugs.launchpad.net/ubuntu/+source/google-apputils-python/+bug/1735162 for 17.10 too
- relax python3-six deps in py-macaroon-bakery
- SRU python3-pymacaroons