html2ps deprecation error message

Bug #1130851 reported by Jim Sizelove on 2013-02-20
14
This bug affects 2 people
Affects Status Importance Assigned to Milestone
html2ps (Fedora)
Fix Released
Undecided
html2ps (Ubuntu)
Undecided
Unassigned

Bug Description

Ubuntu 12.04.2 LTS
html2ps version 1.0 beta7

When I try to run html2ps, I see this message:

Use of assignment to $[ is deprecated at /usr/bin/html2ps line 3409.

I found that someone has reported this error to Fedora, and a simple fix was suggested:
https://bugzilla.redhat.com/show_bug.cgi?id=822117

The home page for html2ps indicates that it is no longer being maintained. Can someone at launchpad verify that perl has deprecated $[, and if so, remove line 3409 from /usr/bin/html2ps? It would be ideal if this fix could get into updates to Ubuntu 12.04 (Precise).

$ html2ps /dev/null > /dev/null
Use of assignment to $[ is deprecated at /usr/bin/html2ps line 3408.
$

Thank you for the report. The usage of '$[' variable has been deprecated by Perl. The assignment to 0 what html2ps does is idempotent because the value is 0 by default. Simple removal of the line from html2ps should fix it without any side effects.

F18--16 are affected.

Fixed as html2ps-1.0-0.9.b7.fc18 in F18.

html2ps-1.0-0.9.b7.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/html2ps-1.0-0.9.b7.fc17

html2ps-1.0-0.8.b7.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/html2ps-1.0-0.8.b7.fc16

Package html2ps-1.0-0.8.b7.fc16:
* should fix your issue,
* was pushed to the Fedora 16 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing html2ps-1.0-0.8.b7.fc16'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-8018/html2ps-1.0-0.8.b7.fc16
then log in and leave karma (feedback).

html2ps-1.0-0.9.b7.fc17 has been pushed to the Fedora 17 stable repository. If problems still persist, please make note of it in this bug report.

html2ps-1.0-0.8.b7.fc16 has been pushed to the Fedora 16 stable repository. If problems still persist, please make note of it in this bug report.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in html2ps (Ubuntu):
status: New → Confirmed

Here's a patch that comments out the line in question (applied against the Ubuntu html2ps 1.0b7-1 package).

The attachment "comment out the deprecated line" seems to be a patch. If it isn't, please remove the "patch" flag from the attachment, remove the "patch" tag, and if you are a member of the ~ubuntu-reviewers, unsubscribe the team.

[This is an automated message performed by a Launchpad user owned by ~brian-murray, for any issues please contact him.]

tags: added: patch
Changed in html2ps (Fedora):
importance: Unknown → Undecided
status: Unknown → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.