Ubuntu

html-helper-mode with ASP-files does not work

Reported by Klaus S. Madsen on 2007-11-29
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
html-helper-mode (Ubuntu)
Low
Unassigned

Bug Description

Binary package hint: html-helper-mode

I'm using gutsy. My emacs package version is 22.1-0ubuntu5.1 and my html-helper-mode package version is 3.0.4kilo-2.

I have enabled the following in my .emacs to make html-helper-mode default to using visual-basic-mode when editing .asp-files:

(custom-set-variables
 '(html-helper-mode-global-JSP-not-ASP nil nil (html-helper-mode))
 '(html-helper-mode-uses-visual-basic t nil (html-helper-mode)))

(autoload 'asp-html-helper-mode "html-helper-mode" "Yay ASP" t)
(setq auto-mode-alist (cons '("\\.asp$" . asp-html-helper-mode) auto-mode-alist))

First of all, if the speedbar isn't active, an error appears in the Messages log, when trying to switch to the asp-html-helper-mode. However I don't think this causes any functional problems.

But when switching to vbscript-mode by pressing F4, the indentation functionality in visual-basic-mode does not work correctly, and causes the error "Invalid regular expression" whenever the tab-button is pressed.

Furthermore the highlighting in visual-basic-mode is case sensitive, which is a bit strange considering that the language is case insensitive.

Attached is a fix for this problem.

Daniel T Chen (crimsun) wrote :

Is this symptom still reproducible in 8.10?

Changed in html-helper-mode:
importance: Undecided → Low
status: New → Incomplete

I don't seem to have the speedbar problem anymore, but both of the patches for visual-basic-mode is still required, and they still apply.

Kamus (kamus) wrote :

We are closing this bug report because it lacks the information we need to investigate the problem, as described in the previous comments. Please reopen it if you can give us the missing information, and don't hesitate to submit bug reports in the future. To reopen the bug report you can click on the current status, under the Status column, and change the Status back to "New". Thanks again!

Changed in html-helper-mode (Ubuntu):
status: Incomplete → Invalid

Please tell me what information is lacking?

The bug was changed to "Incomplete" with the comment "Is this symptom still reproducible in 8.10?", to which I responded "I don't seem to have the speedbar problem anymore, but both of the patches for visual-basic-mode is still required, and they still apply."

That comment obviously applies to whether the problem is reproducible in 8.10.

What might not be obvious is that visual-basic-mode is a part of the html-helper-mode package.

Btw. I've just tested Karmic Koala, and the problem is still present there, and the patches still apply.

I'll change it back to new.

Changed in html-helper-mode (Ubuntu):
status: Invalid → New
Kamus (kamus) wrote :

@Klaus, thanks for you reply I have noticed that this package is not updated since hardy so I have sent your issue to upstream. You can track and follow this problem at: https://savannah.nongnu.org/bugs/?30448

tags: added: patch-forwarded-upstream
removed: patch
Changed in html-helper-mode (Ubuntu):
status: New → Triaged
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.