Ubuntu

HP Deskjet 5440 poor print quality

Reported by Pere Ubu on 2007-03-30
8
Affects Status Importance Assigned to Milestone
hplip (Ubuntu)
Low
Unassigned

Bug Description

My HP Deskjet 5440 prints fine from Windows. So there is nothing wrong with cartridges etc.

The printer is properly detected and set up with the recommended HPIJS driver.

When printing from Feisty letters are blurred, gradients and colours are dotted. Have tried several printout modes and results are the same. This has been a problem with earlier releases of Ubuntu as well (Edgy and Dapper)

This printer should work perfectly according to this site:
http://openprinting.org/show_printer.cgi?recnum=HP-DeskJet_5440

See also:
https://bugs.launchpad.net/ubuntu/+bug/98909

ProblemType: Bug
Architecture: i386
Date: Fri Mar 30 10:17:54 2007
DistroRelease: Ubuntu 7.04
Uname: Linux racer 2.6.20-13-generic #2 SMP Sun Mar 25 00:21:25 UTC 2007 i686 GNU/Linux

Pere Ubu (pereubu) wrote :

After installing the hpijs-ppds package, my printer was detected by HP-toolbox.
See: https://bugs.launchpad.net/ubuntu/+bug/98909

If I print a testpage through the HP-toolbox utility the results are good.
But if try the same from the gnome printer utility it still looks awfull.

Why this difference? How can I get good results from the gnome printing UI?

Till Kamppeter (till-kamppeter) wrote :

Don, Raghu, can you check this? Perhaps this printer is assigned to a wrong device class or so.

Seems to work fine here. I printed the testpage from CUPS, HP Device Manager and Gnome print manager. They all seem fine. I would like to see the output, if possible, by scanning and posting the jpg. I can then compare with what I am seeing here.

Pere Ubu (pereubu) wrote :

Here is to photos (no scanner available atm.) of the test pages.

1. Testpage from HP-toolbox -> GOOD_HP.jpg
2. Testpage from Gnome printer utility -> BAD_Gnome.jpg

Pere Ubu (pereubu) wrote :

No text

Have you run cartridge alignment ?

On 3/30/07, Pere Ubu <email address hidden> wrote:
>
> No text
>
> ** Attachment added: "GOOD_HP"
> http://librarian.launchpad.net/7078373/GOOD_HP.JPG
>
> --
> HP Deskjet 5440 poor print quality
> https://launchpad.net/bugs/98920
>

Pere Ubu (pereubu) wrote :

Yes, because I thought this was the problem. But as you see I only get these "shadows" when printing from gnome.
When printing testpage from the HP-toolbox it's OK.

When I initially searched the hplip mailing list I got these entries:
http://search.gmane.org/?query=alignment&author=&group=gmane.comp.printing.hplip.user&sort=relevance&DEFAULTOP=and&xP=alignment&xFILTERS=Gcomp.printing.hplip.user---A

So it seems I'm not the only one with this problem.

dwelch91 (dwelch91) wrote :

Yes, we can reproduce this and are looking into a solution. Its appears
there may be a bug in the cartridge alignment routines for this printer.

On 3/30/07, Pere Ubu <email address hidden> wrote:
>
> Yes, because I thought this was the problem. But as you see I only get
> these "shadows" when printing from gnome.
> When printing testpage from the HP-toolbox it's OK.
>
> When I initially searched the hplip mailing list I got these entries:
>
> http://search.gmane.org/?query=alignment&author=&group=gmane.comp.printing.hplip.user&sort=relevance&DEFAULTOP=and&xP=alignment&xFILTERS=Gcomp.printing.hplip.user---A
>
> So it seems I'm not the only one with this problem.
>
> --
> HP Deskjet 5440 poor print quality
> https://launchpad.net/bugs/98920
>

Please run hp-align - the command line alignment utility. Indeed there is a bug in the alignment function in the Device Manager. After running the alignment, most of the shadows are gone, but we still seem to have one minor alignment issue and we are working on it.

Pere Ubu (pereubu) wrote :

Thanx for your time and effort!
I'll try hp-align tomorrow.

Pere Ubu (pereubu) wrote :

Hi, I'm back again.

Thank you Till, Raghothama and dwelch91, running hp-align did the trick. Now printing from gnome is smooth as silk.

I'm a happy Ubuntu user now!

Thanks again.

Best regards from Pere Ubu.

Raghu, if you have fixed this for HPLIP 1.7.4, can you post a patch, then I can put the fix into Feisty. Thanks.

dwelch91 (dwelch91) wrote :

Till, there is a simple workaround to use in 1.7.1-1.7.3: use hp-align
instead of the toolbox for alignment on this class of printer. There is a UI
defect in the toolbox which sends the wrong alignment values to the printer.

On 4/1/07, Till Kamppeter <email address hidden> wrote:
>
> Raghu, if you have fixed this for HPLIP 1.7.4, can you post a patch,
> then I can put the fix into Feisty. Thanks.
>
> --
> HP Deskjet 5440 poor print quality
> https://launchpad.net/bugs/98920
>

But to make it as easy as possible for our users, who do not know about this problem I appreciate very much if you could provide a patch, so that it works also out of the GUI.

Changed in hplip:
importance: Undecided → Low
status: Unconfirmed → Confirmed
dwelch91 (dwelch91) wrote :

True. I don't have access to CVS from home today, so you can make the change
yourself, or wait until Monday. If you send me a copy of ui/align10form.py
(may not be the exact name) I can show you the change.

On 4/1/07, Till Kamppeter <email address hidden> wrote:
>
> But to make it as easy as possible for our users, who do not know about
> this problem I appreciate very much if you could provide a patch, so
> that it works also out of the GUI.
>
>
> ** Changed in: hplip (Ubuntu)
> Importance: Undecided => Low
> Status: Unconfirmed => Confirmed
>
> --
> HP Deskjet 5440 poor print quality
> https://launchpad.net/bugs/98920
>

Here we go. I have added some files with similar names, too.

    Till

dwelch91 wrote:
> True. I don't have access to CVS from home today, so you can make the change
> yourself, or wait until Monday. If you send me a copy of ui/align10form.py
> (may not be the exact name) I can show you the change.
>
> On 4/1/07, Till Kamppeter <email address hidden> wrote:
>> But to make it as easy as possible for our users, who do not know about
>> this problem I appreciate very much if you could provide a patch, so
>> that it works also out of the GUI.
>>
>>
>> ** Changed in: hplip (Ubuntu)
>> Importance: Undecided => Low
>> Status: Unconfirmed => Confirmed
>>
>> --
>> HP Deskjet 5440 poor print quality
>> https://launchpad.net/bugs/98920
>>
>

dwelch91 (dwelch91) wrote :

Attached is the fixed version of align10form.py... rename and drop into /ui directory.

Changed in hplip:
status: Confirmed → In Progress
Changed in hplip:
status: In Progress → Fix Committed
Changed in hplip:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers