hp-clean can't find a printer, gives Qt errors

Bug #816531 reported by Akkana Peck on 2011-07-26
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
HPLIP
Undecided
Unassigned
hplip (Ubuntu)
Undecided
Unassigned

Bug Description

I need to clean my printer heads, and CUPS can't do it (see bug 428065 and bug 377812), so I'm trying hp-clean, part of the hplip package. The documentation doesn't say what it expects as a printer or device specifier, so I'm trying
hp-clean -pHP_Deskjet_F4200_series (the name CUPS gave to the printer) and
hp-clean -dusb://HP/Deskjet%20F4200%20series?serial=CN98Q5Z1XF05BR (the URL shown in the CUPS web interface)
but they both fail in the same way:

$ hp-clean -pHP_Deskjet_F4200_series

HP Linux Imaging and Printing System (ver. 3.11.1)
Printer Cartridge Cleaning Utility ver. 4.0

Copyright (c) 2001-9 Hewlett-Packard Development Company, LP
This software comes with ABSOLUTELY NO WARRANTY.
This is free software, and you are welcome to distribute it
under certain conditions. See COPYING file for more details.

error: Invalid printer name: HP_Deskjet_F4200_series
warning: Qt/PyQt 4 initialization failed.
error: hp-clean -u/--gui requires Qt4 GUI support. Entering interactive mode.

HP Linux Imaging and Printing System (ver. 3.11.1)
System Tray Status Service ver. 2.0

Copyright (c) 2001-9 Hewlett-Packard Development Company, LP
This software comes with ABSOLUTELY NO WARRANTY.
This is free software, and you are welcome to distribute it
under certain conditions. See COPYING file for more details.

warning: Qt/PyQt 4 initialization failed.
error: hp-systray requires Qt4 GUI and DBus support. Exiting.
warning: Unable to connect to dbus. Is hp-systray running?
error: Unable to open device: Unknown/invalid device-uri field

If hp-clean requires specific Qt and PyQt 4 packages to run, shouldn't that be a dependency? Or maybe hp-clean should be in hplip-gui rather than in hplip, if it won't run in non-GUI mode.

Changed in hplip:
status: New → Invalid
goutam kodu (goutam-hplip) wrote :

Hi,

Can you please post us the out-put of "hp-check -t" command and "hp-clean -i -g" command.

Thanks & Regards,
Goutam Kodu

Akkana Peck (akkzilla) wrote :

The first time, hp-check told me I wasn't in the lp group (I was in lpadmin). So I added myself, logged out and back in and tried again. Here's the result. BTW, dbus is present and running (two dbus-daemons and one dbus-launch), but there's no hp-systray installed.

Till Kamppeter (till-kamppeter) wrote :

hp-clean generally works in text mode when calling it with the "-i" option. Warnings about hp-systray can be ignored.

HPLIP developers at HP: Can you suppress any warnings about missing Qt and in such a case simply automatically switch to text mode? Can you also suppress any warnings about not being able to connect with hp-systray or not being able to start hp-systray? This makes it easier to work on systems without Qt or when SSHing in from a remote box. Can you also do this for the other command line tools of HPLIP? Thanks.

Changed in hplip:
status: Invalid → Confirmed
Changed in hplip (Ubuntu):
status: New → Confirmed
Akkana Peck (akkzilla) wrote :

-i doesn't work here either. Is it just that hp-clean doesn't support the Deskjet F4280 model? hp-clean -i -g says
debug: Device URI usb://HP/Deskjet%20F4200%20series?serial=CN98Q5Z1XF05BR is invalid/unknown
(I didn't give it that device-uri -- hp-clean found it, either from CUPS or from querying USB).

If it's that the model can't clean its print heads, is there any chance you could make the error message a little clearer? "No device selected/specified or that supports this functionality." sounds like it couldn't find the printer at all, leading to a lot of wasted time trying to solve the wrong problem. Thanks!

Till Kamppeter (till-kamppeter) wrote :

You did not set up your printer correctly. You are using the standard USB backend of CUPS ("usb://..." device URI). You need to set it up with the HP backend ("hp:/..." device URI). To do so, use system-config-printer or hp-setup. These programs use the HP backend by default.

gf (gf-interlinks) wrote :

Hello Akkana,
Thank you for submitting this bug and reporting a problem with the hplip package. You made this bug report in 2011 and Ubuntu and hplip have been updated since then.

Could you confirm that this is no longer a problem and that we can close the ticket?
If it is still a problem, are you still interested in finding a solution to this bug?
If you are, could you let us know and, in the current version, could you run the following (only once):
apport-collect 816531
and upload the updated logs and and any other logs that are relevant for this particular issue.

Thank you again for helping make Ubuntu better.
G
[Ubuntu Bug Squad volunteer triager]

Changed in hplip (Ubuntu):
status: Confirmed → Incomplete
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers