[natty] Cannot set up fax print queue for hp1522nf

Bug #790238 reported by Stefan Bader on 2011-05-30
14
This bug affects 2 people
Affects Status Importance Assigned to Milestone
HPLIP
Undecided
Unassigned
hplip (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: hplip

Installation of the printer via hp-setup was allowing to create a fax queue in parallel with Maverick and before.
The same procedure does not work anymore with Natty.

ProblemType: Bug
DistroRelease: Ubuntu 11.04
Package: hplip 3.11.1-2ubuntu2 [modified: var/lib/hp/hplip.state]
ProcVersionSignature: Ubuntu 2.6.38-8.42-generic 2.6.38.2
Uname: Linux 2.6.38-8-generic x86_64
NonfreeKernelModules: fglrx
Architecture: amd64
Date: Mon May 30 16:06:19 2011
EcryptfsInUse: Yes
InstallationMedia: Ubuntu 11.04 "Natty Narwhal" - Release amd64 (20110426)
Lpstat: device for hp1522: hp:/net/HP_LaserJet_M1522nf_MFP?zc=hp1522nf
MachineType: To Be Filled By O.E.M. To Be Filled By O.E.M.
Papersize: a4
PpdFiles: hp1522: HP LaserJet m1522nf MFP pcl3, hpcups 3.11.1
ProcEnviron:
 LANGUAGE=en_GB:en
 PATH=(custom, user)
 LANG=de_DE.UTF-8
 LC_MESSAGES=en_GB.UTF-8
 SHELL=/bin/bash
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-2.6.38-8-generic root=UUID=2eab68c5-c6fa-405d-a360-1f6f1690bbb3 ro acpi_skip_timer_override quiet splash vt.handoff=7
SourcePackage: hplip
UpgradeStatus: No upgrade log present (probably fresh install)
dmi.bios.date: 04/09/2009
dmi.bios.vendor: American Megatrends Inc.
dmi.bios.version: P1.60
dmi.board.name: ALiveDual-eSATA2
dmi.board.vendor: ASRock
dmi.chassis.asset.tag: To Be Filled By O.E.M.
dmi.chassis.type: 3
dmi.chassis.vendor: To Be Filled By O.E.M.
dmi.chassis.version: To Be Filled By O.E.M.
dmi.modalias: dmi:bvnAmericanMegatrendsInc.:bvrP1.60:bd04/09/2009:svnToBeFilledByO.E.M.:pnToBeFilledByO.E.M.:pvrToBeFilledByO.E.M.:rvnASRock:rnALiveDual-eSATA2:rvr:cvnToBeFilledByO.E.M.:ct3:cvrToBeFilledByO.E.M.:
dmi.product.name: To Be Filled By O.E.M.
dmi.product.version: To Be Filled By O.E.M.
dmi.sys.vendor: To Be Filled By O.E.M.

Related branches

Stefan Bader (smb) wrote :
Till Kamppeter (till-kamppeter) wrote :

To the HPLIP developers at HP: It looks like that something has changed with the HPLIP support for the HP LaserJet m1522nf MFP. It seems that its fax capability is not recognized any more. Can someone have a look? Thanks.

Stefan Bader (smb) wrote :

The same still happens with the Oneiric release. I could provide additional debugging if someone could give me any pointers to start with.

Till Kamppeter (till-kamppeter) wrote :

Can someone of the HPLIP developers at HP check what happened here? The entry for the HP LaserJet M1522nf MFP in the /usr/share/hplip/data/models/models.dat file says "fax-type=0" in HPLIP 3.11.10, which probably means that the device has no fax. In reality it has fax and the fax was supported in older releases of HPLIP. Why was the fax support removed? Can it get reintroduced by editing the "fax-type" entry? Which fax-type has to be set then? Can the fax support for this printer be fixed in the next HPLIP release?

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in hplip (Ubuntu):
status: New → Confirmed
Jorge Juan (jjchico) wrote :

Somehow, fax support from HPLIP for the m1522nf has been dropped. It still does not work in Ubuntu 12.04 (Precise).

hplip web page says that support for this printer is full [1] but also says that PC-fax does not work. PC-fax should work according to full support definition in [2].

Will PC-fax be supported again in the future?

[1] http://hplipopensource.com/hplip-web/models/laserjet/hp_laserjet_m1522nf_mfp.html
[2] http://hplipopensource.com/node/237

Till Kamppeter (till-kamppeter) wrote :

Can someone at HP help here? Thanks.

goutam kodu (goutam-hplip) wrote :

Apologize for not looking into this issue at the earliest.
We are working on the fax support for this device. We will get back on this very soon.

Sorry for the inconvenience.

Regards,
Goutam Kodu

goutam kodu (goutam-hplip) wrote :

Try setting fax-type = 4 in /usr/share/hplip/data/models.dat file in the section [hp_laserjet_m1522nf_mfp] and try running command hp-setup to setup the fax queue and check if this option is working for you.

Jorge Juan (jjchico) wrote :

Yes, fax-type = 4 makes the PC-fax function to work again. Thanks.

Does it mean that this will be corrected in the next hplip release?

goutam kodu (goutam-hplip) wrote :

Yes we are going to correct this for the next hplip release.
Sorry for the inconvenience caused.

Thanks & Regards,
Goutam Kodu

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package hplip - 3.12.2-1ubuntu3

---------------
hplip (3.12.2-1ubuntu3) precise; urgency=low

  * debian/patches/fax-support-hp-laserjet-m1522nf-mfp.dpatch: Fixed fax
    sending support for the HP LaserJet M1522nf MFP (LP: #790238).
 -- Till Kamppeter <email address hidden> Wed, 4 Apr 2012 13:59:00 +0200

Changed in hplip (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers