hp deskjet d2660 prints only one page and then: stopped "/usr/lib/cups/filter/pdftoraster failed"

Bug #665190 reported by Mario Marín on 2010-10-22

This bug report was converted into a question: question #130731: hp deskjet d2660 prints only one page and then: stopped "/usr/lib/cups/filter/pdftoraster failed".

6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
hplip (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: hplip

I followed these instructions from http://ubuntuforums.org/showthread.php?t=1554174&highlight=deskjet+2660:

1. Install the package hplip-cups using Synaptic or Ubuntu Software Center.
2. Go to the Main Menu, System>Administration>Printing. Right click on the printer icon(HP-Deskjet-D2600-Series) and select Properties.
3. On Settings, Make and Model, click Change... (It will search for drivers, then the Change Driver window will appear)
4. Choose Driver, Select printer from database, HP. Click Forward.
5. From the list of Models, select Deskjet d2600. On the list of Drivers, select HP Deskjet d2600 Series, hpcups 3.10.2 [en]. Click Forward.
6. Select anything from the options (Use the new PPD as is, or Try to copy option settings over...). Then click Apply.
7. Now Print a Test Page or something.

I tried automatic install from source:

http://hplipopensource.com/hplip-web/install_wizard/index.html

Manual install

http://hplipopensource.com/hplip-web/install/manual/index.html

Neither of those troubleshoots worked; I know there is bug: https://bugs.launchpad.net/hplip/+bug/608443. But the comments suggest that everyone could print after some troubleshooting, I didn't have the same luck. Furthermore, I am having additional problems with hp-setup, here is the terminal output after I run it:

  File "/usr/bin/hp-setup", line 45, in <module>
    from base import device, utils, tui, models, module
  File "/usr/share/hplip/base/device.py", line 37, in <module>
    import status
  File "/usr/share/hplip/base/status.py", line 45, in <module>
    import hpmudext

But the library libhpmud is installed:

user@user-laptop:~$ dpkg -L libhpmud0
/.
/usr
/usr/share
/usr/share/lintian
/usr/share/lintian/overrides
/usr/share/lintian/overrides/libhpmud0
/usr/share/doc
/usr/share/doc/libhpmud0
/usr/share/doc/libhpmud0/copyright
/usr/share/doc/libhpmud0/changelog.Debian.gz
/usr/lib
/usr/lib/libhpip.so.0.0.1
/usr/lib/libhpmud.so.0.0.6
/lib
/lib/udev
/lib/udev/rules.d
/lib/udev/rules.d/40-hplip.rules
/usr/lib/libhpip.so.0
/usr/lib/libhpmud.so.0

user@user-laptop:~$ dpkg -l libhpmud0
Desired=Unknown/Install/Remove/Purge/Hold
| Status=Not/Inst/Conf-files/Unpacked/halF-conf/Half-inst/trig-aWait/Trig-pend
|/ Err?=(none)/Reinst-required (Status,Err: uppercase=bad)
||/ Name Version Description
+++-================-================-================================================
ii libhpmud0 3.10.6-1ubuntu10 HP Multi-Point Transport Driver (hpmud) run-time

I don't know what else to do. Thanks in advanced.

ProblemType: Bug
DistroRelease: Ubuntu 10.10
Package: hplip 3.10.6-1ubuntu10
ProcVersionSignature: Ubuntu 2.6.35-22.33-generic 2.6.35.4
Uname: Linux 2.6.35-22-generic x86_64
Architecture: amd64
Date: Fri Oct 22 10:51:20 2010
InstallationMedia: Ubuntu 10.10 "Maverick Meerkat" - Beta amd64 (20100901.1)
Lpstat: device for HP_Deskjet_D2600_series: usb://HP/Deskjet%20D2600%20series?serial=CN03HFF2KX05C9
MachineType: Hewlett-Packard Compaq Presario C700 Notebook PC
Papersize: letter
PpdFiles: HP_Deskjet_D2600_series: HP Deskjet d2600 Series, hpcups 3.10.6
ProcCmdLine: BOOT_IMAGE=/boot/vmlinuz-2.6.35-22-generic root=UUID=d3234190-46a0-458a-af1d-0deaab6ec139 ro quiet splash
ProcEnviron:
 PATH=(custom, no user)
 LANG=en_US.utf8
 SHELL=/bin/bash
SourcePackage: hplip
dmi.bios.date: 04/29/2008
dmi.bios.vendor: Hewlett-Packard
dmi.bios.version: F.33
dmi.board.asset.tag: Base Board Asset Tag
dmi.board.name: 30D9
dmi.board.vendor: Hewlett-Packard
dmi.board.version: 83.21
dmi.chassis.type: 10
dmi.chassis.vendor: Hewlett-Packard
dmi.chassis.version: N/A
dmi.modalias: dmi:bvnHewlett-Packard:bvrF.33:bd04/29/2008:svnHewlett-Packard:pnCompaqPresarioC700NotebookPC:pvrF.33:rvnHewlett-Packard:rn30D9:rvr83.21:cvnHewlett-Packard:ct10:cvrN/A:
dmi.product.name: Compaq Presario C700 Notebook PC
dmi.product.version: F.33
dmi.sys.vendor: Hewlett-Packard

Mario Marín (mmfmarin) wrote :
Mario Marín (mmfmarin) wrote :

I just needed to attach files and it was faster with ubuntu-bug.

Changed in hplip (Ubuntu):
status: New → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers