On HP Deskjet 1050/2050 scanning does not work

Bug #652963 reported by Andy S on 2010-10-01
34
This bug affects 6 people
Affects Status Importance Assigned to Milestone
HPLIP
Undecided
Unassigned
hplip (Ubuntu)
Medium
manuel simón

Bug Description

Binary package hint: hplip

Just following on from advice given:

"Yash said on 2010-09-21:

We will support scanning of 1050 in future HPLIP release. Please create bug in launch pad for the same.
Thanks for contacting HPLIP"

Link:

https://answers.launchpad.net/hplip/+question/125633

as I see it hasn't been done yet and I have a Deskjet 1050 here now.

It isn't mine so others may have to follow this one up.

ProblemType: Bug
DistroRelease: Ubuntu 10.10
Package: hplip 3.10.6-1ubuntu10
ProcVersionSignature: Ubuntu 2.6.35-22.33-generic 2.6.35.4
Uname: Linux 2.6.35-22-generic i686
Architecture: i386
CupsErrorLog: E [01/Oct/2010:13:14:24 +0100] [cups-driverd] Bad driver information file "/usr/share/cups/drv/sample.drv"!
Date: Fri Oct 1 13:32:59 2010
InstallationMedia: Ubuntu 9.10 "Karmic Koala" - Release Candidate i386 (20091019.2)
Lpstat: device for Deskjet-1050-J410-series: hp:/usb/Deskjet_1050_J410_series?serial=CN0732P0K505HW
MachineType: Gigabyte Technology Co., Ltd. GA-MA785GMT-UD2H
Papersize: a4
PpdFiles: Deskjet-1050-J410-series: HP Deskjet 1050 j410 Series, hpcups 3.10.6
ProcCmdLine: BOOT_IMAGE=/boot/vmlinuz-2.6.35-22-generic root=UUID=c03cfb8e-753a-4d3f-af52-b8ccbce704e7 ro vga=885 splash
ProcEnviron:
 LANG=en_GB.utf8
 SHELL=/bin/bash
SourcePackage: hplip
dmi.bios.date: 07/03/2009
dmi.bios.vendor: Award Software International, Inc.
dmi.bios.version: F1
dmi.board.name: GA-MA785GMT-UD2H
dmi.board.vendor: Gigabyte Technology Co., Ltd.
dmi.board.version: x.x
dmi.chassis.type: 3
dmi.chassis.vendor: Gigabyte Technology Co., Ltd.
dmi.modalias: dmi:bvnAwardSoftwareInternational,Inc.:bvrF1:bd07/03/2009:svnGigabyteTechnologyCo.,Ltd.:pnGA-MA785GMT-UD2H:pvr:rvnGigabyteTechnologyCo.,Ltd.:rnGA-MA785GMT-UD2H:rvrx.x:cvnGigabyteTechnologyCo.,Ltd.:ct3:cvr:
dmi.product.name: GA-MA785GMT-UD2H
dmi.sys.vendor: Gigabyte Technology Co., Ltd.

Related branches

Andy S (andys-bristolwireless) wrote :
Till Kamppeter (till-kamppeter) wrote :

This is meant for the upstream HPLIP project by HP, not for Ubuntu's packaging. Adding upstream task.

Changed in hplip (Ubuntu):
status: New → Confirmed
Changed in hplip:
status: New → Confirmed
Changed in hplip:
status: Confirmed → Triaged
Changed in hplip:
status: Triaged → Fix Committed

Please download the latest HPLIP 3.10.9 from www.hplipopensource.com site and install.
once installed open /usr/share/hplip/data/models/models.dat file as root.
edit section "deskjet_1050_j410_series" and set "io-mfp-mode=1" and "scan-type=7" and save the file.

quit hp-toolbox / hp-systray if it is running.

launch "xsane" from terminal.

Thanks,
Naga Samrat Chowdary, Narla

Andy S (andys-bristolwireless) wrote :

Uninstallable at present on Ubuntu 10.10 - missing dependency cups-dev* (and possibly 4 more - installer fails one missing dependency at a time):

INSTALL MISSING REQUIRED DEPENDENCIES
-------------------------------------
warning: There are 5 missing REQUIRED dependencies.
note: Installation of dependencies requires an active internet connection.
warning: Missing REQUIRED dependency: cups-devel (CUPS devel- Common Unix Printing System development files)
warning: This installer cannot install 'cups-devel' for your distro/OS and/or version.
error: Installation cannot continue without this dependency. Please manually install this dependency and re-run this installer.

Yes - I have the deb-src repos enabled.

Presumably people will more likely to try getting this printer/scanner with Maverick than older releases.

Andy S (andys-bristolwireless) wrote :

OK - after guessing the actual package names of the missing depends, got the latest hplip to install and after editing /usr/share/hplip/data/models/models.dat as per instructions above (then re-connecting device) scan functions.

Will leave the packaging of a newer hplip to the experts!

Thanks for the fix!

Solution apported by Naga Samrat i has been Ok to me.
Thank you and Regards

Yulin Chen (chen-yulin-yehe) wrote :

I got a HP Deskjet 2050 all in one printer/scanner, and the scan function does not work also, and I set "io-mfp-mode=1" and "scan-type=7" and save the file also, the scan function works.

I test solution aported by Naga Samrat and was Ok for HP Deskjet 1050's scan.However, I've got another printer (HP Deskjet 3940) and after making changes in models.dat to allow acces at 1050 scan, printer 3940 have left to work. And system says impossible communicate with printer (more or less this message).
Thnk & KRGRs

Wim Deblauwe (wim-deblauwe) wrote :

I also get a HP Deskjet 2050, but it does not seem to work (I am on Ubuntu 10.10). I tried to install hplip, but it says that I miss gcc, while apt-get says that I already have the latest version installed. Any thoughts on what I can try next ?

Please follow the attached patch at
https://answers.launchpad.net/hplip/+faq/1356
 <https://answers.launchpad.net/hplip/+faq/1356>and re-install.
once installed, then apply the patch specific to HP Deskjet 2050.

Thanks,
Naga Samrat Chowdary, Narla

On Sun, Nov 21, 2010 at 20:06, Wim Deblauwe <email address hidden> wrote:

> I also get a HP Deskjet 2050, but it does not seem to work (I am on
> Ubuntu 10.10). I tried to install hplip, but it says that I miss gcc,
> while apt-get says that I already have the latest version installed. Any
> thoughts on what I can try next ?
>
> --
> HP Deskjet 1050 scan scanning not functioning
> https://bugs.launchpad.net/bugs/652963
> You received this bug notification because you are subscribed to HPLIP.
>
> Status in HP Linux Imaging and Printing: Fix Committed
> Status in “hplip” package in Ubuntu: Confirmed
>
> Bug description:
> Binary package hint: hplip
>
> Just following on from advice given:
>
> "Yash said on 2010-09-21:
>
> We will support scanning of 1050 in future HPLIP release. Please create bug
> in launch pad for the same.
> Thanks for contacting HPLIP"
>
> Link:
>
> https://answers.launchpad.net/hplip/+question/125633
>
> as I see it hasn't been done yet and I have a Deskjet 1050 here now.
>
> It isn't mine so others may have to follow this one up.
>
> ProblemType: Bug
> DistroRelease: Ubuntu 10.10
> Package: hplip 3.10.6-1ubuntu10
> ProcVersionSignature: Ubuntu 2.6.35-22.33-generic 2.6.35.4
> Uname: Linux 2.6.35-22-generic i686
> Architecture: i386
> CupsErrorLog: E [01/Oct/2010:13:14:24 +0100] [cups-driverd] Bad driver
> information file "/usr/share/cups/drv/sample.drv"!
> Date: Fri Oct 1 13:32:59 2010
> InstallationMedia: Ubuntu 9.10 "Karmic Koala" - Release Candidate i386
> (20091019.2)
> Lpstat: device for Deskjet-1050-J410-series:
> hp:/usb/Deskjet_1050_J410_series?serial=CN0732P0K505HW
> MachineType: Gigabyte Technology Co., Ltd. GA-MA785GMT-UD2H
> Papersize: a4
> PpdFiles: Deskjet-1050-J410-series: HP Deskjet 1050 j410 Series, hpcups
> 3.10.6
> ProcCmdLine: BOOT_IMAGE=/boot/vmlinuz-2.6.35-22-generic
> root=UUID=c03cfb8e-753a-4d3f-af52-b8ccbce704e7 ro vga=885 splash
> ProcEnviron:
> LANG=en_GB.utf8
> SHELL=/bin/bash
> SourcePackage: hplip
> dmi.bios.date: 07/03/2009
> dmi.bios.vendor: Award Software International, Inc.
> dmi.bios.version: F1
> dmi.board.name: GA-MA785GMT-UD2H
> dmi.board.vendor: Gigabyte Technology Co., Ltd.
> dmi.board.version: x.x
> dmi.chassis.type: 3
> dmi.chassis.vendor: Gigabyte Technology Co., Ltd.
> dmi.modalias:
> dmi:bvnAwardSoftwareInternational,Inc.:bvrF1:bd07/03/2009:svnGigabyteTechnologyCo.,Ltd.:pnGA-MA785GMT-UD2H:pvr:rvnGigabyteTechnologyCo.,Ltd.:rnGA-MA785GMT-UD2H:rvrx.x:cvnGigabyteTechnologyCo.,Ltd.:ct3:cvr:
> dmi.product.name: GA-MA785GMT-UD2H
> dmi.sys.vendor: Gigabyte Technology Co., Ltd.
>
>
>

Thank you Naga Samrat Chowdary! I searched for hours yesterday to find a solution, but was unsuccessful. Today, I finally found your comment (written on 2010-10-03), which now has my scanner working! I very much appreciate you taking time to post this solution.

Can you try whether scanning works out-of-the-box with HPLIP 3.10.9? I have packaged it for Natty today.

Changed in hplip (Ubuntu):
status: Confirmed → Incomplete

All scan code is available for this printer on HPLIP 3.10.9 release.
To scan work on this printer, In addition to HPLIP 3.10.9 code, we need to update models.dat file with #3 comments.

Thanks,
Naga Samrat Chowdary, Narla

Changed in hplip (Ubuntu):
status: Incomplete → In Progress
importance: Undecided → Medium
summary: - HP Deskjet 1050 scan scanning not functioning
+ On HP Deskjet 1050/2050 scanning does not work

Applied the changes in models.dat to the Ubuntu Natty package.

Changed in hplip (Ubuntu):
status: In Progress → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package hplip - 3.10.9-0ubuntu7

---------------
hplip (3.10.9-0ubuntu7) natty; urgency=low

  * debian/patches/scan-on-dj-1050-2050.dpatch: Corrected model properties
    to make scanning on DeskJet 1050 and 2050 actually working (LP: #652963)
 -- Till Kamppeter <email address hidden> Sat, 11 Dec 2010 14:10:18 +0100

Changed in hplip (Ubuntu):
status: Fix Committed → Fix Released
Dred (dreadlocks) wrote :

Hi,

For the time being as a work around, please do the following steps;

From HP support:

Open /usr/share/hplip/data/models/models.dat file as root. Go to section [deskjet_1050_j410_series] and set "io-mfp-mode=1" and "scan-type=7" and save the file.

Now your scan should work.

Ken Phillis Jr (kphillisjr) wrote :

Just tested with the recommended fixes, and the scan functionality does not work. However, my system is running x86_64. However, as a bonus, print functionality is fixed using the hplip 3.10.9 source package. Anyways, the specific error is as follows when running simple-scan...

** (simple-scan:12476): WARNING **: Unable to get open device: Device busy

also, xsane produces similar responses.

Also just tested with recommended fixes, and the scan functionality does not work.

Tested on 2 systems: Ubuntu 10.04 LTS and 10.10. Both also x86_64.

Error message after running xsane: "Failed to open device hpaio:/usb/Deskjet_1050_J410_series?seria=CN07M2P3G505HW: Device busy.".

I downloaded hplip 3.10.9, unpacked, modified the right section of models.dat included in the package, installed all requested dependencies (needed to run ./configure repeatedly to install all needed packages). then:

./configure --disable-network-build
make
sudo make install
sudo reboot

still no success...

configure with the following steps from hplip-3.10.9 directory
sudo make uninstall
male clean
./configure --prefix=/usr
make
sudo make install

Thanks,
Naga Samrat Chowdary, Narla

On Sat, Jan 8, 2011 at 22:26, Jan Ostrochovsky <email address hidden>wrote:

> Also just tested with recommended fixes, and the scan functionality does
> not work.
>
> Tested on 2 systems: Ubuntu 10.04 LTS and 10.10. Both also x86_64.
>
> Error message after running xsane: "Failed to open device
> hpaio:/usb/Deskjet_1050_J410_series?seria=CN07M2P3G505HW: Device busy."

Naga, not you, but I say THANKS!

I applied your recommendation and now it works on both systems.

I am using Ubuntu for several years, I love it and the promptness, how huge majority of all problems can be solved with easiness, thanks to people like you. Ubuntu and its community is superior, I love you !!

Ostry (after whole-night amusement, so excuse expressive expressions ;)

emaTux (ematux) wrote :

also for me the scan fuctionality work with the command "./configure --prefix=/usr" and HP Deskjet 2050 on Ubuntu 10.10 64bit!

Thanks!

palimmo (palimmo) wrote :

I'm sorry, but I have serious problems to follow these instructions.
I've tried to install hplip-3.10.9 on my Ubuntu 10.10 64 bit to use my new HP Deskjet 1050 without success.

Can you repeat with precision the correct sequence to install it correctly?
Thanks in advance,
Alessio

(at the moment... I try to open Xsane but it replies: It's not possible open the device 'hpaio:/usb/Deskjet_1050_J410_series?serial=CN08H2J48X05HW': device is busy. )

palimmo (palimmo) wrote :

With
./configure --prefix=/usr
I got this error
configure: error: cannot find net/ucd-snmp support (or --disable-network-build)

With
./configure --disable-network-build
I got
configure: error: cannot find sane-backends-devel support (or --disable-scan-build)

And with
./configure --disable-scan-build
I got
configure: error: cannot find net/ucd-snmp support (or --disable-network-build

palimmo (palimmo) wrote :

Yes!!
It works now!
Solved installing missed packages like snmptt and libsane-dev

Thank you soooo much!
alessio

Knarfix (frankkurian) wrote :

Hi,

I too have a HP Deskjet 2050 on Ubuntu 10.10 64bit, somehow no luck.
xsane says no devices available. Printing is no problem.

Before following the instruction I saw here, I had tried the hplip-3.10.9.run.
Could this be the reason why the scanner is not working?

Thanks :)

Knarfix (frankkurian) wrote :

.....it is working after i redid the changes in /usr/share/hplip/models/models.dat. Thanks a lot :)

carlos cerrato (scriptfang) wrote :

I am amused with the vitality of the Ubuntu community in particular, and Linux in general.

Let me say.

Mr Naga .... you rocks...!!!

I follow your instructions and all is working now. Thank you.

After I made the modifications you give us in ... /model .... I tried xsane and something looks fine.
But ...
In the process I received a message like: device not ready ... or something like that.

the system (xsane) recognized the scanner. let me scan in low resolution, then when I try to scan a document I found two problems.

1) I mentioned it already. Problems with recognizing the scanner. Playing a little with the configuration (of xsane) was solved. (I documented but ... I can't found my notes.)

2) All the time xsane tryes to use the same name for the file (I choose JPEG). the solution? Insert a number 1 in the name. something like .... scan1.JPEG from here xsane increments the number in steps (you can chose the steps, normally 1).

This notes are written thinking in people like me, not Mr. Naga.

Good luck.

carlos

Changed in hplip:
status: Fix Committed → Fix Released
aum11 (jayavinda) wrote :

FYI, just downloaded hplip 3.11.1 and everything on the 2050 worked perfectly, including scanning , with no changes required.

This is on Ubuntu 10.04.

Thanks.

amadenri (amadenri) wrote :

Same success as aum11 (with no changes). On Ubuntu 10.10 64 bit.

Bye.

Wang Xiaoyun (wangxiaoyun) wrote :

I'm not able to install hplip 3.11.1 on my Ubuntu 10.10 64 bit. Several dependency conflicts can not be solved.

Running 'sudo apt-get install --assume-yes libcups2-dev'
Please wait, this may take several minutes...
error: Command failed. Re-try #1...#3
Running 'sudo apt-get install --assume-yes libcups2-dev'
Please wait, this may take several minutes...
error: Package install command failed with error code 100
error: Command failed. Re-try #1...#3
Running 'sudo apt-get install --assume-yes libcupsimage2-dev'
Please wait, this may take several minutes...
error: Package install command failed with error code 100
error: Command failed. Re-try #1...#3
Running 'sudo apt-get install --assume-yes libsane-dev'
Please wait, this may take several minutes...
error: Package install command failed with error code 100

When I want to install those in Synaptic, I got errors such as following.

libcups2-dev:
  Depends: libcups2 (=1.4.4-6ubuntu2) but 1.4.4-6ubuntu2.3 is to be installed

According to Synaptic, libcups2 on my machine is 1.4.4-6ubuntu2.3 actually.

Could someone shed some light on it? Thanks in advance.

Changed in hplip (Ubuntu):
assignee: nobody → manuel simón (manumaya75)
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers