Fax PPD not installed by default

Bug #59409 reported by Till Kamppeter on 2006-09-07
30
This bug affects 3 people
Affects Status Importance Assigned to Milestone
HPLIP
Medium
Unassigned
hplip (Debian)
Fix Released
Unknown
hplip (Ubuntu)
Medium
Till Kamppeter
Declined for Gutsy by Henrik Nilsen Omma
Hardy
Medium
Till Kamppeter

Bug Description

Binary package hint: hplip

On a default installation of Ubuntu Linux (Edgy) I cannot install a Fax queue for HPLIP because the appropriate PPD file is missing.

The Fax PPD file is in the binary package hpijs-ppds and this package is not installed as there is already the Foomatic data for the HPIJS PPDs (foomatic-db-hpijs), and so CUPS 1.2 generates the HPIJS PPDs on the fly. The problem is that there is no Foomatic data for the Fax PPD and therefore it is not available.

My suggestion for a fix is moving the Fax PPD file into the package which contains "hp-sendfax" (package "hplip"), as "hp-sendfax" only makes sense if there is a CUPS queue with the Fax PPD. Then the Fax PPD will be available without adding tons of unneeded PPDs.

Changed in hplip:
status: Unconfirmed → Confirmed

ubuntu-desktop used to have a dependency on hpijs-ppds making it install by default but this was removed on 29 Aug.

ubuntu-meta (1.17) edgy; urgency=low

  * Refreshed dependencies
  * Removed hpijs-ppds from desktop-i386, desktop-amd64, desktop-
    powerpc, desktop-ia64, desktop-sparc, desktop-hppa
  * Removed foomatic-filters-ppds from desktop-i386, desktop-amd64,
    desktop-powerpc, desktop-ia64, desktop-sparc, desktop-hppa

 -- Tollef Fog Heen <email address hidden> Tue, 29 Aug 2006 14:41:49 +0200

> And so CUPS 1.2 generates the HPIJS PPDs on the fly.

PPDs are NOT generated on the fly on my Edgy system, did you put a symlink in /usr/lib/cups/driver manually?
I have suggested to move to dynamically generated PPDs here: https://lists.ubuntu.com/archives/ubuntu-devel/2006-August/020320.html
But currently a symlink from /usr/lib/cups/driver/foomatic to /usr/bin/foomatic-ppdfile is not present in Edgy and the static PPD files under /usr/share/ppd are used.
Since hpijs-ppds and foomatic-filters-ppds were removed from ubuntu-desktop this would mean that a freshly installed Edgy would have nearly no printer drivers installed?
The decision of using dynamically generated PPDs versus static PPDs should be worked out as soon as possible.

> Then the Fax PPD will be available without adding tons of unneeded PPDs.

I don't agree since we still need the static hpijs-ppds at this moment to setup a printer queue with hp-setup from hplip.

For the hpijs PPDs it is a little bit difficult to decide weather to include static or dynamically generated PPDs only for 2 reasons:
1. The hp-setup printer queue setup tool from hplip only works with static PPDs. We could keep the HP hpijs PPDs together with real PostScript PPDs from hplip source but they shouldn't be installed under /usr/share/ppd to avoid duplicate entries when PPDs are retrieved via the CUPS API. They could be installed under e.g. /usr/share/hplip/ppd. It would still be better to alter hp-setup to use the CUPS API or the command line interface for driver programs for retrieving PPDs, because then the same PPD file would be used independent of the printer queue setup tool that was used.
Another possibillity would be to remove hp-setup from Ubuntu so it can't be used for queue setup.
2. Moving to dynamically generated PPDs from foomatic-db-hpijs would provide the missing non-HP hpijs PPDs (see Malone bug #49102).

So it looks like we need both at this moment, what is you opinion about this Till?

Till Kamppeter (till-kamppeter) wrote :

As the Fax PPD is not generated by Foomatic data we have decided to move it into the hpijs sub-package which makes part of the standard installation. Now it is always available.

Changed in hplip:
status: Confirmed → Fix Released
unggnu (unggnu) wrote :

This happens again in Gutsy. While installing my printer with fax functionality I got the error "Unable to find HP fax PPD file. - Please check your HPLIP installation and try again.".
I have searched for this file and it seems that one file has been deleted since Feisty. Maybe that is the problem.

Feisty:
usr/lib/hplip/fax/HP-Fax-hplip.ppd utils/hplip
usr/share/ppd/hpijs/HP/HP-Fax-hplip.ppd.gz text/hpijs

Gutsy:
usr/share/ppd/hpijs/HP/HP-Fax-hplip.ppd.gz text/hpijs

Changed in hplip:
status: Fix Released → New
Henrik Nilsen Omma (henrik) wrote :

Till, can you check if this is a regression from Edgy/Feisty to Gutsy (or am I mistaken in thinking that it did work at some point)?

Changed in hplip:
assignee: nobody → till-kamppeter
importance: Undecided → Low
status: New → Incomplete
Till Kamppeter (till-kamppeter) wrote :

The PPD file is in place and provided by the hpijs package which should be in the standard installation:

till@till-laptop:~/ubuntu/cupsys$ dpkg -S /usr/share/ppd/hpijs/HP/HP-Fax-hplip.ppd.gz
hpijs: /usr/share/ppd/hpijs/HP/HP-Fax-hplip.ppd.gz
till@till-laptop:~/ubuntu/cupsys$

Strange thing is that hp-setup does not find this file.

Changed in hplip:
status: New → Confirmed
Till Kamppeter (till-kamppeter) wrote :

Dave, Raghu, Don, it seems that hp-setup searches for the fax PPD at another place than CUPS:

hp-setup: /usr/lib/hplip/fax/HP-Fax-hplip.ppd

CUPS: /usr/share/ppd/hpijs/HP/HP-Fax-hplip.ppd.gz

Can you make hp-setup searching at the same place as CUPS to eliminate needing two copies of the PPD?

Till--I was going to submit a seperate bug however found this one and I think they are related. I'll also send this to the rest of the team and see if they have any thoughts on it.

Issue:
Using the pre-installed HPLIP to configure a printer (in this case photosmart 3310) the hp-setup is not correctly selecting the fax ppd.

Steps:
Clean gutsy system
Install python-qt3
Run hp-setup
Configure a printer with fax using the default settings (i tested a networked photosmart 3310)
Error at the end "Unable to find HP Fax PPD File. Please check your HPLIP installation and try again."

Install Log:

FAX QUEUE SETUP
hp-setup[9738]: debug: {}

 q=quit) ?er a name for this fax queue (m=use model name:'Photosmart_3300_fax'*,
Using queue name: Photosmart_3300_fax
hp-setup[9738]: debug: Found PDD file: lsb/usr/hpijs/HP/HP-Fax-hplip.ppd.gz
Enter a location description for this printer (q=quit) ?
Enter additonal information or notes for this printer (q=quit) ?

Adding fax queue to CUPS:
Device URI: hpfax:/net/Photosmart_3300_series?ip=15.252.59.48
Queue name: Photosmart_3300_fax
PPD file: lsb/usr/hpijs/HP/HP-Fax-hplip.ppd.gz
Location:
Information:
hp-setup[9738]: debug: addPrinter('Photosmart_3300_fax', 'hpfax:/net/Photosmart_3300_series?ip=15.252.59.48', '', 'lsb/usr/hpijs/HP/HP- Fax-hplip.ppd.gz', '', '')
error: PPD file 'lsb/usr/hpijs/HP/HP-Fax-hplip.ppd.gz' not found.
hp-setup[9738]: debug: {}
error: Fax queue setup failed. Please restart CUPS and try again.

Locate Fax PPD:
sudo updatedb
locate Fax outputs:
/usr/share/ppd/hpijs/HP/HP-Fax-hplip.ppd.gz

The problem:
Setup is looking for :
hp-setup[9738]: debug: Found PDD file: lsb/usr/hpijs/HP/HP-Fax-hplip.ppd.gz

Notice the LSB/USR..
It should be /usr/share/ppd, not lsb/usr/...also the file seems to be in /usr/share/ppd/hpijs/HP while setup is looking in /usr/hpijs/HP.

Works:
HPLIP 2.7.7 installed form source
HPLIP 2.7.10 installed from source

Does not work:
2.7.7.dfsg.1-0ubuntu5

I've been able to reproduce this several times, although I am unable to reproduce it after installing the HPLIP source (http://hplip.sf.net ) version 2.7.10 nor was I able to reproduce this by installing hplip 2.7.7..seems to be only the pre-installed ubuntu version.

Aaron

Till Kamppeter (till-kamppeter) wrote :

Aaron, the problem is the following:

If CUPS is asked for listing PPDs ("lpinfo -m" or equivalent IPP call), the returned paths are not necessarily real file system paths. They are more to understand as PPD URIs. To get safely any arbitrary PPD CUPS reports to you, you have to ask CUPS to give you the PPD. either by using "lpadmin" with the "-m" option and exactly the PPD URI as listed by "lpinfo -m" or by polling the PPD from CUPS via an appropriate IPP call. See the code of system-config-printer (in Ubuntu and Fedora) for a possible Python implementation.

dwelch91 (dwelch91) wrote :

hp-setup uses the CUPS call CUPS_GET_PPDS to get the list of PPDs. My assumption is that this is the same list that lpinfo -m gives (it appears to be).

dwelch91 (dwelch91) wrote :

hp-setup uses the path stored in /etc/hp/hplip.conf to locate the fax PPD file. For example:

[dirs]
home=/usr/share/hplip
run=/var/run
ppd=/usr/share/ppd/HP
ppdbase=/usr/share/ppd
doc=/usr/share/doc/hplip-2.7.12.0
icon=/usr/share/applications
cupsbackend=/usr/lib/cups/backend
foomatic=/usr/share/foomatic

The path specified by ppd= will be used to search for the file (in this case/usr/share/ppd/HP) . If this path is incorrect, the file will not be found. This path is setup during 'make install' and can be specified in the './configure' using the '--with-hpppddir=DIR' option (see http://hplip.sourceforge.net/tech_docs/tarball_install.html).

Till,
hp-setup should be using the "ppd" key value pair in hplip.conf to determine were the HP-Fax-hplip.ppd directory is. The "ppd" key value is set by the hplip configure time option "--with-hpppddir". The "--with-hpppdir" is where the Fax-hplip.ppd file is installed at "make install" time.

If hp-setup is searching at /usr/lib/hplip/fax/HP-Fax-hplip.ppd, but your package actually installed at /usr/share/ppd/hpijs/HP/HP-Fax-hplip.ppd.gz then I believe the hplip.conf was set incorrectly.

To resolve this problem, you should set "--with-hpppdir=/usr/share/ppd/hpijs/HP" at hplip configure time. This will reflect where your package actually puts the fax ppd file.

-dave

Dave, thank you. After hand-editing /etc/hp/hplip.conf to have the line

ppd=/usr/share/ppd/hpijs/HP/

creating a fax queue with hp-setup is no problem.

So I will let the package build with

./configure --with-hpppdir=/usr/share/ppd/hpijs/HP/

now and it should work out-of-the-box.

Changed in hplip:
status: Incomplete → Triaged
status: Confirmed → Invalid
Changed in hplip:
status: Triaged → In Progress
Changed in hplip:
status: In Progress → Fix Committed

hplip (2.7.10-5ubuntu1) hardy; urgency=low

  * Merge with Debian unstable. No remaining Ubuntu changes.
  * debian/rules: Added "--with-hpppddir=\$${prefix}/share/ppd/hpijs/HP" to
    "./configure" call so that "hp-setup" will find the fax PPD (Ubuntu bug
    LP: #59409).
  * debian/rules: Removed "--dpkg-shlibdeps-params=--ignore-missing-info"
    from dh_shlibdeps. Does not build under Ubuntu.

 -- Till Kamppeter <email address hidden> Thu, 6 Dec 2007 16:34:49 +0000

Changed in hplip:
status: Fix Committed → Fix Released
unggnu (unggnu) wrote :

Will there be an update for Gutsy with this fix?

henrik, now where the bug is fixed in Hardy, can you accept the nomination for Gutsy or at least allow nominating it again? I think this bug is a good SRU candidate.

Fabián Rodríguez (magicfab) wrote :

I am using Hardy Alpha 4 and still have this problem.

Click on the "browse to file" button at the error dialog shows an HP Fax PPD archive in the /usr/share/ppd/hpijs/HP/ directory but choosing it brings back another error:
"error: Incorrect fax PPD file. The fax PPD file must have a nickname of 'HP Fax', not 'HP Fax - HPLIP 2.7.12'."

The /etc/hp/hplip.conf file has the following line:
ppd=/usr/share/ppd/hpijs/HP

Instead of:
ppd=/usr/share/ppd/hpijs/HP/

I tried both with the same result.

hp-setup relies on the internal nickname of the PPD file to be a certain
string. If this is changed during packaging, either the code in hp-setup
will have to be changed, or it will not properly recognize the file.

On Feb 6, 2008 1:37 PM, Fabián Rodríguez <email address hidden> wrote:

> I am using Hardy Alpha 4 and still have this problem.
>
> Click on the "browse to file" button at the error dialog shows an HP Fax
> PPD archive in the /usr/share/ppd/hpijs/HP/ directory but choosing it brings
> back another error:
> "error: Incorrect fax PPD file. The fax PPD file must have a nickname of
> 'HP Fax', not 'HP Fax - HPLIP 2.7.12'."
>
> The /etc/hp/hplip.conf file has the following line:
> ppd=/usr/share/ppd/hpijs/HP
>
> Instead of:
> ppd=/usr/share/ppd/hpijs/HP/
>
> I tried both with the same result.
>
> --
> Fax PPD not installed by default
> https://bugs.launchpad.net/bugs/59409
> You received this bug notification because you are a direct subscriber
> of the bug.
>

unggnu (unggnu) wrote :

I can confirm that this still happens in current Hardy.

Changed in hplip:
status: Fix Released → Confirmed
Henrik Nilsen Omma (henrik) wrote :

Till, people are reporting this as not fixed in Hardy. It would be a nice Hardy-fix though -- bumping the priority.

Changed in hplip:
importance: Low → Medium
dwelch91 (dwelch91) wrote :

Please keep in mind that, starting with HPLIP 2.8.2, there are two (2) Fax
PPD files required for HPLIP Fax functionality (the second one handles a
different class of fax device that requires different parameters for
rendering).

On Mon, Feb 25, 2008 at 6:01 AM, Henrik Nilsen Omma <email address hidden>
wrote:

> Till, people are reporting this as not fixed in Hardy. It would be a
> nice Hardy-fix though -- bumping the priority.
>
> ** Changed in: hplip (Ubuntu)
> Importance: Low => Medium
>
> --
> Fax PPD not installed by default
> https://bugs.launchpad.net/bugs/59409
> You received this bug notification because you are a direct subscriber
> of the bug.
>

In the last packaging (2.8.2-0ubuntu1) I have removed all code which modifies the fax PPD from debian/rules. So the fax PPD is OK in the HPLIP package from the mentioned version on.

My /etc/hp/hplip.conf contains

ppd=/usr/share/ppd/hpijs/HP
ppdbase=/usr/share/ppd/hpijs

and with this hp-setup finds the fax PPD for me. These are also the settings of the hplip.conf of the original package.

Problem is here that /etc/hp/hplip.conf is a config file and for users who have tried to fix this problem manually the file gets never replaced with future updates.

As everything in /etc/hp/hplip.conf is distribution-specific and any manual change by the user would break HPLIP I would suggest to let the post-install script always replace the whole file with the standard one of the package. WDYT?

unggnu can you update to the current version of HPLIP (do a full update of your Hardy) and then try hp-setup again?

If it does not work, post /etc/hp/hplip.conf here and then edit it to have the lines

ppd=/usr/share/ppd/hpijs/HP
ppdbase=/usr/share/ppd/hpijs

Then try hp-setup again.

Post also your file

/usr/share/ppd/hpijs/HP/HP-Fax-hplip.ppd.gz

and the output of

dpkg -S /usr/share/ppd/hpijs/HP/HP-Fax-hplip.ppd.gz
dpkg -l "*hplip*"
dpkg -l "*hpijs*"

Don, Aaron, Raghu: My suggestion is that also the fax PPD should be assigned by CUPS, so if it floats around in the future HPLIP versions it will not depend on a path hard-coded into a config file. The assignment of the fax PPD by CUPS is used in the CUPS web interface and in system-config-printer and is absolutely reliable.

Reopening upstream task as a feature request ...

Changed in hplip:
status: Invalid → New
status: Confirmed → Incomplete

Don, what are the names of the two PPD files, where are they in the source tree, where do they get installed, and what are there pseudo device IDs? The device IDs should be different, hpfax should output the pseudo device ID so that CUPS selects the correct PPD and also the Nicknames and other PPD entries should correspond to the pseudo device IDs.

Please tell also which models need the second device ID, so that I can buy an appropriate printer on HP's PO to test the case of the second fax PPD and also whether system-config-printer handles the case correctly.

Don, I have found the second fax file now in the source tree:

fax/ppd/HP-Fax2-hplip.ppd

The pseudo device ID is:

MFG:HP;MDL:Fax;DES:HP Fax 2;

I suggest to modify it to

MFG:HP;MDL:Fax 2;DES:HP Fax 2;

as otherwise MFG and MDL are identical and so a printer setup tool which starts checking already after finding only MFG and MDL can confuse the files.

So please change this device ID to the version which I suggested and modify the hpfax CUPS backend appropriately, so that it outputs the device ID according to the actually connected fax device type. Please post also an appropriate patch for HPLIP 2.8.2 here, as we are already after feature freeze and therefore we cannot replace the complete HPLIP package.

unggnu, please tell also which printer model you have.

dwelch91 (dwelch91) wrote :

The two PPD files are:

-rw-rw-rw- 1 dwelch dwelch 5207 2007-12-04 14:56 HP-Fax2-hplip.ppd
-rw-rw-rw- 1 dwelch dwelch 5197 2007-12-04 14:58 HP-Fax-hplip.ppd

HP-Fax2-hplip.ppd is for these models (as of 2.8.2):
hp_laserjet_m2727_mfp
hp_laserjet_m2727nf_mfp
hp_laserjet_m2727nfs_mfp

HP-Fax-hplip.ppd is for all other models (as of 2.8.2).

They should both be in the src tree in the fax/ppd directory.

HP-Fax-hplip.ppd has these nicknames/model names:
*ModelName: "HP Fax"
*ShortNickName: "HP Fax"
*NickName: "HP Fax"

HP-Fax2-hplip.ppd has these nicknames/model names:
*ModelName: "HP Fax 2"
*ShortNickName: "HP Fax 2"
*NickName: "HP Fax 2"

I will post again later with the answers to the remaining questions.

On Mon, Feb 25, 2008 at 9:44 AM, Till Kamppeter <email address hidden>
wrote:

> Don, what are the names of the two PPD files, where are they in the
> source tree, where do they get installed, and what are there pseudo
> device IDs? The device IDs should be different, hpfax should output the
> pseudo device ID so that CUPS selects the correct PPD and also the
> Nicknames and other PPD entries should correspond to the pseudo device
> IDs.
>
> Please tell also which models need the second device ID, so that I can
> buy an appropriate printer on HP's PO to test the case of the second fax
> PPD and also whether system-config-printer handles the case correctly.
>
> --
> Fax PPD not installed by default
> https://bugs.launchpad.net/bugs/59409
> You received this bug notification because you are a direct subscriber
> of the bug.
>

unggnu (unggnu) wrote :

I am using HP Photosmart 3310. I can't check it atm but I'll report back if I have the possibility.

Don, thank you for the first part of your answer. I will add the HP LaserJet M2727 NFS to my shopping list.

I have fixed the problem in the Ubuntu and Debian HPLIP packages on the Debian SVN now. Once the missing Fax 2 will get installed now and second, the /etc/hp/hplip.conf file will be corrected by the package's post-install script, so that it is assured that the PPD paths are correct.

unggnu, I will switch the Ubuntu task to "In Progress" now, but please answer my questions as soon as you are able to so that I know whether my fix is really correct.

Changed in hplip:
status: Incomplete → In Progress
dwelch91 (dwelch91) wrote :

Till, do you want hpfax: backend to return the MDL: of "Fax" and "Fax 2" or
the actual MDL: of the discovered device? Could you please provide a sample
of what you'd like to see?

On Mon, Feb 25, 2008 at 9:54 AM, Till Kamppeter <email address hidden>
wrote:

> Don, I have found the second fax file now in the source tree:
>
> fax/ppd/HP-Fax2-hplip.ppd
>
> The pseudo device ID is:
>
> MFG:HP;MDL:Fax;DES:HP Fax 2;
>
> I suggest to modify it to
>
> MFG:HP;MDL:Fax 2;DES:HP Fax 2;
>
> as otherwise MFG and MDL are identical and so a printer setup tool which
> starts checking already after finding only MFG and MDL can confuse the
> files.
>
> So please change this device ID to the version which I suggested and
> modify the hpfax CUPS backend appropriately, so that it outputs the
> device ID according to the actually connected fax device type. Please
> post also an appropriate patch for HPLIP 2.8.2 here, as we are already
> after feature freeze and therefore we cannot replace the complete HPLIP
> package.
>
> --
> Fax PPD not installed by default
> https://bugs.launchpad.net/bugs/59409
> You received this bug notification because you are a direct subscriber
> of the bug.
>

My HP LaserJet 3390 produces the following output:

till@till-laptop:~/ubuntu/hplip/svn/pkg-hpijs/hplip/build-area$ /usr/lib/cups/backend/hpfax
direct hpfax:/usb/HP_LaserJet_3390?serial=00CNMJP81545 "HP Fax" "HP LaserJet 3390 HP Fax HPLIP" "MFG:HP;MDL:Fax;DES:HP Fax;"
till@till-laptop:~/ubuntu/hplip/svn/pkg-hpijs/hplip/build-area$

This is how it should be. It makes CUPS assigning the old fax PPD to this device.

For the HP LaserJet M2727 (and any other model with the new color fax capability) I expect the following (I do not have this printer, I only show how it should look like):

till@till-laptop:~/ubuntu/hplip/svn/pkg-hpijs/hplip/build-area$ /usr/lib/cups/backend/hpfax
direct hpfax:/usb/HP_LaserJet_M2727?serial=XXXXXXXXXX "HP Fax 2" "HP LaserJet M2727 HP Fax 2 HPLIP" "MFG:HP;MDL:Fax 2;DES:HP Fax 2;"
till@till-laptop:~/ubuntu/hplip/svn/pkg-hpijs/hplip/build-area$

The PPD should have as model name, short nick name, and nick name "HP Fax 2" and as device ID "MFG:HP;MDL:Fax 2;DES:HP Fax 2;". Then CUPS would perfectly assign always the correct PPD file.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package hplip - 2.8.2-0ubuntu2

---------------
hplip (2.8.2-0ubuntu2) hardy; urgency=low

  [ Till Kamppeter ]
  * debian/rules: Install the new fax PPD file for color fax devices
    (currently only HP LaserJet M2727 series, Ubuntu LP: #59409).
  * debian/hplip.postinst: Fix PPD paths in /etc/hp/hplip.conf, so that
    hp-setup finds the fax PPDs (Ubuntu LP: #59409).
  * debian/hplip.postinst: Removed code to correct permissions of .hplip
    personal config in user's home directories (Ubuntu LP: #191299).

  [ Mark Purcell ]
  * Added NEWS/ README entry about the need to use 'scanner' group
    - Non-root users need to be in group scanner! (Closes: #454339)
    - should use plugdev rather than scanner group (Closes: #452454)
    - sane-utils: Scanner only accessible under root (Closes: #462563)
  * Force (-f) removal of init.d scripts
    - Uses update-rc.d remove while init script exists; upgrade fails
    (Closes: #456378)

 -- Till Kamppeter <email address hidden> Tue, 26 Feb 2008 10:08:52 +0100

Changed in hplip:
status: In Progress → Fix Released
dwelch91 (dwelch91) wrote :

Hpfax: (hpfax.py) patch for 2.8.2 to add proper pseudo ID and PPD matching
(attached).

-Don

On Tue, Feb 26, 2008 at 2:35 AM, Launchpad Bug Tracker <
<email address hidden>> wrote:

> This bug was fixed in the package hplip - 2.8.2-0ubuntu2
>
> ---------------
> hplip (2.8.2-0ubuntu2) hardy; urgency=low
>
> [ Till Kamppeter ]
> * debian/rules: Install the new fax PPD file for color fax devices
> (currently only HP LaserJet M2727 series, Ubuntu LP: #59409).
> * debian/hplip.postinst: Fix PPD paths in /etc/hp/hplip.conf, so that
> hp-setup finds the fax PPDs (Ubuntu LP: #59409).
> * debian/hplip.postinst: Removed code to correct permissions of .hplip
> personal config in user's home directories (Ubuntu LP: #191299).
>
> [ Mark Purcell ]
> * Added NEWS/ README entry about the need to use 'scanner' group
> - Non-root users need to be in group scanner! (Closes: #454339)
> - should use plugdev rather than scanner group (Closes: #452454)
> - sane-utils: Scanner only accessible under root (Closes: #462563)
> * Force (-f) removal of init.d scripts
> - Uses update-rc.d remove while init script exists; upgrade fails
> (Closes: #456378)
>
> -- Till Kamppeter <email address hidden> Tue, 26 Feb 2008
> 10:08:52 +0100
>
> ** Changed in: hplip (Ubuntu)
> Status: In Progress => Fix Released
>
> --
> Fax PPD not installed by default
> https://bugs.launchpad.net/bugs/59409
> You received this bug notification because you are a direct subscriber
> of the bug.
>

Thank you for the patch, I will apply it to the next Ubuntu release of the HPLIP package. Please note that your patch is not complete, also in the fax PPD for "HP Fax 2" the device ID has to be changed to "MFG:HP;MDL:Fax 2;DES:HP Fax 2;" (Note the MDL part, it must be "Fax 2".

dwelch91 (dwelch91) wrote :

Oh, sorry, I missed that.

-Don

On Tue, Feb 26, 2008 at 3:10 PM, Till Kamppeter <email address hidden>
wrote:

> Thank you for the patch, I will apply it to the next Ubuntu release of
> the HPLIP package. Please note that your patch is not complete, also in
> the fax PPD for "HP Fax 2" the device ID has to be changed to
> "MFG:HP;MDL:Fax 2;DES:HP Fax 2;" (Note the MDL part, it must be "Fax 2".
>
> --
> Fax PPD not installed by default
> https://bugs.launchpad.net/bugs/59409
> You received this bug notification because you are a direct subscriber
> of the bug.
>

dwelch91 (dwelch91) wrote :

Here's that patch...

On Tue, Feb 26, 2008 at 3:36 PM, dwelch91 <email address hidden> wrote:

> Oh, sorry, I missed that.
>
> -Don
>
>
> On Tue, Feb 26, 2008 at 3:10 PM, Till Kamppeter <email address hidden>
> wrote:
>
> > Thank you for the patch, I will apply it to the next Ubuntu release of
> > the HPLIP package. Please note that your patch is not complete, also in
> > the fax PPD for "HP Fax 2" the device ID has to be changed to
> > "MFG:HP;MDL:Fax 2;DES:HP Fax 2;" (Note the MDL part, it must be "Fax 2".
> >
> > --
> > Fax PPD not installed by default
> > https://bugs.launchpad.net/bugs/59409
> > You received this bug notification because you are a direct subscriber
> > of the bug.
> >
>
>

Don, thank you very much for the two patches. I will apply them to the Ubuntu and Debian packages of HPLIP soon.

Changed in hplip:
status: New → In Progress

Don, I have added you patches to the Debian SVN for HPLIP now, so they get into the next packages for sure.

Johannes Meixner (jsmeix) wrote :

By chance I noticed that there are patches avaialble.

I have a question and/or feature request:

Is there an official developer location (web page, URL)
where such patches are collected so that
it would be sufficient to check only one URL
to get all the latest currently available patches
for a certain HPLIP version?

Preferably with links to matching bug reports
so that the information is complete.

I think HP, the Linux distributors, and the end-users
would benefit because for example I could provide
a patched HPLIP version for more testers via
http://download.opensuse.org/repositories/home:/jsmeix/
so that possible unexpected side-effects could be
detected sooner.

The official feedback place for HPLIP is the Launchpad. Report a bug to the project "HPLIP" with the patch attached.

Johannes Meixner (jsmeix) wrote :

It seems there is a misunderstanding.

I didn't ask for a place to where I can submit
something for HPLIP.

I asked if there is a summary page of all currently
available patches for a certain HPLIP version.

Changed in hplip:
status: Unknown → New
Changed in hplip:
status: New → Confirmed
Changed in hplip:
status: Confirmed → Fix Released
Changed in hplip:
assignee: nobody → kalosaurusrex
importance: Undecided → Medium
status: In Progress → Fix Released
Joe Linux (j-linux) wrote :

Hello there,

I read above with interest, BUT...
Note: My HP Officejet Pro L7590 is connected to my LAN.

1- In my previous Ubuntu 9.04 after having installed HPLIP (v. ?) from Ubuntu depositories, launched it and used its Device Manager - Setup Device... I was able without any problem to detect my Officejet - both Printer and Fax - and then to use both fonctions during 6 months without any problem and trick to implement. GREAT!

2- Now, I just have installed the new Ubuntu 9.10 which run perfectly. I have done as per above installing HPLIP (but now v. 3.9.8) from Ubuntu repositories.
When trying its Device Manager - Setup Device... My OJ is well recognized (HP Officejet Pro l7500 HPA31632 hp:/net/Officejet_Pro_L7500?zc=HPA31632) and then ONLY the Printer driver is proposed ready to be installed.

=> PB: For the FAX, I am getting the following message: "HP Device Manager - Setup. Unable to locate the HPLIP Fax PPD file - HP-Fax.hpcups.ppd.gz. Fax setup has been disable!".
Trying to go further reading thru HPLIP web site, I have red this version of HPLIP (i.e. v. 3.9.8) needs at least CUPS v.1.2 when Ubuntu 9.10 is only proposing and installing CUPS v.1.1.12! and with no update.

What do you thing? How can I fix this/my Fax issue? Is it Ubuntu 9.10 / HPLIP 3.9.8 issue or specific to my PC?
Thank you. Cheers.

Untitled No. 4 (untitled-no4) wrote :

Yes, this bug has seem to have made a comeback in 9.10 (I'm using Kubuntu).

To resolve the issue you need to run
sudo aptitude install hplip-cups
and install the printer again.

Changed in hplip (Ubuntu Hardy):
status: Fix Released → New
status: New → Fix Released

Untitled No. 4, see bug 459275.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.