HPLIP + LaserJet 10xx/P10xx: "out of paper" resetter needed

Bug #572125 reported by Cesare Mastroianni on 2010-04-30
This bug affects 6 people
Affects Status Importance Assigned to Milestone
hplip (Fedora)
hplip (Ubuntu)

Bug Description

Using Ubuntu 9.10 + HPLIP 3.9.12 (Device Man. ver. 15.0 Qt4) + HP LaserJet P1005

The printer works fine as long as there is paper in. When the paper bin is empty, HPLIP interface claims for "Device communication error". When I put some new paper in, the printer won't come back printing and HPLIP still claims for the communication error.

I'm not able to find any interface action to resume printing after having filled the paper in. The printing queue simply claims for "paper missing" and there is no interface action to backup from this situation. Then I need to delete the printing process from the queue, turn the printer off and on again, and start printing the original document from the missing page on.

The only way to prevent this to happen is to load more paper to the printer BEFORE it complete the jobs ... but this rather unfair if I need to print some jobs in remote, or if the print queue is long enough to last for the night ...

The official HP help pages (web source or PDF cd-rom source) only refer to Microsoft Windows software control panel interface.

Please, could You help me? I wrote this question to the "question" section of LaunchPad, and I had no answer at all.

Ciao from Italy

affects: ubuntu → hplip (Ubuntu)
maximi89 (maximi89) wrote :

this affect directly to HPLIP
i get STATUS CODE 1009

that means out of paper... so the things is, who are directly relationed with the error?
the firmware or hplip?

 i do the same as you, turn off and then turn on the printer... then it works... nicely.

Till Kamppeter (till-kamppeter) wrote :

Added upstream task, as the problem happens in two distributions.

Till Kamppeter (till-kamppeter) wrote :

I have seen that foo2zjs (third-party driver for ZJS-based HP LaserJet printers) has a paper out resetter utility which offers a button to the user which he has to click after reloading paper. The utility does not more than polling the device ID when clicking the button. So polling the device ID must have the effect of signalling the printer that paper was reloaded and so make it continue to work.

So remove paper from the printer so that it is insufficient for the next print job, print a job making the printer running out of paper, reload paper, and then do one of the following tests:

1. Run

sudo usb_printerid /dev/usb/lp0

2. Run


3. Run

lpinfo -v

As all of these poll the device ID from the printer, your printer must continue now printing the job.

To the developers at HP: Please add a paper out resetter.

Changed in hplip (Fedora):
status: New → Incomplete
Changed in hplip (Ubuntu):
status: New → Incomplete
Changed in hplip:
status: New → Incomplete
Till Kamppeter (till-kamppeter) wrote :

For me the method of the previous comment works with the HP LaserJet 1020.

Changed in hplip:
status: Incomplete → Confirmed
Changed in hplip (Ubuntu):
status: Incomplete → Confirmed
Changed in hplip (Fedora):
status: Incomplete → Confirmed
summary: - Ubuntu 9.10 Karmic HPLIP + LaserJet P1005 = "out of paper" error
+ HPLIP + LaserJet 10xx/P10xx = "out of paper" error
summary: - HPLIP + LaserJet 10xx/P10xx = "out of paper" error
+ HPLIP + LaserJet 10xx/P10xx: "out of paper" resetter needed
Cesare Mastroianni (cece) wrote :

Many thanks for Your help.

I tried all the 3 alternatives. Here the output:

0) I start printing a 2 pages job, while the paper tray holds 1 single page - after the first page is printed, the printer tries to load the second, which is missing - after this the light LED of the printer start flashing - then I insert a new page and go on ...

$ sudo usb_printerid /dev/usb/lp0
Error: No such file or directory: can't open '/dev/usb/lp0'
$ ls -la /dev/usb
totale 0
drwxr-xr-x 2 root root 60 2010-07-15 18:56 .
drwxr-xr-x 17 root root 4040 2010-07-15 18:56 ..
crw-rw---- 1 root root 180, 96 2010-07-15 18:56 hiddev0

this doesn't work

$ /usr/lib/cups/backend/usb
bash: /usr/lib/cups/backend/usb: Permesso negato
$ sudo !!
sudo /usr/lib/cups/backend/usb
DEBUG: list_devices_libusb
DEBUG: usb_find_busses=5
DEBUG: usb_find_devices=9
direct usb://HP/LaserJet%20P1005?serial=BC1R5SS "HP LaserJet P1005" "HP LaserJet P1005" "MFG:Hewlett-Packard;MDL:HP LaserJet P1005;CMD:HBS,PJL,ACL;CLS:PRINTER;DES:HP LaserJet P1005;FWVER:20080415;" ""

nothing else happens: this doesn't work

$ lpinfo -v
network ipp
network lpd
direct scsi
network http
network beh
network smb
network socket
direct hp:/usb/HP_LaserJet_P1005?serial=BC1R5SS
direct usb://HP/LaserJet%20P1005?serial=BC1R5SS
direct hpfax

this tooks 10 seconds to complete, but nothing else happens: this doesn't work

4) After these 3 tests the red LED is still flashing and the paper tray holds the blank page.

FINAL RESULT: at my computer these solutions don't work for me... or I had not understood exactly what to do.


Cesare Mastroianni (cece) wrote :

What does You mean with "reload paper" after the paper tray was empy? The model P1005 which I use has no hardware button at all. It only has the power on-off, and 2 leds (one is green, one is red). The paper is filled in by hands, just putting in inside the tray.

I'm asking this because I also have a 1320n that has a removable tray for actual "loading" of the paper.

This comment should stress my doubt about the right procedure to follow to perform the 3 tests You proposed ... sorry for my pedantic approach, but both my english and my computer knowledge could be too much poor to help You


Till Kamppeter (till-kamppeter) wrote :

The 1320n has a completely closed tray. To insert paper you must take it out and to print you must reinsert it. When it is completely inserted it presses against a switch telling the printer to continue printing.

Inkjet printers have a tray which is not removable and open. Here you have to press a button when you have finished inserting the paper.

This is all for the printer not starting to print while you hold the paper still inyour hand, to not tear apart a sheet and getting a page printed on the torn sheet.

The cheap HP lasers have no buttons and an open tray. They assume the continue signal after reloading paper coming from the software. At least on the HP LaserJet 1000, 1005, 1018, and 1020 this signal is the command to poll the device ID. And this works on my 1020. If I do something which polls the device ID, the printer continues printing the rest of the job.

Perhaps the LaserJet P10xx series needs another signal. Can someone from HP help here?

Till Kamppeter (till-kamppeter) wrote :

I had a look into the current version of foo2zjs and there the paper-out resetter is expanded to also reset the paper-out state of the LaserJet P10xx series and what it does is re-uploading the firmware file. This looks like that the author did not find out the "right" way yet but he did find out that re-uploading the firmware also does the trick.

Cesare Mastroianni (cece) wrote :

Thanks Till K. so far ... but still no help came from HP about the HP - P10xx devices (at least, no help about my P1005). In the meantime, I turn to Maverick (leaving Lucid), and nothing happened: the "bug" is still here.


Oliver Oxtoby (olliox) wrote :

What I find works for the P1005 is to open and close the top cover...it reloads and carries on printing where it left off.

gf (gf-interlinks) wrote :

Hello Cesare,
Thank you for submitting this bug and reporting a problem with the hplip package. You made this bug report in 2010 and Ubuntu has been updated since then.

Could you confirm that this is no longer a problem and that we can close the ticket?
If it is still a problem, are you still interested in finding a solution to this bug?
If you are, could you let us know and, in the current version, could you run the following (only once):
apport-collect BUGNUMBER
and upload the updated logs and and any other logs that are relevant for this particular issue.

Thank you again for helping make Ubuntu better.
[Ubuntu Bug Squad volunteer triager]

Changed in baltix:
status: New → Incomplete
Changed in hplip (Ubuntu):
status: Confirmed → Incomplete
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Related questions