hpfax crashed with NameError in bug()

Bug #560849 reported by James Clemence on 2010-04-11
18
This bug affects 2 people
Affects Status Importance Assigned to Milestone
hplip (Ubuntu)
Medium
Unassigned

Bug Description

Binary package hint: hplip

Crashed as I tried to start compiz.

ProblemType: Crash
DistroRelease: Ubuntu 10.04
Package: hplip 3.10.2-2ubuntu1
ProcVersionSignature: Ubuntu 2.6.32-19.28-generic 2.6.32.10+drm33.1
Uname: Linux 2.6.32-19-generic x86_64
NonfreeKernelModules: fglrx
Architecture: amd64
Date: Sun Apr 11 18:24:49 2010
ExecutablePath: /usr/lib/cups/backend/hpfax
InstallationMedia: Ubuntu 10.04 "Lucid Lynx" - Beta amd64 (20100317.1)
InterpreterPath: /usr/bin/python2.6
Lpstat:
 device for KONICA-MINOLTA-C200: socket://192.168.1.200:9100
 device for Stylus-Photo-RX500: usb://EPSON/Stylus%20Photo%20RX500
MachineType: System manufacturer System Product Name
Papersize: a4
PpdFiles:
 KONICA-MINOLTA-C200: KONICA MINOLTA C250 PS(P)
 Stylus-Photo-RX500: Epson Stylus Photo RX500 - CUPS+Gutenprint v5.2.5 Simplified
ProcCmdLine: BOOT_IMAGE=/boot/vmlinuz-2.6.32-19-generic root=UUID=aa0eb128-149a-45d5-a48a-4e6c27d6016c ro quiet splash
ProcCmdline: python /usr/lib/cups/backend/hpfax
ProcEnviron:
 PATH=(custom, no user)
 LANG=en_US.UTF8
PythonArgs: ['/usr/lib/cups/backend/hpfax']
SourcePackage: hplip
Title: hpfax crashed with NameError in bug()
UserGroups:

dmi.bios.date: 11/24/2009
dmi.bios.vendor: American Megatrends Inc.
dmi.bios.version: 1803
dmi.board.asset.tag: To Be Filled By O.E.M.
dmi.board.name: M4A78-E
dmi.board.vendor: ASUSTeK Computer INC.
dmi.board.version: Rev 1.xx
dmi.chassis.asset.tag: Asset-1234567890
dmi.chassis.type: 3
dmi.chassis.vendor: Chassis Manufacture
dmi.chassis.version: Chassis Version
dmi.modalias: dmi:bvnAmericanMegatrendsInc.:bvr1803:bd11/24/2009:svnSystemmanufacturer:pnSystemProductName:pvrSystemVersion:rvnASUSTeKComputerINC.:rnM4A78-E:rvrRev1.xx:cvnChassisManufacture:ct3:cvrChassisVersion:
dmi.product.name: System Product Name
dmi.product.version: System Version
dmi.sys.vendor: System manufacturer

Related branches

James Clemence (jvc26) wrote :
tags: removed: need-duplicate-check
visibility: private → public
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in hplip (Ubuntu):
status: New → Confirmed
Changed in hplip (Ubuntu):
status: Confirmed → In Progress
Till Kamppeter (till-kamppeter) wrote :

I am peparing a new HPLIP package now which fixes the crash, but what should happen instead of the crash is the output of an error message that hpfax could not find the HPLIP library directory in /etc/hp/hplip.conf. So independent of the release of the new HPLIP package you should run the following commands in a terminal window to clean up your HPLIP installation:

sudo dpkg -P --force-depends libsane-hpaio
sudo apt-get install libsane-hpaio
sudo apt-get install --reinstall hplip hplip-data

This makes sure that all needed files are in place and especially recovers your /etc/hp/hplip.conf file.

If this does not work, try also

sudo rm -rf /var/spool/cups/tmp/.hplip

Changed in hplip (Ubuntu):
status: In Progress → Fix Committed
Changed in hplip (Ubuntu):
milestone: none → ubuntu-11.10
importance: Undecided → Medium
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package hplip - 3.11.7-1ubuntu2

---------------
hplip (3.11.7-1ubuntu2) oneiric; urgency=low

  * debian/patches/hpfax-bug-function-used-before-importing-log.dpatch:
    The hpfax CUPS backend uses its function bug() (which in turnuses log())
    before log() gets imported (with base.g). Made use of log() in bug()
    optional (LP: #560849).
 -- Till Kamppeter <email address hidden> Fri, 23 Sep 2011 11:05:00 +0200

Changed in hplip (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers