Problems with hpcups driver: Setting duplex too complicated, miscellaneous regressions

Bug #428588 reported by Alexander Kallenbach on 2009-09-12
64
This bug affects 10 people
Affects Status Importance Assigned to Milestone
Evince
Expired
Medium
HPLIP
Undecided
Unassigned
hplip (Ubuntu)
High
Unassigned
Maverick
High
Unassigned
system-config-printer (Ubuntu)
Undecided
Unassigned
Maverick
High
Unassigned

Bug Description

Binary package hint: hplip

On my new HP Officejet Pro 8500 duplex-printing doesn't work. The printer prints the first page, stops printing (with first page still inside) and then does nothing for several minutes. After a while I get an error notification. Under details I've found this message:

The printer's state message is: '/usr/lib/cups/filter/foomatic-rip failed'

ProblemType: Bug
Architecture: i386
DistroRelease: Ubuntu 9.04
Lpstat:
 Gerät für Officejet-Pro-8500-A909a: hp:/usb/Officejet_Pro_8500_A909a?serial=MY96K430MF
 Gerät für Officejet_Pro_8500_A909a: hp:/usb/Officejet_Pro_8500_A909a?serial=MY96K430MF
 Gerät für Officejet_Pro_8500_A909a_fax: hpfax:/usb/Officejet_Pro_8500_A909a?serial=MY96K430MF
MachineType: Acer AOA150
Package: hplip 3.9.2-3ubuntu4
Papersize: a4
PpdFiles:
 Officejet_Pro_8500_A909a: HP Officejet Pro 8500 a909a hpijs, 3.9.2
 Officejet_Pro_8500_A909a_fax: HP Fax
 Officejet-Pro-8500-A909a: HP Officejet Pro 8500 a909a hpijs, 3.9.2
ProcCmdLine: root=UUID=52c0fb34-b340-44e1-9877-5f7c3db93ed5 ro quiet splash
ProcEnviron:
 LANG=de_DE.UTF-8
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 2.6.28-15.49-generic
SourcePackage: hplip

OK, Duplex-printing works out of OpenOffice but doesn work from Document Viewer. So it isn't a problem of hplip???

I get the same error message when printing a pdf out of Adobes Acrobat Reader.

Till Kamppeter (till-kamppeter) wrote :

Please create an error_log for a job which has the problem proceeding as described in the "CUPS error_log" section of
https://wiki.ubuntu.com/DebuggingPrintingProblems

Changed in hplip (Ubuntu):
status: New → Incomplete
Till Kamppeter (till-kamppeter) wrote :

Shiyun, Dave, Aaron, can this be the same problem as bug 406074?

Here comes the error_log

Till Kamppeter (till-kamppeter) wrote :

Thank you for your error_log.

According to the error_log, Ghostscript or hpijs crashes with a segmentation fault. I have copied the Ghostscript command line from your error_log and run it with some arbitrary PDF files. On Jaunty I can reproduce the segmentation fault and according to /var/log/syslog it is a segmentation fault in hpijs. On Karmic Ghostscript completes its job, but produces a lot of warnings:

prnt/hpijs/hpijs.cpp 389: unable to set key=Quality:SpeedMech, value=1

Shiyun, Dave, Aaron, can someone of you look into what fixed the segmentation fault in hpijs (and perhaps provide a patch) and also have a look at what causes the warning in Karmic's HPIJS?

Ghostscript in Jaunty is 8.64, in Karmic is 8.70.

HPLIP in Jaunty is 3.9.2, in Karmic is 3.9.8.

Changed in hplip (Ubuntu):
status: Incomplete → Invalid
status: Invalid → Confirmed
Changed in hplip:
status: New → Confirmed
Changed in evince:
status: Unknown → New
Nicolas Diogo (nicolasdiogo) wrote :

just adding my voice here to confirm this bug.

any alternative way to solve it while a proper solutions is designed will be mostly appreciated.

thanks

Duplex printing in Karmic doesn't work at all!!! In OpenOffice I even can't choose to print as duplex (screenshot added). But the duplexer is marked as installed (screenshot added).
In evince it's the same. In the HPLIP Device Manager the Duplexer is marked as installed as well (screenshot added as well).

Out of the HP Device Manager duplex printing works under Karmic.

Alex, for Duplex printing you have to choose the "A4Duplex" page size instead of "A4" (or "LetterDuplex" instead of "Letter"). If your application's printing dialog allows changing the page size, change it appropriately and you should be able to print. If not, check whether you can choose the page size at other places, like in "File"/"Page Setup" (choose your printer in the first drop-down and then the "Duplex" page size in the second drop-down) or "Format"/"Page". If the "Duplex" page sizes are not accessible you are out of luck with that application (the application has a bug then, please report it).

Everyone, please try the HPIJS drivers on Karmic. For that open system-config-printer ("System"/"Administration"/"Printing"), right-click your printer's icon and choose "Properties". In the upcoming dialog stay on the first page ("Settings"), click the "Change" button in the "Make and Model" line and in the upcoming wizard keep make and model but choose in the driver field (second step, on the right) the driver with "hpijs". With this driver the options will look different, especially you will have every page size only once. Please tell how well printing works for you with this driver.

At this moment I can't change the driver to hpijs over the menu (is there another possibility?) because of this bug:

https://bugs.launchpad.net/bugs/436218

In evince I can't choose the page size A4dublex (or anything comparable). In OpenOffice I can choose the "A4Autodublex" page size and then after I've done this printing in duplex mode is selectable. But even if I choose duplex Printing mode the printer printed one-sided!!!!

I have fixed bug 436218 and bug 436218. Please apply the patches attached there, then you should be able to change the driver with system-config-printer.

Nicolas Diogo (nicolasdiogo) wrote :

till,

when you say 'apply these patches'

how exactly are we to apply them?
and are these patches for ubuntu versions other then Karmic? i am using 9.10.

thanks,

Since the last updates it was possible to change the driver to hpijs. Now duplex printing is possible out of evince and OpenOffice.

Nicolas, the patches are not needed any more, the fixed system-config-printer is uploaded. So you only need to update your system.

Karmic and 9.10 are the same.

Nicolas Diogo (nicolasdiogo) wrote :

thanks,

Till for clarifying it.

regards,

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package hplip - 3.9.8-0ubuntu7

---------------
hplip (3.9.8-0ubuntu7) karmic; urgency=low

  * debian/hplip-cups.postinst, debian/hpijs.postinst: Let the hpijs package
    migrate queues for the hpcups driver (hplip-cups package) to the HPIJS
    driver when updating PPDs of existing queues. The hplip-cups package
    does not migrate HPIJS queues any more now. We prefer HPIJS for now as
    hpcups has still problems, especially shifted prints on the back side
    of the sheet (LP: #426826), page size confusion with duplex printing
    (LP: #428588) and borderless printing.
  * debian/patches/kde4-kdesudo-support.dpatch: Try also
    /usr/lib/kde4/libexec/kdesu as sudo GUI (LP: #281880).
  * debian/hplip.install, debian/hplip-gui.install: Moved all hp-* utilities
    which do not work in text mode from hplip to hplip-gui (LP: #430539).
  * debian/control: Let hplip recommend hpijs instead of hplip-cups, as this
    is our preferred driver for now. Add to hplip-gui's dependencies
    kdebase-runtime as one of the alternatives to provide a sudo GUI utility
    (LP: #281880). Added versioned depends and conflicts on hplip to hp-gui,
    due to the moving of the GUI-only utilities to hplip-gui.
  * debian/patches/hp-setup-prompt-for-custom-PPD.dpatch: hp-setup did not
    prompt for a custom PPD if the description field of the default PPD is
    empty (LP: #432808).

 -- Till Kamppeter <email address hidden> Thu, 3 Sep 2009 19:22:38 +0200

Changed in hplip (Ubuntu):
status: Confirmed → Fix Released

Important note, especially for the upstream developers: The Ubuntu package upload is not really a fix for this problem, it only reverts the user's print queues to the old HPIJS driver which still does not use different paper sizes for onne-sided and double-sided printing. This should cause duplex printing to just work for all Ubuntu users.

To the upstream developers of HPLIP: For making hpcups the default driver in Karmic there must be an easier way for the users to set up duplex (see this bug) and the back sides need to get correctly positioned (bug 426826). If you can provide a patch for these two issues before Final Freeze for Karmic (October 15) I can make hpcups be the default.

summary: - Duplex printing doesn't work on HP Officejet Pro 8500
+ Problems with hpcups driver: Setting duplex too complicated,
+ miscellaneous regressions
tags: added: hpcups
Johannes Meixner (jsmeix) wrote :

Regarding "easier way for the users to set up duplex"
I would like to mention what I wrote here:

https://bugs.launchpad.net/hplip/+bug/173857/comments/4

i.e. I suggest that the defaults in the PPD are
such that duplex printing works.

As far as I see the consequence is that then even
for "simpex" printing with the default settings in the PPD
the presumably smaller ImageableArea for duplex printing
would be used.

But I think in the end this is even an advantage because
with such defaults the printout result is by default what
a normal user would presumably expect:

The ImageableArea is the same regardless if duplex
or "simplex" printing is used so that one can print the
same document in duplex or simplex mode
and the only difference is that in duplex mode
the back-side of the paper is also used
but there is no difference at all regarding
the printed content on each page.

Therefore it may make more sense to do
the opposite of what I suggested at
https://bugs.launchpad.net/hplip/+bug/173857/comments/3

I.e. not have special paper size definitions
in the PPD for duplex printing
but special paper size definitions
for "semi-full-bleed simplex printing".

I.e. PageSize A4 is the right one for duplex
and DefaultPageSize is set to A4
and additionally there is an optional choice
PageSize A4.Simplex
to enforce "semi-full-bleed simplex printing"
for those useres who really need to squeeze out
the very maximum possible printable area
from their printer ;-)

For devices which support real full bleed
(photo) printing one more optional choice
PageSize A4.FullBleed
(together with appropriate UIConstraints)
might be needed.

Such several kind of "different same paper sizes"
like A4, A4.Simplex, A4.FullBleed, A4.whatever...
do not look very user-friendly but currently
I do not have a better idea :-(

Martin (agima) wrote :

In lucid lynx hpcups gets installed by default again and setting duplex is still too complicated. Please again select hpijs by default.

Michal Pěnka (michal-penka) wrote :

I can't select double-sided (long/short edge) printing in the print dialog. Can you please help how to solve this? I really need this feature a lot.

I'm using Lucid Lynx, daily updated.

Michal, pleas check at first whether the printer is configured for having a duplex unit, start the printer tool with System -> Administration -> Printing, right-click the printer, choose "Properties". Choose "Installed Options" on the left and make sure that the box at "Duplex Unit" is marked. Now you can set the default choice for double-sided printing under "Printer Options". Set the default page size to the "Duplex" variant of your default page size if you choose to print duplex by default. From now on applications should offer duplex printing in their dialogs.

I have problem with 'manual duplex' printing on my HP CP1514n in Ubuntu.
In 10.04 I select the double sided print option (print long edge). Print is now simplex printing which is wrong.
In 10.10beta there is a new option checkbox : Duplexer installed. I don't have a duplexer attached to my printer. If I deselect this option, I cannot select double sided printing any more.
What to do?
I want first to print the even pages. Then I place the printed stack even pages in the printer tray.
When I Acknowledge with the OK printer button, the printer shall print the odd pages in the correct order on the opposite side of the even pages.
This works perfectly in Windows. Ubuntu (Linux) must have the same functionality!
I believe a lot of people have the same problem!

Changed in hplip (Ubuntu):
status: Fix Released → Incomplete
Changed in evince:
importance: Unknown → Medium

The same bug is there again in Maverick Meerkat. I couldn't print in duplex mode out of evince and the dialogues to activate the duplexer are quiet complicated. I had to change the driver from hpcups to hpijs.

Why is the same bug there again and again?

Joerg Beyer (j-beyer) wrote :

here too: on Maverick Meerkat/10.10 I could not print on my new Officejet 6500 wireless. Any ideas?

Joerg Beyer, are you not able to print at all or is the problem oinly the duplex printing? In the former case you have another bug, please report a new bug then.

JM (meonline) wrote :
Download full text (6.3 KiB)

I believe I'm experiencing the same/related issue. With Ubuntu10.04 and hplip-3.10.9, gedit does not allow duplex printing. However, I *am* able to duplex print from Firefox. I tried to specify the hpijs driver as described above (#27) but only the hpcups driver was listed.

Not sure if this matters ... I also have installed cups-pdf.

hp-check -r output:

HP Linux Imaging and Printing System (ver. 3.10.9)
Dependency/Version Check Utility ver. 14.3

Copyright (c) 2001-9 Hewlett-Packard Development Company, LP
This software comes with ABSOLUTELY NO WARRANTY.
This is free software, and you are welcome to distribute it
under certain conditions. See COPYING file for more details.

Note: hp-check can be run in three modes:
1. Compile-time check mode (-c or --compile): Use this mode before compiling the
HPLIP supplied tarball (.tar.gz or .run) to determine if the proper dependencies
are installed to successfully compile HPLIP.
2. Run-time check mode (-r or --run): Use this mode to determine if a distro
supplied package (.deb, .rpm, etc) or an already built HPLIP supplied tarball
has the proper dependencies installed to successfully run.
3. Both compile- and run-time check mode (-b or --both) (Default): This mode
will check both of the above cases (both compile- and run-time dependencies).

Saving output in log file: hp-check.log

Initializing. Please wait...

---------------
| SYSTEM INFO |
---------------

Basic system information:
Linux d420nix 2.6.32-25-generic #44-Ubuntu SMP Fri Sep 17 20:26:08 UTC 2010 i686 GNU/Linux

Distribution:
ubuntu 10.04

Checking Python version...
OK, version 2.6.5 installed

Checking PyQt 4.x version...
OK, version 4.7.2 installed.

Checking for CUPS...
Status: scheduler is running
Version: 1.4.3
error_log is set to level: warn

Checking for dbus/python-dbus...
dbus daemon is running.
python-dbus version: 0.83.0

------------------------
| RUNTIME DEPENDENCIES |
------------------------

Checking for dependency: CUPS - Common Unix Printing System...
OK, found.

Checking for dependency: GhostScript - PostScript and PDF language interpreter and previewer...
OK, found.

Checking for dependency: PIL - Python Imaging Library (required for commandline scanning with hp-scan)...
OK, found.

Checking for dependency: PolicyKit - Administrative policy framework...
OK, found.

Checking for dependency: PyQt 4 DBus - DBus Support for PyQt4...
OK, found.

Checking for dependency: Python DBus - Python bindings for DBus...
OK, found.

Checking for dependency: Python libnotify - Python bindings for the libnotify Desktop notifications...
OK, found.

Checking for dependency: Python XML libraries...
OK, found.

Checking for dependency: Python 2.3 or greater - Required for fax functionality...
OK, found.

Checking for dependency: Reportlab - PDF library for Python...
OK, found.

Checking for dependency: SANE - Scanning library...
OK, found.

Checking for dependency: scanimage - Shell scanning program...
OK, found.

Checking for dependency: xsane - Graphical scanner frontend for SANE...
OK, found.

----------------------
| HPLIP INSTALLATION |
------------------...

Read more...

Please everyone who suffers this problem (or especially cannot print duplex) in Maverick, install the "hpijs" package, for example via the command

sudo apt-get install hpijs

in a terminal window and create a print queue for your printer using the "hpijs" driver. Can you print duplex through this queue?

JM (meonline) wrote :

Thank you, Till. That worked for me!

Specifically, after installing the hpijs package, I immediately opened a txt file using gedit and was able to select duplex mode. No other changes were necessary.

At least for Maverick we should switch back to HPIJS (instead of hpcups) as default driver for HP's non-PostScript printers. Here the duplex option is simpler and works with all the applications which have all kinds of bugs in their printing dialogs. Added hplip and system-config-printer task for a Maverick SRU. See also bug 657357.

Changed in hplip (Ubuntu Maverick):
status: New → Triaged
importance: Undecided → High
Changed in system-config-printer (Ubuntu Maverick):
importance: Undecided → High
status: New → Triaged
Changed in system-config-printer (Ubuntu):
status: New → Invalid

Prepared SRU for Maverick. The new HPLIP package installs hpijs and migrated hpcups-based print queues to hpijs. debdiff attached and package uploaded to the -proposed queue, waiting for approval.

Changed in hplip (Ubuntu Maverick):
status: Triaged → Fix Committed

Prepared SRU for Maverick. The new system-config-printer package prioritizes the hpijs driver against the hpcups driver when creating a new print queue. debdiff attached and package uploaded to the -proposed queue, waiting for approval.

Changed in system-config-printer (Ubuntu Maverick):
status: Triaged → Fix Committed
Changed in hplip (Ubuntu):
importance: Undecided → High

Accepted hplip into maverick-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

tags: added: verification-needed
Martin Pitt (pitti) wrote :

Accepted system-config-printer into maverick-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

The hplip package in -proposed has built now. Sorry for the delay, we had a problem with the package build.

Could someone experiencing this problem test the package in maverick-proposed and report here ?
Thanks in advance.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package hplip - 3.10.6-1ubuntu10.1

---------------
hplip (3.10.6-1ubuntu10.1) maverick-proposed; urgency=low

  * debian/hplip-cups.postinst, debian/hpijs.postinst: Switch back to HPIJS as
    default driver (migrate hpcups queues to HPIJS) as there are still problems
    with hpcups and duplex printing (LP: #428588, LP: #487695, LP: #657357).
  * debian/control: Let hplip depend on hpijs instead of on hplip-cups as
    printer driver.
 -- Till Kamppeter <email address hidden> Thu, 21 Oct 2010 14:35:03 +0200

Changed in hplip (Ubuntu Maverick):
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package system-config-printer - 1.2.3+20100723-0ubuntu8.1

---------------
system-config-printer (1.2.3+20100723-0ubuntu8.1) maverick-proposed; urgency=low

  * debian/patches/78_give-priority-to-hpijs.patch: Prioritize hpijs against
    hpcups again. With hpcups duplex printing does not work with most
    applications (LP: #428588, LP: #487695, LP: #657357).
 -- Till Kamppeter <email address hidden> Thu, 21 Oct 2010 14:58:06 +0200

Changed in system-config-printer (Ubuntu Maverick):
status: Fix Committed → Fix Released
quarkrad (quarkrad) wrote :

Sorry - I'm in late to this world. Having trouble with duplex printing in 10.10/maverick with C310 printer using 3.10.9. I have read this and installed hpijs as per the comment

sudo apt-get install hpijs

in a terminal window and create a print queue for your printer using the "hpijs" driver.

I'm a newbie so I apologies for this question:- having sudo'd and installed hpijs, how do I create a new print queue?

Changed in evince:
status: New → Expired
Changed in hplip:
status: Confirmed → Fix Committed
vonibenz (vonibenz) wrote :

I also have a trouble with Duplex Printing on HPLIP. My printer is a HP psc 1510 and I can't print double sided, nor with Ubuntu 9.04 neither with Ubuntu 10.10, in spite of the correct setting of the program. I am bearing this bug for the last two years, too much time indeed!

Nicolas Diogo (nicolasdiogo) wrote :

try changing the border size
it made a difference for me.

Changed in hplip (Ubuntu):
status: Incomplete → Fix Released

In the current Ubuntu/Debian package of HPLIP the duplex problem of the hpcups driver is solved by reorganizing the different margin types of the page sizes, see bug 487695. Therefore closing the task for the Ubuntu package of HPLIP as fixed.

Benjamin Weggenmann (bubun2) wrote :

I cannot enable duplex when printing from within firefox (7.01). The combo-box in the Page Setup tab of the print dialog simply shows just one option "One Sided". In KDE applications, it correctly shows all three options (one sided, long edge, short edge) but both firefox and chromium (non-KDE) do not. Selecting the autoduplex page sizes will not print two sided. With hpijs driver, it does show the long and short edge options in all tested applications, BUT it only prints an error message "Unable to open the initial device, quitting."
I did check the "duplexer installed" option in CUPS administration. I am on Oneiric Ocelot. I tried hplip 3.11.7 (repositories) and a manually downloaded 3.11.10. "hp-check -t" says "No errors or warnings.".

Benjamin Weggenmann (bubun2) wrote :

I forgot to say I have an OfficeJet Pro 8500A.

I just tried to set the CUPS Printer Default Options to "Long Edge" (my idea was to 'force' even gnome/non-KDE apps to use duplex), and got this "fun" result (see attached screenshot):
--- snip ---
Error: The following options are conflicting:

    Double-Sided Printing: Long Edge (Standard)
    Duplexer Installed: Installed

Please change one or more of the options to resolve the conflicts.
--- snap ---

Aha, so if I have a duplexer I cannot print duplex. Great. Of course changing the "Duplexer Installed:" to "Not Installed" does not allow me to set the "Double-Sided Printing:" option to "Long Edge (Standard)" either.

goutam kodu (goutam-hplip) wrote :

Hi Benjamin,

Can you please post us the "hp-check -t" output. And also attach us the ppd file for this printer which will be in /etc/cups/ppd directory.

Thanks & Regards,
Goutam Kodu

To post a comment you must log in.