HP 1018 LaserJet printer not printing

Bug #368124 reported by Rimas on 2009-04-27
16
This bug affects 2 people
Affects Status Importance Assigned to Milestone
hplip (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: hplip

The problem description is here: https://answers.launchpad.net/ubuntu/+source/hplip/+question/68339
It is not just a problem, it is a bug, IMHO :)

It happens too, with a custom foo2zjs build on Kubuntu 9.04 final. Very annoying.

---
Citing the question:

All my steps:

1) I've just installed fresh Ubuntu 9.04 Release Candidate
2) I pluged and turned my HP LaserJet 1018 printer
3) Ubuntu found it and opened setup window for "plugin download". Everything was successful.
4) I tried to print test page, but it was just "Job completed" without printing anything.
5) I fount, that I need to install hplip-gui, but noting changed.
6) I tried to change driver (Menu: System->Administration->Printing->HP_LaserJet_1018->"Make and model"->Change), but also nothing new.
7) I installed new printer by runing hp-setup (I name it HP_LaserJet_1018_2)
8) printing works, but:

when I try to print (with "HP_LaserJet_1018") this:
http://originalus.lt/tmp/hplip/HP_LaserJet_1018.odt
result looks like this:
http://originalus.lt/tmp/hplip/HP_LaserJet_1018.png

when I try to print (with "HP_LaserJet_1018_2"):
http://originalus.lt/tmp/hplip/HP_LaserJet_1018_2.odt
result looks a bit different:
http://originalus.lt/tmp/hplip/HP_LaserJet_1018_2.png

"hp-check -t" result I put here:
http://originalus.lt/tmp/hplip/hp-check_-t_result

Some time before, when I used Ubuntu 8.04 and same printer was installed by running hplip-2.8.12.run (or maybe older - I'm not sure now), everything worked fine.

And I don't know now, what to do...

Thanks in advance.

Tautvydas

this also happens on a ubuntu 8.10 or the new 9.04 both desktop and server edition experiencing the same problem.
Duesouth

All my steps:

1) I've just installed fresh Ubuntu 9.04 Release Candidate
2) I pluged and turned my HP LaserJet 1018 printer
3) Ubuntu found it and opened setup window for "plugin download". Everything was successful.
4) I tried to print test page, but it was just "Job completed" without printing anything.
5) I fount, that I need to install hplip-gui, but noting changed.
6) I tried to change driver (Menu: System->Administration->Printing->HP_LaserJet_1018->"Make and model"->Change), but also nothing new.
7) I installed new printer by runing hp-setup (I name it HP_LaserJet_1018_2)
8) printing does not work at all for me.

I can not get this printer to work either under 8.10 or 9.04 whether it is desktop edition or server edition.

it see the printer, but it is unable to print to it. it just display processing and then printing but nothing is being printed or coming out of the printer. no change on the lights of the printer.

hmm what can be the problem. if I want to print I have to save the file on my other drive and reboot in windows. that is basically the only why I am keeping another operating system in my computer on a separate hard drives.

Duesotuh (ma634) on 2009-05-07
description: updated
summary: - Margins cut on HP LaserJet printers (1018, 1020, 4000 etc)
+ HP 1018 LaserJet printer not printing
Rimas (deepredromance) wrote :

FYI, Duesotuh, I believe that these are two separate bugs, not one.So to avoid possible confusion, I would recommend opening a new bug, instead of adding information to this one.

I may be wrong, though

--
Rimas

Till Kamppeter (till-kamppeter) wrote :

Your problems are most probably the (already fixed) bugs bug 365329, bug 357732, and bug 363522. Please do appropriate updates and all should work.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers