Jumbled output on plaintext lines with '_' char via lpr on HP Color LaserJet CP2025dn

Bug #365239 reported by jcox on 2009-04-22
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
HPLIP
Undecided
Unassigned
hplip (Ubuntu)
Undecided
Unassigned

Bug Description

Printer: HP Color LaserJet CP2025dn printer
Driver: HP Color LaserJet CP2020 Series with Duplexer Postscript (recommended)
PPD: hp-color_laserjet_cp2025dn-ps.ppd

The problem:

When printing from the command line via lp or lpr,
if a line within a plaintext file contains an underscore character ('_'),
then characters to the right of the underscore are shifted leftwards,
thereby creating a jumbled overstrike effect. Lines that do not contain
an underscore character seem to print just fine.

This "underscore creates overstrike" bug does not occur when printing
the same plain text file from firefox.

Here's a copy of my test file (notice the underscores in different places on each line):

12345678901234567890123456789012345678901234567890123456789012345678901234567890
123456789_1234567890123456789012345678901234567890123456789012345678901234567890
1234567890123456789_123456789012345678901234567890123456789012345678901234567890
12345678901234567890123456789_12345678901234567890123456789012345678901234567890
123456789012345678901234567890123456789_1234567890123456789012345678901234567890
1234567890123456789012345678901234567890123456789_123456789012345678901234567890
12345678901234567890123456789012345678901234567890123456789_12345678901234567890
123456789012345678901234567890123456789012345678901234567890123456789_1234567890
1234567890123456789012345678901234567890123456789012345678901234567890123456789_

A workaround for this bug is to put 'mpage' in the printing pipeline, even if you're printing "one page per page" via the "-1" flag.

Thus the following command causes HP ColorLaserJet CP2025dn to print lines with "_" normally:

% cat foo.txt | mpage -1 | lp

What is going on here?

gf (gf-interlinks) wrote :

Hello Jcox,
Thank you for submitting this bug and reporting a problem with hplip. You made this bug report some time ago and Ubuntu and hplip have been updated since then.

Could you confirm that this is no longer a problem and that we can close the ticket?
If it is still a problem, are you still interested in finding a solution to this bug?
If you are, could you let us know and, in the current version, could you run the following (only once):
apport-collect 365239
and upload the updated logs and and any other logs that are relevant for this particular issue.

Thank you again for helping make Ubuntu and hplip better.
G

Changed in hplip (Ubuntu):
status: New → Incomplete
Changed in hplip:
status: New → Incomplete
Launchpad Janitor (janitor) wrote :

[Expired for hplip (Ubuntu) because there has been no activity for 60 days.]

Changed in hplip (Ubuntu):
status: Incomplete → Expired
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers