Error while printing with HP Laserjet: 40 EIO Transmission Error with hp backend

Bug #229981 reported by Ruben Verweij on 2008-05-13
This bug affects 9 people
Affects Status Importance Assigned to Milestone
hplip (Ubuntu)
system-config-printer (Ubuntu)

Bug Description

While printing to my HP Laserjet 4000 Series from Ubuntu Hardy Heron 8.04, I get the following error on the screen of the printer: "40 EIO TRANSMISSION ERROR - PRESS START TO CONTINUE". It does however print the page, the page looks just fine. I'm not sure which package causes the error, but I will happily provide more information if needed.

Please provide the information described here:, including the output of the printingbug info script and your cups error log.
Do you need to press START each time to continue the printing?

Ruben Verweij (ruben-verweij) wrote :

No, I don't need to press START, even though the printer asks for it...
I have attached the log files, I hope they'll be useful.

Ruben Verweij (ruben-verweij) wrote :

I observe the same behavior using a Jetdirect-connected HP-4050N printer at my office. Gutsy shows no such error.

Joel Oliver (joelol75) wrote :

I'm having the same problem ("40 EIO 1 Bad Transmission" - "Press Go to Continue") - using JetDirect like above. It prints fine and resets the error after the print job. My /var/log/cups/error_log is empty, but syslog is logging a string of these:

Aug 23 18:43:37 psyserveftp HP_LaserJet_4050_Series?ip= prnt/backend/hp.c 496: unable to connect hpssd socket 2207: Connection refused
Aug 23 18:45:00 psyserveftp last message repeated 2 times

After turning on debugging my error_log is showing (Not sure if relevent):
 Discarding unused printer-state-changed event.
 Discarding unused job-progress event.

The whole debugging error_log is attached along with my dmesg is needed.

Joel Oliver (joelol75) wrote :
Robb Kidd (ubuntu-thekidds) wrote :

I received the same error on Hardy and Intrepid when using the "HP LaserJet 4000 Series Postscript [en] (recommended)" driver. With Intrepid, changing the driver to "HP LaserJet 4000 series Foomatic/hpijs [en]" resulted in a test print without error.

ii foomatic-db-hpijs 20080915-0ubuntu1 OpenPrinting printer support - database for HPIJS driver
ii hpijs 2.8.7-0ubuntu6 HP Linux Printing and Imaging - gs IJS driver (hpijs)
ii hpijs-ppds 2.8.7-0ubuntu6 HP Linux Printing and Imaging - HPIJS PPD files
ii hplip 2.8.7-0ubuntu6 HP Linux Printing and Imaging System (HPLIP)
ii hplip-data 2.8.7-0ubuntu6 HP Linux Printing and Imaging - data files
ii hplip-gui 2.8.7-0ubuntu6 HP Linux Printing and Imaging - GUI utilities

Ruben Verweij (ruben-verweij) wrote :

I can confirm that using the "HP LaserJet 4000 series Foomatic/hpijs [en]" solves the problem. Shouldn't it be set to recommended instead of "HP LaserJet 4000 Series Postscript [en] (recommended)"?

Jan Beranek (jan233321) wrote :

Also have exactly the same problem HP LJ 4000 with default driver. If I choose Generic/PCL5e or PCL6 XL printing works without error.
But tray selection works only with correct "HP LaserJet 4000 Series Postscript [en] (recommended)" driver. Do anybody know, how to get tray selection working with any other driver?

It is problem, I hope it will be solved ASAP.

I also have the same problem in hp 9000 how to solve this???

Luca Aluffi (aluffilu) wrote :

Here is the same with hp 3005 and jaunty.

dpg77 (damien-graves) wrote :

I'm using 9.04 - the Jaunty Jackalope

I had the same problem with a hp 4050 tn printer and every other driver worked except the HP Laserjet 4050 Series Postscript [en] (recommended)
This was great no errors but couldn't setup duplexer or 3rd tray for the printer.

this was using the default HP Linux Imaging and Printing (HPLIP)

I changed the connection type to APPSocket/HP JetDirect

and off it went no errors and no problems accessing duplexer or 3rd tray.

not a fix but maybe a workaround for the problem so people can use trays or duplex units.

lnny (gatorit) wrote :

On 9.04

HP LJ 4100N

It gets the same error using HP LaserJet 4100 Series v3010.107 postscript [en] (recommended)

It works correctly using HP LaserJet 4100 Series Foomatic/ljet4 [en]

I came to this forum because of the error and am glad to report thanks to the info in this forum it works. Hope this helps someone else.

Reuben Firmin (reubenf) wrote :

I had the same issue with my HP Laserjet 8150N. Changing drivers to HP Laserjet 8150 Foomatic/ljet4 solved the problem.

egmi (egmichau) wrote :

On 9.10

HP LJ 4100N

I found a pdf file (a transaction receipt received from Place des Arts) that would not print out using Document Viewer 2.28.1.
But if I print it to a file (PDF again) then print that new file to the LJ4100n, it would then print and produce afterward the EIO 2 error but without consequence.

All this using HP LaserJet 4100 Series v3010.107 postscript [en] (recommended)

On the other hand, all works correctly when using HP LaserJet 4100 Series Foomatic/ljet4 [en]

sdowney717 (sdowney717) wrote :

Ok, thanks, this fixed it. I simply added a new printer and told it to find it and then selected connection type to APPSocket/HP JetDirect

Jay Morris (jaypmorris) wrote :

On 9.04

HP LJ 4050n & 4050

Does any one have a step by step to fixing this problem? i have tried the above approaches and they dont seem to work?

I started seeing this problem after upgrading to 10.10. According to the message near the end of

it is caused by the server closing the TCP connection to the printer before the printer has finished sending back status information.

I fixed the problem by changing the connection type to AppSocket/HP JetDirect.

I'm also getting the 40 EIO BAD TRANSMISSION error on Laserjet 4000N in Ubuntu 10.04 LTS using the HP LaserJet 4000 Series Postscript (recommended) driver.
This is caused by the HPLIP hp: backend, since switching the connection to AppSocket/HP JetDirect (socket:) works.
You can verify the backend used by checking the Device URI/Connection and the driver used by checking Printer Make and Model/Driver in system-config-printer properties/cups webinterface.

But on maverick (hplip 3.10.6-1ubuntu10) it no longer seem to be a problem with the hp backend too.
Adrian Johnson, Ruben Verweij or others, can you confirm? Risk-free testing without installation is possible with the maverick daily-live cd.

summary: - Error while printing with HP Laserjet: 40 EIO Transmission Error
+ Error while printing with HP Laserjet: 40 EIO Transmission Error with hp
+ backend
Changed in hplip (Ubuntu):
status: New → Incomplete

Ignore the last paragraph of my comment above, it turns out on maverick it still is a problem. I just ran into another bug where the wrong gutenprint/simplified driver is used: see bug #653814.
I'm still getting the 40 EIO BAD TRANSMISSION error with the Postscript (recommended) driver and the hp backend in maverick. Switching the connection to AppSocket/HP JetDirect with the Postscript (recommended) driver works around the problem.

Changed in hplip (Ubuntu):
status: Incomplete → Confirmed

Also when setting up my LaserJet 4000N printer in maverick alternatively using the CUPS webinterface and selecting the discovered network printer, the socket (AppSocket/HP JetDirect) connection is used automatically.

Perhaps system-config-printer should default to the socket connection too instead of the hp backend.

sdowney717 (sdowney717) wrote :

ok, I just had to do this again as I was getting E10 bad transmission when I reinstalled the OS.

The solution is firast off let it find the printer IP address, or if you know the ip of the printer good.

then choose under network printer
 "AppSocket/HP JetDirect"

in the Host field enter the ip address of the printer

click forward, select various options and print a test page.
No more E10 errors

Mörgæs (moergaes) wrote :

Closing due to age.
If a similar problem appears in the latest Ubuntu release please open a new report.

Changed in hplip (Ubuntu):
status: Confirmed → Invalid
Changed in system-config-printer (Ubuntu):
status: New → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers