Missing foomatic-rip-hplip filter, used for hpijs-ppds

Bug #211382 reported by Ryan Novosielski on 2008-04-03
2
Affects Status Importance Assigned to Milestone
hplip (Ubuntu)
Medium
Till Kamppeter

Bug Description

Fresh install of Hardy 8.04, up-to-date with all upgrades from yesterday (currently installing today's, but none seem to be printing-related).

I select the HP DeskJet 932C driver using hpijs, which is provided by hpijs-ppds -- note that this driver will not display in the KDE Printing driver list, also mentioned in bug 209220. After selecting this driver and attempting a test page, nothing happens. I eventually discovered in /var/log/cups/error_log:

E [03/Apr/2008:09:49:16 -0400] Filter "foomatic-rip-hplip" for printer "hpdj932c" not available: No such file or directory

It looks as if this filter file is missing, yet no Ubuntu package contains it. I'm at a loss for how to proceed, and frankly, if I had to do anything more than I've already done, there's a bug here as this ought to be very easy. Near as I can tell, I have everything I'd need installed:

ii foomatic-db 20080211-0ubuntu1 OpenPrinting printer support - database
ii foomatic-db-engine 3.0.2-20070719-0ubuntu4 OpenPrinting printer support - programs
ii foomatic-db-hpijs 20070813-0ubuntu2 OpenPrinting printer support - database for
ii foomatic-filters 3.0.2-20071204-0ubuntu2 OpenPrinting printer support - filters
ii hpijs 2.8.2+2.8.2-0ubuntu5 HP Linux Printing and Imaging - gs IJS drive
ii hpijs-ppds 2.8.2+2.8.2-0ubuntu5 HP Linux Printing and Imaging - HPIJS PPD fi
ii hplip 2.8.2-0ubuntu5 HP Linux Printing and Imaging System (HPLIP)
ii hplip-data 2.8.2-0ubuntu5 HP Linux Printing and Imaging - data files
ii hplip-gui 2.8.2-0ubuntu5 HP Linux Printing and Imaging - GUI utilitie

Would love some help, as my current home printer is now non-functional as a result.

Till Kamppeter (till-kamppeter) wrote :

Fix committed to the Debian SVN, Ubuntu package coming soon.

Changed in hplip:
assignee: nobody → till-kamppeter
importance: Undecided → Medium
milestone: none → ubuntu-8.04
status: New → Fix Committed

Thanks much for the quick response, Till. Was something I'd have hated
to see remain broken.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package hplip - 2.8.2-0ubuntu6

---------------
hplip (2.8.2-0ubuntu6) hardy; urgency=low

  * debian/control: Let hpijs depend on foomatic-filters (LP: #187403).
  * debian/control, debian/hplip.links: Added missing links to utilities
    hp-check and hp-scan. Added dependency on python-imaging for hp-scan.
  * debian/rules: Corrected filter name from "foomatic-rip-hplip" to
    "foomatic-rip" (LP: #211382).
  * debian/hplip.preinst: Remove obsolete /etc/default/hplip file before
    installation of the hplip binary package (LP: #211377).

 -- Till Kamppeter <email address hidden> Thu, 3 Apr 2008 22:28:52 +0200

Changed in hplip:
status: Fix Committed → Fix Released
Andre (andrecontiero) wrote :

I tried the following:

$ sudo su
$ hp-plugin -i

and I saw a miracle. I hope that it help you.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Bug attachments