hp-setup plugin file does not match its checksum

Bug #1476011 reported by Nathan Adams on 2015-07-19
12
This bug affects 2 people
Affects Status Importance Assigned to Milestone
HPLIP
Undecided
Unassigned
hplip (Ubuntu)
Undecided
Unassigned

Bug Description

I have a fresh install of Ubuntu 15.04 and am attempting to install hplip and the associated plugin(s) for my printer/scanner (HP LaserJet Pro CM1415fnw color MFP).

After installing hplip, hplip-dbg, hplip-doc, and hplip-gui, I ran hp-setup, selected my printer (connected via Ethernet), and chose to download the associated plug-in. This returned an error dialog:

HP Device Manager - Plug-in Installer
(X) file does not match its checksum. File may have been corrupted or altered

Command line output:

$ hp-setup

HP Linux Imaging and Printing System (ver. 3.15.2)
Printer/Fax Setup Utility ver. 9.0

Copyright (c) 2001-15 Hewlett-Packard Development Company, LP
This software comes with ABSOLUTELY NO WARRANTY.
This is free software, and you are welcome to distribute it
under certain conditions. See COPYING file for more details.

Searching... (bus=net, timeout=5, ttl=4, search=(None) desc=0, method=slp)
error: The printer you are trying to setup requires a binary driver plug-in and it failed to install. Please check your internet connection and try again. Visit http://hplipopensource.com for more infomation.

Done.

Nathan Adams (nadams) wrote :

$ lsb_release -rd
Description: Ubuntu 15.04
Release: 15.04

$ apt-cache policy hplip
hplip:
  Installed: 3.15.2-0ubuntu4.1
  Candidate: 3.15.2-0ubuntu4.1
  Version table:
 *** 3.15.2-0ubuntu4.1 0
        500 http://us.archive.ubuntu.com/ubuntu/ vivid-updates/main amd64 Packages
        100 /var/lib/dpkg/status
     3.15.2-0ubuntu4 0
        500 http://us.archive.ubuntu.com/ubuntu/ vivid/main amd64 Packages

Nathan Adams (nadams) on 2015-07-19
affects: systemd (Ubuntu) → hplip (Ubuntu)
Till Kamppeter (till-kamppeter) wrote :

Did you apply all updates?

Changed in hplip (Ubuntu):
status: New → Incomplete
Changed in hplip:
status: New → Incomplete
goutam (goutamkk) wrote :

Sourceforge site is down (http://sourceforge.net/blog/sourceforge-infrastructure-and-service-restoration/) and unfortunately hp-plugin utility is not able to fetch the plugin.conf from sorceforge site.
Can you directly download the plugin files from here:
https://www.openprinting.org/download/printdriver/auxfiles/HP/plugins/hplip-3.15.2-plugin.run
https://www.openprinting.org/download/printdriver/auxfiles/HP/plugins/hplip-3.15.2-plugin.run.asc

To install the plugin file you can run command 'sudo sh hplip-3.15.2-plugin.run' in terminal or you can run command 'sudo hp-plugin' in terminal and choose the second option to manually select the hplip-3.15.2-plugin.run file and install.

Run command 'hp-setup' to configure the print queue.

Nathan Adams (nadams) wrote :
Download full text (6.1 KiB)

$ sudo apt-get update && sudo apt-get upgrade
Ign http://us.archive.ubuntu.com vivid InRelease
Ign http://security.ubuntu.com vivid-security InRelease
Hit http://security.ubuntu.com vivid-security Release.gpg
Ign http://us.archive.ubuntu.com vivid-updates InRelease
Hit http://security.ubuntu.com vivid-security Release
Ign http://ppa.launchpad.net vivid InRelease
Ign http://us.archive.ubuntu.com vivid-backports InRelease
Hit http://us.archive.ubuntu.com vivid Release.gpg
Hit http://security.ubuntu.com vivid-security/main Sources
Hit http://us.archive.ubuntu.com vivid-updates Release.gpg
Hit http://security.ubuntu.com vivid-security/restricted Sources
Hit http://ppa.launchpad.net vivid Release.gpg
Hit http://us.archive.ubuntu.com vivid-backports Release.gpg
Hit http://security.ubuntu.com vivid-security/universe Sources
Hit http://us.archive.ubuntu.com vivid Release
Hit http://security.ubuntu.com vivid-security/multiverse Sources
Hit http://ppa.launchpad.net vivid Release
Hit http://us.archive.ubuntu.com vivid-updates Release
Hit http://security.ubuntu.com vivid-security/main amd64 Packages
Hit http://us.archive.ubuntu.com vivid-backports Release
Hit http://security.ubuntu.com vivid-security/restricted amd64 Packages
Hit http://ppa.launchpad.net vivid/main amd64 Packages
Hit http://us.archive.ubuntu.com vivid/main Sources
Hit http://security.ubuntu.com vivid-security/universe amd64 Packages
Hit http://us.archive.ubuntu.com vivid/restricted Sources
Hit http://security.ubuntu.com vivid-security/multiverse amd64 Packages
Hit http://us.archive.ubuntu.com vivid/universe Sources
Hit http://security.ubuntu.com vivid-security/main i386 Packages
Hit http://ppa.launchpad.net vivid/main i386 Packages
Hit http://us.archive.ubuntu.com vivid/multiverse Sources
Hit http://security.ubuntu.com vivid-security/restricted i386 Packages
Hit http://us.archive.ubuntu.com vivid/main amd64 Packages
Hit http://security.ubuntu.com vivid-security/universe i386 Packages
Hit http://ppa.launchpad.net vivid/main Translation-en
Hit http://us.archive.ubuntu.com vivid/restricted amd64 Packages
Hit http://security.ubuntu.com vivid-security/multiverse i386 Packages
Hit http://us.archive.ubuntu.com vivid/universe amd64 Packages
Hit http://security.ubuntu.com vivid-security/main Translation-en
Hit http://us.archive.ubuntu.com vivid/multiverse amd64 Packages
Hit http://security.ubuntu.com vivid-security/multiverse Translation-en
Hit http://us.archive.ubuntu.com vi...

Read more...

Nathan Adams (nadams) wrote :

Thank you, goutamkk. Your work-around was successful with 1 thing of note:

During hp-setup this error dialog is returned:

HP Device Manager - Setup
(X) Unable to locate the HPLIP Fax PPD file:
HP-Fax2-hpcups.ppd.ga
Fax setup has been disabled.

This isn't a problem for me, but others may need the fax driver as well.

Launchpad Janitor (janitor) wrote :

[Expired for hplip (Ubuntu) because there has been no activity for 60 days.]

Changed in hplip (Ubuntu):
status: Incomplete → Expired
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers