hpfax crashed with PermissionError in __main__: [Errno 13] Permission denied: '/home/clh/.hplip/hp_fax-pipe-2'

Bug #1437753 reported by Chris Hermansen on 2015-03-28
20
This bug affects 3 people
Affects Status Importance Assigned to Milestone
hplip (Fedora)
Fix Released
Undecided
hplip (Ubuntu)
Medium
Unassigned

Bug Description

Installing HP printer with settings>printers when this occurred.

ProblemType: Crash
DistroRelease: Ubuntu 15.04
Package: hplip 3.15.2-0ubuntu4
ProcVersionSignature: Ubuntu 3.19.0-10.10-generic 3.19.2
Uname: Linux 3.19.0-10-generic x86_64
ApportVersion: 2.16.2-0ubuntu5
Architecture: amd64
CupsErrorLog:
 W [28/Mar/2015:15:43:02 -0700] Notifier for subscription 2 (dbus://) went away, retrying!
 W [28/Mar/2015:15:58:10 -0700] Notifier for subscription 2 (dbus://) went away, retrying!
 W [28/Mar/2015:15:58:11 -0700] Notifier for subscription 4 (dbus://) went away, retrying!
 W [28/Mar/2015:15:58:11 -0700] Notifier for subscription 6 (dbus://) went away, retrying!
Date: Sat Mar 28 16:24:34 2015
ExecutablePath: /usr/lib/cups/backend/hpfax
InstallationDate: Installed on 2015-03-28 (0 days ago)
InstallationMedia: Ubuntu 15.04 "Vivid Vervet" - Beta amd64 (20150326)
InterpreterPath: /usr/bin/python3.4
Lpstat:
 device for Hewlett-Packard-HP-LaserJet-Professional-P1102w: hp:/net/HP_LaserJet_Professional_P1102w?zc=NPI4E67A6
 device for HP-Fax: hpfax:/net/HP_LaserJet_Professional_M1212nf_MFP?zc=NPIA0DECA
MachineType: Gigabyte Technology Co., Ltd. EP45-UD3P
Papersize: letter
PpdFiles:
 Hewlett-Packard-HP-LaserJet-Professional-P1102w: HP LaserJet Pro P1102w Foomatic/foo2zjs-z2 (recommended)
 HP-Fax: HP Fax hpcups
ProcCmdline: /usr/bin/python3 /usr/lib/cups/backend/hpfax 2 clh Test\ Page 1 job-uuid=urn:uuid:dcbc0664-9d88-3486-493a-f7cd02279545\ job-originating-host-name=localhost\ time-at-creation=1427585074\ time-at-processing=1427585074
ProcEnviron:
 PATH=(custom, no user)
 LANG=en_CA.UTF-8
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.19.0-10-generic root=UUID=875222c0-9e4e-4b22-8578-4288c2b68aea ro quiet splash vt.handoff=7
PythonArgs: ['/usr/lib/cups/backend/hpfax', '2', 'clh', 'Test Page', '1', 'job-uuid=urn:uuid:dcbc0664-9d88-3486-493a-f7cd02279545 job-originating-host-name=localhost time-at-creation=1427585074 time-at-processing=1427585074']
SourcePackage: hplip
Title: hpfax crashed with PermissionError in __main__: [Errno 13] Permission denied: '/home/clh/.hplip/hp_fax-pipe-2'
UdevLog: Error: [Errno 2] No such file or directory: '/var/log/udev'
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups:

dmi.bios.date: 05/20/2009
dmi.bios.vendor: Award Software International, Inc.
dmi.bios.version: FB
dmi.board.name: EP45-UD3P
dmi.board.vendor: Gigabyte Technology Co., Ltd.
dmi.board.version: x.x
dmi.chassis.type: 3
dmi.chassis.vendor: Gigabyte Technology Co., Ltd.
dmi.modalias: dmi:bvnAwardSoftwareInternational,Inc.:bvrFB:bd05/20/2009:svnGigabyteTechnologyCo.,Ltd.:pnEP45-UD3P:pvr:rvnGigabyteTechnologyCo.,Ltd.:rnEP45-UD3P:rvrx.x:cvnGigabyteTechnologyCo.,Ltd.:ct3:cvr:
dmi.product.name: EP45-UD3P
dmi.sys.vendor: Gigabyte Technology Co., Ltd.

Version-Release number of selected component:
hplip-3.13.9-2.fc19

Additional info:
reporter: libreport-2.1.7
cmdline: /usr/bin/python /usr/lib/cups/backend/hpfax 99 mejh 'Driving Directions from 3408 94th Ave N, Minneapolis, Minnesota 55443 to [4000-4099] Pipewood Cir, Excelsior, Minnesota 55331 | MapQuest' 1 'Encoding=MMR Quality=Standard PageSize=Letter number-up=1 job-uuid=urn:uuid:9d440415-89bb-3f9a-5662-9de076facee9 job-originating-host-name=localhost time-at-creation=1381010921 time-at-processing=1381010921'
executable: /usr/lib/cups/backend/hpfax
kernel: 3.11.2-201.fc19.x86_64
runlevel: N 5
type: Python
uid: 0

Truncated backtrace:
#1 <module> in /usr/lib/cups/backend/hpfax:258

Created attachment 808320
File: backtrace

Created attachment 808321
File: environ

In case it helps the following fixed the problem for me:

sudo mkdir /var/run/hplip

Really? That's odd... hplip already ships a /var/run/hplip directory.

$ rpm -qlv hplip | grep var/run
drwxrwxr-x 2 root lp 0 Nov 6 09:44 /var/run/hplip

...but something deletes it.

# rpm -V hplip
missing /var/run/hplip

Oh, of course, /var/run is a tmpfs now.

hplip-3.13.11-2.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/hplip-3.13.11-2.fc20

hplip-3.13.11-2.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/hplip-3.13.11-2.fc19

hplip-3.13.11-2.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/hplip-3.13.11-2.fc18

Package hplip-3.13.11-2.fc18:
* should fix your issue,
* was pushed to the Fedora 18 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing hplip-3.13.11-2.fc18'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-21827/hplip-3.13.11-2.fc18
then log in and leave karma (feedback).

hplip-3.13.11-4.fc20 has been pushed to the Fedora 20 stable repository. If problems still persist, please make note of it in this bug report.

hplip-3.13.11-4.fc19 has been pushed to the Fedora 19 stable repository. If problems still persist, please make note of it in this bug report.

hplip-3.13.11-4.fc18 has been pushed to the Fedora 18 stable repository. If problems still persist, please make note of it in this bug report.

Chris Hermansen (c-hermansen) wrote :
tags: removed: need-duplicate-check
Changed in hplip (Ubuntu):
importance: Undecided → Medium
information type: Private → Public
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in hplip (Ubuntu):
status: New → Confirmed
Reinhard Tartler (siretart) wrote :

This backtrace is pretty much the same as https://bugzilla.redhat.com/show_bug.cgi?id=1015831 - redhat/fedora has released a fix to accomodate that /var/run is now a tmpfs. Does the fix also apply to Ubuntu?

Changed in hplip (Fedora):
importance: Unknown → Undecided
status: Unknown → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.