[Gutsy] HPLIP menu entries

Bug #134480 reported by Alan Wright on 2007-08-24
2
Affects Status Importance Assigned to Milestone
hplip (Ubuntu)
Medium
Unassigned

Bug Description

This is similar to #67892 (same messages) but occurs with Tribe 5 CD live. HPLIP Toolbox from System/Preferences, and both Fax address book and HPLIP fax utility from Apps/Office produce the message that PyQT is not installed. Should these entries be included in the menus?

Till Kamppeter (till-kamppeter) wrote :

Now as calling the tools from the menus gives a decent message telling the user what he has to do I do not see a problem here. Hiding the tools completely is a bad idea. Then users will not know that there are tools to access the extra functionality of their HP MF devices. The solution of hiding the menu entries comes from the time when there was no message and calling the menu entries simply did nothing.

Changed in hplip:
status: New → Invalid
Alan Wright (alan-sailaway) wrote :

I would say the problem is for someone new to Linux. They would expect menu entries to work, not that they should have to install more software. Why not have the prereq s/w already installed? Also, the HP entries are only relevant to those using HP h/w (I presume).

Two issue we had with Feisty seem to pop up again:
1) The 3 HPLIP menu entries clutter up the menu for people that don't have HP hardware.
In Feisty we did hide the HPLIP menu entries by setting NoDisplay=true in the desktop files. The HPLIP entries could be made visible by clicking System > Preferences > Main Menu which creates a copy of the desktop file in ~/.local/share/applications/ with NoDisplay=false. This approach should be avoided as it can lead to duplicate HPLIP menu entries on dist-upgrades because of name changes, additions or removals of desktop files.
2) People expect menu entries to work without the need to install extra packages. The python-qt3 package is not installed by default because this package and its dependencies take up too much space on the Ubuntu Desktop CD. After clicking the HPLIP entries a GUI message "the python-qt3 package must be installed for this program to work" is shown and the user needs to manually install this package.

I believe the best way to avoid these issues is to create a hplip-gui package as suggested by Till Kamppeter in bug #67892:

> So my suggestion is to move the 3 .desktop files into a
> separate binary package named "hplip-gui", but with the
> "NoDisplay=true" lines removed. "hplip-gui" will then depend on
> python-qt and hplip and it will only be installed by default on
> the Kubuntu (KDE-based) desktop CD but not on the desktop CDs
> of Ubuntu (GNOME) and Xubuntu (XFCE). the "hplip" package
> should recommend/suggest "hplip-gui" so that a package
> installer tool makes the user aware of the available GUI.

> So a user who wants to have the HPLIP GUIs on Ubuntu or Xubuntu
> has to install only the "hplip-gui" package and everything
> needed gets installed.

This would close the hplip upgrade task of bug #86893 and bug #67892 again.

Changed in hplip:
status: Invalid → New
Changed in hplip:
importance: Undecided → Medium
status: New → Triaged
Changed in hplip:
status: Triaged → Fix Committed
Till Kamppeter (till-kamppeter) wrote :

hplip (2.7.7.dfsg.1-0ubuntu2) gutsy; urgency=low

  * debian/control, debian/hplip.install, debian/hplip-gui.install,
    debian/rules:
    Moved menu entries for the GUI utilities into the new hplip-gui package.
    This package requires python-qt3 and so the menu entries can never appear
    if python-qt3 is not installed. Let the main package (hplip) recommend
    hplip-gui instead of python-qt3 now. Fixes: LP: #67892, LP: #86893,
    LP: #134480, LP: #137168

 -- Till Kamppeter <email address hidden> Wed, 5 Sep 2007 10:05:57 +0100

Changed in hplip:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers