HP1510 Not Printing

Bug #1315864 reported by Elfy on 2014-05-04
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
hplip (Ubuntu)
Undecided
Unassigned
Trusty
Undecided
Unassigned

Bug Description

Added printer in updated UU.

Add printer dialogue recommended a different printer. Same printer was recognised as 1510 (and works) correctly in 14.04

Appears to install correctly - appears to print - print queue empties - nothing prints.

ProblemType: Bug
DistroRelease: Ubuntu 14.10
Package: cups 1.7.2-2
ProcVersionSignature: Ubuntu 3.13.0-24.46-generic 3.13.9
Uname: Linux 3.13.0-24-generic x86_64
NonfreeKernelModules: nvidia
ApportVersion: 2.14.2-0ubuntu2
Architecture: amd64
CurrentDesktop: XFCE
Date: Sun May 4 13:35:31 2014
InstallationDate: Installed on 2014-05-04 (0 days ago)
InstallationMedia: Xubuntu 14.10 "Utopic Unicorn" - Alpha amd64 (20140503)
Lpstat: device for HP-Deskjet-1510-series: usb://HP/Deskjet%201510%20series?serial=CN38E1HH7405YR&interface=1
MachineType: Gigabyte Technology Co., Ltd. To be filled by O.E.M.
Papersize: a4
PpdFiles: HP-Deskjet-1510-series: HP DeskJet 1220C - CUPS+Gutenprint v5.2.10-pre2
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.13.0-24-generic root=UUID=3146854d-c104-40e5-8151-e15c3d2a5b55 ro quiet splash
SourcePackage: cups
UpgradeStatus: No upgrade log present (probably fresh install)
dmi.bios.date: 06/21/2012
dmi.bios.vendor: American Megatrends Inc.
dmi.bios.version: FE
dmi.board.asset.tag: To be filled by O.E.M.
dmi.board.name: H61M-S2PV
dmi.board.vendor: Gigabyte Technology Co., Ltd.
dmi.board.version: To be filled by O.E.Mx
dmi.chassis.asset.tag: To Be Filled By O.E.M.
dmi.chassis.type: 3
dmi.chassis.vendor: Gigabyte Technology Co., Ltd.
dmi.chassis.version: To Be Filled By O.E.M.
dmi.modalias: dmi:bvnAmericanMegatrendsInc.:bvrFE:bd06/21/2012:svnGigabyteTechnologyCo.,Ltd.:pnTobefilledbyO.E.M.:pvrTobefilledbyO.E.M.:rvnGigabyteTechnologyCo.,Ltd.:rnH61M-S2PV:rvrTobefilledbyO.E.Mx:cvnGigabyteTechnologyCo.,Ltd.:ct3:cvrToBeFilledByO.E.M.:
dmi.product.name: To be filled by O.E.M.
dmi.product.version: To be filled by O.E.M.
dmi.sys.vendor: Gigabyte Technology Co., Ltd.

Elfy (elfy) wrote :
Till Kamppeter (till-kamppeter) wrote :

Please follow the instructions of the sections "CUPS error_log" and "Capturing print job data" on https://wiki.ubuntu.com/DebuggingPrintingProblems. Please attach the files one by one, do not compress them or package them together. Thanks

Changed in cups (Ubuntu):
status: New → Incomplete
Elfy (elfy) wrote :

That wiki makes no sense if you don't use gnome.

I've added the necessary files to the bug. Though I didn't get any further previously than trying to print a test page when installing.

Elfy (elfy) wrote :
Elfy (elfy) on 2014-05-06
Changed in cups (Ubuntu):
status: Incomplete → New
Till Kamppeter (till-kamppeter) wrote :

Were there any problems to obtain error_log? Please follow the instructions of the "error_log" section on https://wiki.ubuntu.com/DebuggingPrintingProblems. What I need is the error_log in debug mode of one of your print jobs which does not come out correctly for you. Please simply print the job again which you tried to print.

If you have any problem with following the instruction, please post here about your problems. Thanks.

Changed in cups (Ubuntu):
status: New → Incomplete
Elfy (elfy) wrote :
Changed in cups (Ubuntu):
status: Incomplete → New
affects: cups (Ubuntu) → hplip (Ubuntu)
Changed in hplip (Ubuntu):
status: New → Triaged
Till Kamppeter (till-kamppeter) wrote :

Fixed in HPLIP 3.14.3-0ubuntu5. Please re-create your print queue after updating to this version.

Changed in hplip (Ubuntu):
status: Triaged → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package hplip - 3.14.3-0ubuntu5

---------------
hplip (3.14.3-0ubuntu5) utopic; urgency=low

  * debian/rules: Corrected copy-and-paste error in previous release which
    deactivated hpcups printer support completely (LP: #1315864, LP: #1311697).
 -- Till Kamppeter <email address hidden> Wed, 7 May 2014 12:40:00 +0200

Changed in hplip (Ubuntu):
status: Fix Committed → Fix Released
Elfy (elfy) wrote :

Removed installed printer, reinstalled it - works fine.

Thanks :)

Chris J Arges, Trusty is handled in bug 1311697, as the problem was introduced by the SRU handled there. I have already uploaded the fix of this bug as the correction for the SRU.

Changed in hplip (Ubuntu Trusty):
status: New → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers