Fax sending broken (after upgrading to raring?)

Bug #1187132 reported by Christian Hoffmann on 2013-06-03
24
This bug affects 4 people
Affects Status Importance Assigned to Milestone
hplip (Ubuntu)
Undecided
Unassigned

Bug Description

(Fix/Workaround included, see below)

Reproduce:
Try sending a fax using the fax printer from Evince, LibreOffice, etc.

Expected result:
Target phone number selection dialog should appear (from hplip).

Actual result:
Nothing visible happens / dialog doesn't appear.

OR

Reproduce:
Try sending a fax using the hp-sendfax utility. Cover page dialog appears, continue to the next step, add a PDF file (or anything else).

Expected result:
File should be listed in the file overview in hp-sendfax's dialog.

Actual result:
Returning from the file selection dialog does not trigger any visible action (selected file does not appear in the file list).

Debugging:
Saw this in the syslog:
hpcupsfax[12947]: common/utils.c 253: Failed to check directory [/var/log/hp/tmp] errno[2]

... so I created /var/log/hp/tmp (parent directory already existed).

Tried sending a fax again, saw this in the syslog:
hpcupsfax[31352]: prnt/hpijs/hpcupsfax.cpp 685: ERROR: Unable to open Fax output file - /var/log/hp/tmp/hplipfaxLog_sPUT65 for writing

Played with permissions on /var/log/hp/tmp until it worked. root:lp/775 sounds halfway sane and works for me. lp:.../755 would probably be okay as well.

Suggested fix:
Ensure that /var/log/hp/tmp gets pre-created with sane permissions or patch/configure hplip to use another path maybe (?).

I am not entirely sure when this bug got introduced. I had sent my last fax about two months ago, so it was certainly before the upgrade to raring.
I assume this bug is not printer-specific.

Similar issue in Fedora Core: https://bugs.launchpad.net/hplip/+bug/1055510

ProblemType: Bug
DistroRelease: Ubuntu 13.04
Package: hplip 3.13.3-1
ProcVersionSignature: Ubuntu 3.8.0-22.33-generic 3.8.11
Uname: Linux 3.8.0-22-generic x86_64
ApportVersion: 2.9.2-0ubuntu8
Architecture: amd64
Date: Mon Jun 3 22:50:14 2013
EcryptfsInUse: Yes
InstallationDate: Installed on 2011-06-17 (717 days ago)
InstallationMedia: Ubuntu 11.04 "Natty Narwhal" - Release amd64 (20110427.1)
Lpstat:
 device for Officejet_6500_E709a: hp:/net/Officejet_6500_E709a?zc=HPD8265E
 device for Officejet_6500_E709a_fax: hpfax:/net/Officejet_6500_E709a?zc=HPD8265E
MachineType: Gigabyte Technology Co., Ltd. GA-880GA-UD3H
MarkForUpload: True
Papersize: a4
PpdFiles:
 Officejet_6500_E709a: HP Officejet 6500 e709a, hpcups 3.13.3
 Officejet_6500_E709a_fax: HP Fax hpcups
ProcEnviron:
 TERM=xterm
 PATH=(custom, no user)
 XDG_RUNTIME_DIR=<set>
 LANG=de_DE.UTF-8
 SHELL=/bin/bash
ProcKernelCmdLine: BOOT_IMAGE=/vmlinuz-3.8.0-22-generic root=UUID=93f6756c-a6cb-4dde-9875-e61e6daacefa ro quiet splash vt.handoff=7
SourcePackage: hplip
UpgradeStatus: Upgraded to raring on 2013-04-25 (39 days ago)
dmi.bios.date: 11/24/2010
dmi.bios.vendor: Award Software International, Inc.
dmi.bios.version: F7
dmi.board.name: GA-880GA-UD3H
dmi.board.vendor: Gigabyte Technology Co., Ltd.
dmi.board.version: x.x
dmi.chassis.type: 3
dmi.chassis.vendor: Gigabyte Technology Co., Ltd.
dmi.modalias: dmi:bvnAwardSoftwareInternational,Inc.:bvrF7:bd11/24/2010:svnGigabyteTechnologyCo.,Ltd.:pnGA-880GA-UD3H:pvr:rvnGigabyteTechnologyCo.,Ltd.:rnGA-880GA-UD3H:rvrx.x:cvnGigabyteTechnologyCo.,Ltd.:ct3:cvr:
dmi.product.name: GA-880GA-UD3H
dmi.sys.vendor: Gigabyte Technology Co., Ltd.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in hplip (Ubuntu):
status: New → Confirmed
PJSingh5000 (pjsingh5000) wrote :

Experiencing the same issue. Looks like a regression of Bug #153152.

Kevin Dalley (nereocystis) wrote :

Creating /var/log/hp/tmp owner by root:root, with permissions of 777 fixed the problem.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package hplip - 3.13.9-0ubuntu1

---------------
hplip (3.13.9-0ubuntu1) saucy; urgency=low

  [ Till Kamppeter ]
  * New upstream release
     o Bug fixes and added hardware support
     o Added support for: HP Designjet Z5400 44-in PostScript ePrinter,
       Deskjet Ink Advantage 1018 Printer, 1518/2540/2545/2546 All-in-One
       Printer, 4515/4518 e-All-in-One Printer, Envy 4504 e-All-in-One,
       LaserJet Pro MFP M435nw, Officejet 4630/4632/4635 e-All-in-One Printer,
       OfficeJet Pro 8600 Premium e-AiO N911n, Photosmart 5521 e-All-in-One
       Printer
     o HP OfficeJet G55 is not detecting through USB (LP: #1209339)
     o Collate broken under hplip-3.13.7 as hpps sends SET COPIES (LP: #1209352)
     o Fix for plugin (firmware) installation and test page in 'hp-setup -i'
  * debian/patches/10_shebang_fixes.dpatch,
    debian/patches/hp-setup-prompt-for-custom-PPD.dpatch,
    debian/patches/kbsd.dpatch,
    debian/patches/make-commafy-correctly-work-with-python-2.dpatch,
    debian/patches/black-stripes-on-pcl5c-printouts.dpatch: Removed, applied
    upstream.
  * debian/patches/hp_photosmart_pro_b9100_support.dpatch,
    debian/patches/hp-check_debian.dpatch
    debian/patches/hp-mkuri-take-into-account-already-installed-plugin-also-for-exit-value.dpatch,
    debian/patches/simple-scan-as-default.dpatch,
    debian/patches/add-lidil-two-cartridge-modes.dpatch,
    debian/patches/hp-systray-make-menu-title-visible-in-sni-qt-indicator.dpatch,
    debian/patches/hp-systray-make-menu-appear-in-sni-qt-indicator-with-kde.dpatch,
    debian/patches/hpaio-option-duplex.diff: Refreshed with quilt.
  * debian/patches/ubuntu-hp-mkuri-notification-text.dpatch: Manually adapted
    to the new source code.
  * debian/hplip.install, debian/rules: Removed hplipjs and hpcac filters, they
    are removed from HPLIP.
  * debian/hplip.dirs, debian/hplip.postinst, debian/hplip.postrm: Added
    /var/log/hp/tmp/ (775 root.lp), needed by hp-sendfax (LP: #1187132).
  * debian/printer-driver-postscript-hp.install: Some DesignJet PPDs do not
    have "ps" in their names and therefore did not get packaged.
  * debian/non-shipped-files.txt: Updated.
  * debian/rules: Remove the non-shipped files in the end of the install-stamp
    rule, as some of them get created after "make install" by this rule.
  * debian/rules: Do not create HAL .fdi file.
 -- Till Kamppeter <email address hidden> Wed, 11 Sep 2013 21:36:00 +0200

Changed in hplip (Ubuntu):
status: Confirmed → Fix Released
Kevin Dalley (nereocystis) wrote :

But this fix is not part of raring. This makes hp-sendfax unusable in raring, without mkdir and chmod.

Please place the fix into raring.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers