does not recognize multimedia keys, euro and dollar key on Acer Aspire

Bug #90687 reported by Jaap Haitsma on 2007-03-08
22
This bug affects 3 people
Affects Status Importance Assigned to Milestone
hotkey-setup (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: hotkey-setup

The multimedia keys are not recognized. I cannot assign them in the keyboard shortcuts capplet

Lucas Arruda (lucasarruda) wrote :

This seems to affect Aspire 5672 also.

Some keys like +, -, (e-mail), works, but not the >/II (play/pause), I<< (previous) and >>I (next).

Thanks in advance.

Gabriel Mazetto (brodock) wrote :

i can confirm that...
also the $ and euro key near the arrows don't work too

Thanks for your bug report.

Please provide the information as described here:
https://wiki.ubuntu.com/LaptopTestingTeam/HotkeyResearch.

Changed in hotkey-setup:
assignee: nobody → pascal-devuyst
status: New → Incomplete
Jaap Haitsma (jaap) wrote :

I don't get any response with any of th methods

$ sudo dmidecode -s system-manufacturer
$ sudo dmidecode -s system-product-name
$ sudo dmidecode -s system-version

Acer
Aspire 5630
V3.24

Changed in hotkey-setup:
assignee: pascal-devuyst → nobody
status: Incomplete → New
status: New → Confirmed
Gabriel Mazetto (brodock) wrote :

Just to let you know, it's working fine on Ubuntu Hardy Heron, seens solved for me

I have two different acer laptops, in which some multimedia keys are not working. I'll add them here, in case somebody can update /usr/share/hotkey-setup/acer*

Acer Aspire 6935G
sudo dmidecode -s system-manufacturer
Acer
sudo dmidecode -s system-product-name
Aspire 6935
sudo dmidecode -s system-version
V1.06

These are kernel keycodes
keycode e003 (unknown by kernel) should be rewind
keycode e009 (unknown by kernel) should be fast forward
keycode e01e (unknown by kernel) shows a returning arrow, will update when I know what this is for.
keycode e012 (unknown by kernel) shows a jumping man, will update when I know what this is for.
keycode e04a (unknown by kernel) hold (works in hardware as of now) (disables/enables the rest of the keys)

Euro and dollar keys are not working either. kernel keycodes are e033 (€) and e034 ($)

AddBrightness (X keycode 126), apart from working, is giving me ±

marco.pallotta (marco-pallotta) wrote :

Also In my Acer Aspire 5920 multimedia keys don't run (either in Hardy or in Intrepid).
In 8.10 is there a workaround (not a fix) to make these keys recognisible (thanks to Percy Leonhardt for this as you can read from bug #152016). With the workaround you have to insert the command
xinput set-button-map "4" 1 2 3 17 18 19 20 8 9 10 11 12 13 14 15 16
in system -> preferences -> sessions -> startup programs and then restart X
After the restart if you go to the system -> preferences -> keyboard shortcuts you can now assign the multimedia keys to an action.
The strange thing is that even before inserting the command above and go to system -> preferences -> keyboard shortcuts the actions play, stop, next track and so on are assigned to shortcuts XF86AudioPlay, XF86AudioStop, etc, that are the real assignments of the multimedia keys. You can try this:
- inserting the command above (xinput set-button-map etc etc etc)
- restarting X
- going to system -> preferences -> keyboard shortcuts and trying to re-customize the actions I told before

Obviously before inserting the xinput command and you try to re-customize the actions play, stop, next track, etc you cannot do it as the multimedia keys don't run.

After you insert xinput and restart you can reassign the shortcuts for the launch media player as the default shortcut doesn't do anything. I assign this action to Acer Empower key (the key with the "e"). Now when you press it rhythmbox is launched. Then if you load some files and try to listen them via rhythmbox you realize that multimedia keys don't run or, to say better, don't do nothing but they change the light when "pressed".

I also confirm that euro and dollar keys don't work.

@Brodock can we know the steps that you did to make them (multimedia, dollar, and euro keys) work on Hardy?

marco.pallotta (marco-pallotta) wrote :

I forgot to say that also the Acer Arcade key isn't recognisible. If I press it I can see, from the log files:
Jan 1 16:48:15 ubuntu kernel: [ 2255.899383] atkbd.c: Unknown key pressed (translated set 2, code 0x92 on isa0060/serio0).
Jan 1 16:48:15 ubuntu kernel: [ 2255.899398] atkbd.c: Use 'setkeycodes e012 <keycode>' to make it known.
Jan 1 16:48:15 ubuntu kernel: [ 2255.909421] atkbd.c: Unknown key released (translated set 2, code 0x92 on isa0060/serio0).
Jan 1 16:48:15 ubuntu kernel: [ 2255.909434] atkbd.c: Use 'setkeycodes e012 <keycode>' to make it known.

marco.pallotta (marco-pallotta) wrote :

Another clarification about my first comment: In fact I sayd the the multimedia keys change the light when "pressed", after passing the workaround (xinput). To say the truth these keys change the light also before the workaround. So this property isn't associable to the workaround.

Percy Leonhardt (p3y) wrote :

About the arcade, euro and dollar keys:

You have to edit the file /usr/share/hal/fdi/information/10freedesktop/30-keymap-acer.fdi to get them working. I must admit I mapped euro and dollar to page up and down as it makes more sense for me but there should be a way to get euro and dollar instead when needed. Here is what I have added to and changed in the above file:

<append key="input.keymap.data" type="strlist">e012:f24</append> <!-- Media key -->
<append key="input.keymap.data" type="strlist">e033:pageup</append> <!-- Euro symbol -->
<append key="input.keymap.data" type="strlist">e034:pagedown</append> <!-- Dollar symbol -->

This way I can use the arcade key to start Rhythmbox and use the e-Key for something different...

About the media keys:

I did not map them to a function or command using the keyboard settings but instead created a file ~/.xbindkeysrc containing:

"rhythmbox-client --play-pause"
   b:17

"rhythmbox-client --pause"
   b:18

"rhythmbox-client --previous"
   b:19

"rhythmbox-client --next"
   b:20

Then I added a new entry in Gnome sessions which just contains the command 'xbindkeys' to get the file loaded on start up. Please take a look at this thread http://ubuntuforums.org/showthread.php?t=517156 there is also an example for Amarok at point 15.

Bye, Percy

Percy, your suggestions don't work for me (Ubuntu Hardy Heron on Acer Aspire 5920).
About the acrace, euro and dollar keys, I tested all you sayd in 30-keymap-acer.fdi, and then I rebooted, but nothing happened. To say the truth in the default file of my Hadry there already is the entry related to euro and dollar keys
        <append key="input.keymap.data" type="strlist">e033:euro</append> <!-- Euro symbol -->
        <append key="input.keymap.data" type="strlist">e034:dollar</append> <!-- Dollar symbol -->

but they don't work. Is there a way to debug the key mapping?

About the multimedia keys, I created the ~/.xbindkeysrc as you suggested. I downloaded xbindkeys package and the I added it to gnome session startup, but nothing happened at the X restart. I made a debug of xbindkeys launching it from command line:

displayName = :0.0
rc file = /home/marco/.xbindkeysrc
rc guile file = /home/marco/.xbindkeysrc.scm
getting rc guile file /home/marco/.xbindkeysrc.scm.
WARNING : /home/marco/.xbindkeysrc.scm not found or reading not allowed.
4 keys in /home/marco/.xbindkeysrc

min_keycode=8 max_keycode=255 (ie: know keycodes)
"rhythmbox-client --play-pause"
    m:0x0 + b:17 (mouse)
"rhythmbox-client --pause"
    m:0x0 + b:18 (mouse)
"rhythmbox-client --previous"
    m:0x0 + b:19 (mouse)
"rhythmbox-client --next"
    m:0x0 + b:20 (mouse)
starting loop...

Percy Leonhardt (p3y) wrote :

Hi Marco,

sorry, my suggestions were for Intrepid, for Hardy you should follow the complete instructions at the above mentioned forum thread. There are some changes you have to make to your xorg.conf in Hardy that are no longer possible in Intrepid because of the very minimal xorg.conf. That's why you need the xinput-workaround on Intrepid.

The workaround with the .fdi-file is also only valid for Intrepid or at least it was not necessary for Hardy...

Percy Leonhardt (p3y) wrote :

Marco, one more thing about the xbindkeys: this will only work if you manage to setup the mediakeys so that they simulate mouse buttons 17-20. That's what the 'b:' means in the .xbindkeysrc. You can manage this on Hardy with changes to xorg.conf or on Intrepid with the xinput-workaround.

I forgot to say earlier that I am using Intrepid

Percy,

I tried your workaround on Intrepid but:
- the modifications to the file 30-keymap-acer.fdi didn't take effects (after changing the file I restarted the keyboard-setup service and then I restarted X as I couldn't reboot the machine seen that I used an Intrepid live)
- I didn't find the xbindkeys package in the Intrepid repos (in Ubuntu they are present) so I couldn't test the rhythmbox tips (have you downloaded this package directly from its www site?)

Hi Marco,
> - the modifications to the file 30-keymap-acer.fdi didn't take effects

I think you have to restart hal.

> - I didn't find the xbindkeys package in the Intrepid repos (in Ubuntu they are present)

Sorry, not sure what you mean but I just started Synaptic on Intrepid
and there is a package xbindkeys.

Also remember that you need the xinput-workaround to map the mediakeys
to different buttons before xbindkeys will work.

Percy, I did again as you sayd and now:

1) the modifications to the file 30-keymap-acer.fdi only take effects (after hal restarting as you suggested) for "Media key" but not for euro or dollar keys (I also tested these symbols with the pagup and pagedown as you did but with no success).
2) the xbindkeys modifications seem not to take effects (pressing pause/play, stop, next and previous keys, after having launched rhythmbox and playing some songs, nothing happens).
If I launch xbindkeys with the flag -v I have:

ubuntu@ubuntu:~$ xbindkeys -v
displayName = :0.0
rc file = /home/ubuntu/.xbindkeysrc
rc guile file = /home/ubuntu/.xbindkeysrc.scm
getting rc guile file /home/ubuntu/.xbindkeysrc.scm.
WARNING : /home/ubuntu/.xbindkeysrc.scm not found or reading not allowed.
4 keys in /home/ubuntu/.xbindkeysrc

min_keycode=8 max_keycode=255 (ie: know keycodes)
"rhythmbox-client --play-pause"
    m:0x0 + b:17 (mouse)
"rhythmbox-client --pause"
    m:0x0 + b:18 (mouse)
"rhythmbox-client --previous"
    m:0x0 + b:19 (mouse)
"rhythmbox-client --next"
    m:0x0 + b:20 (mouse)
starting loop...

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers