Brightness buttons don't work on System76 Z35F

Bug #131672 reported by Marc Tardif on 2007-08-10
6
Affects Status Importance Assigned to Milestone
hotkey-setup (Ubuntu)
Medium
Marc Tardif

Bug Description

I'm running gutsy tribe-4 on a System76 Z35F. When pressing the brightness buttons, nothing happens. When trying the buttons in System -> Preferences -> Keyboard Shortcuts, nothing happens. What kind of information could I provide to diagnose this problem?

Thanks for your bug report.

Please provide the information as described here: https://wiki.ubuntu.com/LaptopTestingTeam/HotkeyResearch.

Changed in hotkey-setup:
importance: Undecided → Medium
Changed in hotkey-setup:
assignee: pascal-devuyst → cr3
Colin Watson (cjwatson) wrote :

Moving milestone forward. Marc, could you please respond with the feedback requested from you?

Marc Tardif (cr3) wrote :

The brightness buttons still don't work for the System76 Z35F running beta. I have attached the dmidecode output and /var/log/acpid when pressing the brightness buttons. Please note that showkey -u didn't return anything other than 0x9c.

Marc Tardif (cr3) wrote :
Marc Tardif (cr3) wrote :

Actually, to follow up on my previous message, nothing is generated at all in /var/log/acpid when pressing the brightness buttons.

Brian Murray (brian-murray) wrote :

Was this system tested with Feisty at all? If so did it used to work? Thanks again.

Tomas Šiaulys (tosi) wrote :

Brightness works fine for me on Asus Z35F out of the box. Other problems I've faced were that I had to specify "model=asus" for snd-hda-intel module and that bluetooth doesn't seem to work too (Asus bt-183).

Tomas Šiaulys (tosi) wrote :

Hm... Bluetooth seems to work too, so the only thing I needed to change was audio.

komputes (komputes) wrote :

I am currently using the system76 Z35Fm and I find that the Fn+F5 (Brightness Minus - Dark Sun) and Fn+F6 (Brightness Plus - Bright Sun).

I was looking for the keycode for these two combinations.
I have followed the wiki - https://wiki.ubuntu.com/LaptopTestingTeam/HotkeyResearch to find out what the ErrorLevel/KeyCode was for these two combinations.

====
Result
====

Method 1:
The Keyboard shortcuts do not produce any response to the combinations.

Method 2:
Through the terminal screen, I tried running the "showkey" command and ended up getting 0x9c (return key release) for both combinations.

Method 3:
Since I am unable to get a keycode I tried going low level and getting an APCI event generated from these combinations. Using the "tail" command, I got frustrated from the lack of response I got. I'm guessing that the even was not received by the kernel.

Laptop Identification:
ASUSTeK Computer Inc.
Z35FM
1.0

By asking around I found that this may be caused by a buggy DSDT file (which may need to be manually configured for this machine). I wanted to check if there was an update to DSDT from system76, so I checked the knowledge76.com wiki and found that the system76 driver is not installed on this particular machine (recognizable by looking for System>Administration>System76*).

See:
http://knowledge76.com/index.php/System76_Driver
http://knowledge76.com/index.php/Restoring_Your_System

Will try downloading and installing http://planet76.com/repositories/system76-driver-2.1.1.deb
Will report with changes.

komputes (komputes) wrote :

system76-driver deb package installed
driver recognizes system type and codename (Darter Ultra)
39 updates followed through Update Manager

After Restart, Fn+F5 and Fn+F6 still do not work

Parallel discussion on system76 forums (meanwhile, trying to find workaround)
http://system76.com/forums/viewtopic.php?p=7519#7519

komputes (komputes) wrote :

The bug is explained here: https://bugs.launchpad.net/system76/+bug/114677

Download the following and follow instructions to BIOS update. Brightness keys should work well afterwards.

http://launchpadlibrarian.net/7835209/Sys76_BootImage
http://launchpadlibrarian.net/7835211/AFLASH2.EXE
http://launchpadlibrarian.net/7835215/Z35FAG.305

**Please backup any files on your USB pen drive that you want to keep. This process will completely reformat the drive.**

1. Download to your desktop the three files attached to this bug report (unfortunately, I can only seem to attach one per entry, so see the following entries for the other two). The attachments are: Sys76_BootImage , AFLASH2.EXE , Z35AG.305.

2. In a terminal, type: tail -f /var/log/syslog

3. Insert a USB pen drive

4. In the terminal, syslog will give you the /dev/* path of your USB pen drive. Record it. For a Darter, it will probably be /dev/sdb1. It is of the utmost importance that you record this path correctly. Failure to do so likely will hose your computer and reduce you to a slobbering cry-baby. (But don't worry. If you hose it, we're here for you.)

5. BEFORE YOU HIT ENTER, READ THIS ENTIRE STEP!
In a terminal, type:
dd if=~/Desktop/Sys76_BootImage of=/dev/sdb bs=1M
NOTICE that I omitted the number from the USB path (i.e. /dev/sdb instead of /dev/sdb1). ALSO, if you recorded something other than /dev/sdb in step #3, you should substitute your recorded path (minus the number) for /dev/sdb. In other words, type:
dd if=~/Desktop/Sys76_BootImage of=<your usb path minus the number> bs=1M

6. Right-click on the USB pen drive icon on your desktop and select EJECT.

7. Remove the USB pen drive from your computer and re-insert it. It should auto-mount and open a file browser showing you its contents.

8. Drag-and-drop AFLASH2.EXE and Z35FAG.305 into the file browser. Then close the file browser.

9. Right-click on the USB pen drive icon on your desktop and select EJECT.

10. Restart your computer. When the INTEL screen appears, press ESCAPE.

11. Using your arrow keys, highlight your USB pen drive and Press Enter.

12. When you get the A:\> prompt, type the following and press enter:
aflash2 z35fag

13. Type "2" (without the quotes) and press enter.

14. Type "z35fag.305" (without the quotes) and press enter.

15. Press "Y"

16. When the process has completed, press your spacebar. Remove the USB pen drive. Press Ctrl-Alt-Delete and let your computer reboot.

17. You will then see the American Megatrends screen, which will give you a "CMOS Checksum Bad" message. Don't sweat it. It's the last time you'll ever see it. Press F1 to continue booting.

18. Enjoy the use of your LCD brightness keys (Fn-F5 and Fn-F6).

komputes (komputes) on 2008-05-05
Changed in hotkey-setup:
status: Incomplete → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Bug attachments