[SRU] refresh memcached static assets after upgrade

Bug #1802226 reported by Xav Paice on 2018-11-08
14
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Ubuntu Cloud Archive
Status tracked in Stein
Queens
Medium
Unassigned
Rocky
Medium
Unassigned
Stein
Medium
Unassigned
horizon (Ubuntu)
Medium
Seyeong Kim
Bionic
Medium
Unassigned
Cosmic
Medium
Unassigned
Disco
Medium
Seyeong Kim

Bug Description

[Impact]
After upgrading openstack-dashboard pkg,
Because compressed css file name has been changed,
UI is broken

affected B
UCA Q

keep testing the other releases and will update

flushing or restarting memcached on openstack-dashboard fixes this issue.

[Test Case]
1. deploy openstack env
2. install old pkg (e.g 13.0.1-0ubuntu1) on openstack-dashboard node
3. apt install openstack-dashboard(this means upgrading)
4. check web page

[Regression]
This patch flushes memcached's cache when installing pkg. It makes re-creating cache again so, it will be slow at first. Basically no effect to running cloud environment.

[Others]

[Original Description]
Using Queens on Xenial. We updated the packages to the current versions:

~$ apt-cache policy openstack-dashboard-ubuntu-theme
openstack-dashboard-ubuntu-theme:
  Installed: 3:13.0.1-0ubuntu3~cloud0
  Candidate: 3:13.0.1-0ubuntu3~cloud0
  Version table:
 *** 3:13.0.1-0ubuntu3~cloud0 500
        500 http://ubuntu-cloud.archive.canonical.com/ubuntu xenial-updates/queens/main amd64 Packages
        100 /var/lib/dpkg/status
     2:9.1.2-0ubuntu5 500
        500 http://archive.ubuntu.com/ubuntu xenial-updates/main amd64 Packages
     2:9.0.0-0ubuntu2 500
        500 http://archive.ubuntu.com/ubuntu xenial/main amd64 Packages

Using the Ubuntu theme results in a page full of garbage, missing css. The browser reports the following in consoles:

The requested URL /static/dashboard/css/6e9a9fafb1ba.css was not found on this server.

If I use other themes, it seems OK, just this one.

Xav Paice (xavpaice) on 2018-11-08
tags: added: canonical-bootstack
Xav Paice (xavpaice) wrote :

fwiw, setting Horizon to run with debug appears to allow things to work OK, but of course we don't want to leave it that way.

Seyeong Kim (xtrusia) wrote :

Hello Xav,

I reproduced this issue and found that restarting memcached fixes this issue.

After upgrading openstack-dashboard, compressed css file's name has changed.

but generated html still has old name. so this happens.

I'm going to check if we need to put script for restarting memcached on postinst script in deb pkg for this.

Thanks

tags: added: sts
Trent Lloyd (lathiat) wrote :

If restarting memcached fixes the issue, perhaps this is another instance of the fact the memcache caches are not shared.

Refer to existing bug for keystone:
https://bugs.launchpad.net/charm-keystone/+bug/1771114

Seyeong Kim (xtrusia) on 2018-11-12
description: updated
Seyeong Kim (xtrusia) wrote :
Seyeong Kim (xtrusia) wrote :
tags: added: sts-sru-needed

The attachment "lp1802226-queens.debdiff" seems to be a debdiff. The ubuntu-sponsors team has been subscribed to the bug report so that they can review and hopefully sponsor the debdiff. If the attachment isn't a patch, please remove the "patch" flag from the attachment, remove the "patch" tag, and if you are member of the ~ubuntu-sponsors, unsubscribe the team.

[This is an automated message performed by a Launchpad user owned by ~brian-murray, for any issue please contact him.]

tags: added: patch
Corey Bryant (corey.bryant) wrote :

I'd prefer to see this fixed with:

if which invoke-rc.d >/dev/null 2>&1; then
    invoke-rc.d memcached restart > /dev/null 2>&1 || true
else
    /etc/init.d/memcached restart > /dev/null 2>&1 || true
fi

Seyeong Kim (xtrusia) wrote :

Thanks corey
I'll test this soon and will update this.

Changed in horizon (Ubuntu):
assignee: nobody → Seyeong Kim (xtrusia)
Seyeong Kim (xtrusia) wrote :

Hey corey

I checked this is working with bionic and xenial-queens

Thanks

James Page (james-page) on 2018-11-22
Changed in horizon (Ubuntu):
status: New → In Progress
importance: Undecided → Medium
Corey Bryant (corey.bryant) wrote :

Hi Seyeong,

Did you test with the approach I mentioned in comment #7?

Thanks,
Corey

Seyeong Kim (xtrusia) wrote :

Hey corey

yes #9 is about it

sorry for making confusion

it worked fine with your script in post script

Thanks

Changed in horizon (Ubuntu Cosmic):
status: New → Triaged
Changed in horizon (Ubuntu Bionic):
status: New → Triaged
importance: Undecided → Medium
Changed in horizon (Ubuntu Cosmic):
importance: Undecided → Medium
summary: - upgrade to 13.0.1-0ubuntu3~cloud0 caused loss of css
+ refresh memcached static assets after upgrade
summary: - refresh memcached static assets after upgrade
+ [SRU] refresh memcached static assets after upgrade
Corey Bryant (corey.bryant) wrote :

This has been uploaded to disco, cosmic, and bionic and is awaiting SRU team review for cosmic and bionic.

Hello Xav, or anyone else affected,

Accepted horizon into bionic-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/horizon/3:13.0.1-0ubuntu4 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-bionic to verification-done-bionic. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-bionic. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance for helping!

N.B. The updated package will be released to -updates after the bug(s) fixed by this package have been verified and the package has been in -proposed for a minimum of 7 days.

Changed in horizon (Ubuntu Bionic):
status: Triaged → Fix Committed
tags: added: verification-needed verification-needed-bionic
Brian Murray (brian-murray) wrote :

Hello Xav, or anyone else affected,

Accepted horizon into cosmic-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/horizon/3:14.0.1-0ubuntu1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-cosmic to verification-done-cosmic. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-cosmic. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance for helping!

N.B. The updated package will be released to -updates after the bug(s) fixed by this package have been verified and the package has been in -proposed for a minimum of 7 days.

Changed in horizon (Ubuntu Cosmic):
status: Triaged → Fix Committed
tags: added: verification-needed-cosmic
Changed in cloud-archive:
status: Triaged → Fix Committed
Seyeong Kim (xtrusia) wrote :

Hello

verified bionic for this issue.

step to vefiry
1. deploy bionic env.
2. install old openstack-dashboard pkg on openstack-dashboard node
3. upgrade it to current version, and check if there is error ( there is )
4. upgrade -proposed version and check if there is error ( it is gone )

dpkg -l

root@node-10:~# dpkg -l | grep openstack-dashboard
ii openstack-dashboard 3:13.0.1-0ubuntu4 all Django web interface for OpenStack
root@node-10:~# dpkg -l | grep horizon
ii python-django-horizon 3:13.0.1-0ubuntu4 all Django module providing web based interaction with OpenStack

tags: added: verification-done-bionic
removed: verification-needed-bionic
Seyeong Kim (xtrusia) wrote :

It seems that cosmic-proposed failed to build.

Corey Bryant (corey.bryant) wrote :

Hello Xav, or anyone else affected,

Accepted horizon into queens-proposed. The package will build now and be available in the Ubuntu Cloud Archive in a few hours, and then in the -proposed repository.

Please help us by testing this new package. To enable the -proposed repository:

  sudo add-apt-repository cloud-archive:queens-proposed
  sudo apt-get update

Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-queens-needed to verification-queens-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-queens-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

tags: added: verification-queens-needed
Seyeong Kim (xtrusia) wrote :

Hello

I verified queens for this issue.

steps to verify
1. deploy queens env.
2. install old openstack-dashboard pkgs on openstack-dashboard node
3. restart memcached
4. upgrade it to current version, and check if there is error ( there is )
5. install -proposed pkg and check if there is error ( it is gone )

Thanks

dpkg -l | grep openstack-dashboard
ii openstack-dashboard 3:13.0.1-0ubuntu4~cloud0 all Django web interface for OpenStack
ii openstack-dashboard-ubuntu-theme 3:13.0.1-0ubuntu4~cloud0 all Transitional dummy package for Ubuntu theme for Horizon

tags: added: verification-queens-done
removed: verification-queens-needed
Łukasz Zemczak (sil2100) wrote :

Thank you for validating! A few questions: I see the fix for this is present in the horizon version in disco-proposed but the package seems to be stuck there since 19 days due to unsatisfiable depends. Before releasing any of the SRUs we'd have to make sure the fix in disco migrates. Also, the horizon version for cosmic FTBFS on amd64 and still needs verification.

Seyeong Kim (xtrusia) wrote :

@sil2100

for cosmic, I found that build is failed so I couldn't upgrade pkg on my test env.
(I tried this a week ago)
Could you please confirm it?
https://launchpad.net/ubuntu/+source/horizon/3:14.0.1-0ubuntu1

and for disco, Do I need to check dependency for disco? this fix includes only restarting script in post-inst

James Page (james-page) wrote :

Package has now built and published successfully - looks like some sort of buildd issue

Seyeong Kim (xtrusia) wrote :

Hello

I verified cosmic pkgs.

1. deploy cosmic env
2. I got some errors if I install old pkgs so I just tried to install newer version
3. In the middle of installing -proposed pkg(collecting and compressing static assets.. step), openstack-dashboard ui show us abnormal UI.
4. After finishing installation step, It is back to normal ( I think it is because proper script ran )

Thanks

dpkg -l | grep openstack-dashboard
ii openstack-dashboard 3:14.0.1-0ubuntu1 all Django web interface for OpenStack
ii openstack-dashboard-common 3:14.0.1-0ubuntu1 all Django web interface for OpenStack - common files
ii openstack-dashboard-ubuntu-theme 3:14.0.1-0ubuntu1 all Transitional dummy package for Ubuntu theme for Horizon

tags: added: verification-done-cosmic
removed: verification-needed-cosmic
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package horizon - 3:14.0.1-0ubuntu1

---------------
horizon (3:14.0.1-0ubuntu1) cosmic; urgency=medium

  * d/gbp.conf: Create stable/rocky branch.
  * d/openstack-dashboard.postinst: Ensure that if memcached is installed it is
    restarted in post-install script after collecting/compressing static assets,
    enabling refresh of memcached static assets after upgrade (LP: #1802226).
  * New stable point release for OpenStack Rocky (LP: #1806049).
  * d/p/add-enabled-check-in-backups-panel.patch: Dropped. Fixed in stable
    point release.

 -- Corey Bryant <email address hidden> Tue, 27 Nov 2018 14:17:30 -0500

Changed in horizon (Ubuntu Cosmic):
status: Fix Committed → Fix Released

The verification of the Stable Release Update for horizon has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package horizon - 3:13.0.1-0ubuntu4

---------------
horizon (3:13.0.1-0ubuntu4) bionic; urgency=medium

  * d/openstack-dashboard.postinst: Ensure that if memcached is installed it is
    restarted in post-install script after collecting/compressing static assets,
    enabling refresh of memcached static assets after upgrade (LP: #1802226).

 -- Corey Bryant <email address hidden> Tue, 27 Nov 2018 14:22:30 -0500

Changed in horizon (Ubuntu Bionic):
status: Fix Committed → Fix Released
Łukasz Zemczak (sil2100) wrote :

So I guess I released these two SRUs a bit too hastily as it seems horizon in disco-proposed is still stuck. Seeing update_excuses, it doesn't migrate for this reason:

python3-django-horizon/amd64 unsatisfiable Depends: python3-django-debreach
python3-django-openstack-auth/amd64 unsatisfiable Depends: python3-django-debreach (>= 1.4.2)

Could someone take a look at that and make sure the disco horizon migrates to release? Thanks!

James Page (james-page) wrote :

The verification of the Stable Release Update for horizon has completed successfully and the package has now been released to -updates. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

James Page (james-page) wrote :

This bug was fixed in the package horizon - 3:14.0.1-0ubuntu1~cloud0
---------------

 horizon (3:14.0.1-0ubuntu1~cloud0) bionic-rocky; urgency=medium
 .
   * New upstream release for the Ubuntu Cloud Archive.
 .
 horizon (3:14.0.1-0ubuntu1) cosmic; urgency=medium
 .
   * d/gbp.conf: Create stable/rocky branch.
   * d/openstack-dashboard.postinst: Ensure that if memcached is installed it is
     restarted in post-install script after collecting/compressing static assets,
     enabling refresh of memcached static assets after upgrade (LP: #1802226).
   * New stable point release for OpenStack Rocky (LP: #1806049).
   * d/p/add-enabled-check-in-backups-panel.patch: Dropped. Fixed in stable
     point release.

Corey Bryant (corey.bryant) wrote :

@sil2100 disco migration is awaiting security MIR review: https://bugs.launchpad.net/ubuntu/+source/python-django-debreach/+bug/1805690

Corey Bryant (corey.bryant) wrote :

The verification of the Stable Release Update for horizon has completed successfully and the package has now been released to -updates. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

Corey Bryant (corey.bryant) wrote :

This bug was fixed in the package horizon - 3:13.0.1-0ubuntu4~cloud0
---------------

 horizon (3:13.0.1-0ubuntu4~cloud0) xenial-queens; urgency=medium
 .
   * New update for the Ubuntu Cloud Archive.
 .
 horizon (3:13.0.1-0ubuntu4) bionic; urgency=medium
 .
   * d/openstack-dashboard.postinst: Ensure that if memcached is installed it is
     restarted in post-install script after collecting/compressing static assets,
     enabling refresh of memcached static assets after upgrade (LP: #1802226).

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package horizon - 3:15.0.0~b2~git2019013121.d11ab7b28-0ubuntu1

---------------
horizon (3:15.0.0~b2~git2019013121.d11ab7b28-0ubuntu1) disco; urgency=medium

  * New upstream snapshot for OpenStack Stein.
  * d/p/ubuntu_settings.patch: Rebased.

 -- Corey Bryant <email address hidden> Thu, 31 Jan 2019 21:02:43 -0500

Changed in horizon (Ubuntu Disco):
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers